Commit 1f02ef32 authored by Matthias Clasen's avatar Matthias Clasen

gio: Move gmodule to Requires.private

Users of GIO are not generally expected to use gmodule API,
so don't force them all to link against it.
parent c4a11858
......@@ -9,7 +9,8 @@ glib_compile_schemas=@bindir@/glib-compile-schemas@EXEEXT@
Name: GIO
Description: glib I/O library
Version: @VERSION@
Requires: glib-2.0,gobject-2.0,gmodule-no-export-2.0
Requires: glib-2.0,gobject-2.0
Requires.private: gmodule-no-export-2.0
Libs: -L${libdir} -lgio-2.0
Libs.private: @ZLIB_LIBS@ @NETWORK_LIBS@
Cflags:
Cflags:
......@@ -6,6 +6,6 @@ includedir=@includedir@
Name: GIO unix specific APIs
Description: unix specific headers for glib I/O library
Version: @VERSION@
Requires: gobject-2.0,gmodule-no-export-2.0,gio-2.0
Requires: gobject-2.0,gio-2.0
Libs: -L${libdir} -lgio-2.0
Cflags: -I${includedir}/gio-unix-2.0/
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment