Commit 9cc21bef authored by Michael Catanzaro's avatar Michael Catanzaro

Disable building PKCS#11 backend by default

This backend has never been enabled at runtime, except when the
GIO_USE_TLS=gnutls-pkcs11 environment variable is set. I'm quite
uncertain as to whether it should continue to exist or not. So let's
disable it. If nobody complains, I'll probably delete the code, but
let's keep the code around for now to be on the safe side.

https://bugzilla.gnome.org/show_bug.cgi?id=793281
parent 3c2b5da2
option('libproxy_support', type: 'boolean', value: true, description: 'support for libproxy proxy configration')
option('gnome_proxy_support', type: 'boolean', value: true, description: 'support for GNOME desktop proxy configuration')
option('pkcs11_support', type: 'boolean', value: true, description: 'support for PKCS#11 using p11-kit')
option('pkcs11_support', type: 'boolean', value: false, description: 'support for PKCS#11 using p11-kit')
option('installed_tests', type: 'boolean', value: false, description: 'enable installed tests')
option('static_modules', type: 'boolean', value: false, description: 'build static modules')
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment