Commit 6f4fb567 authored by Juan Pablo Ugarte's avatar Juan Pablo Ugarte
Browse files

Python plugin: fix linking error

Since pygobject 3.8 we need to link with python-3.8-embed to avoid
missing symbols when loading the plugin.

Fix compiler warning
parent ba841dbc
......@@ -138,7 +138,7 @@ pygobject_version = '3.8.0'
pygobject_dep = dependency('pygobject-3.0', version: '>= ' + pygobject_version, required: get_option('python'))
have_python = pygobject_dep.found()
if have_python
python_dep = import('python').find_installation().dependency()
python_dep = dependency('python-3.8-embed', version: '>= 3.8')
version_array = pygobject_version.split('.')
config_h.set('PYGOBJECT_REQUIRED_MAJOR', version_array[0].to_int())
......
......@@ -110,7 +110,7 @@ glade_python_setup ()
if (PyErr_Occurred ())
{
PyObject *ptype, *pvalue, *ptraceback, *pstr;
char *pvalue_char = "";
const char *pvalue_char = "";
PyErr_Fetch (&ptype, &pvalue, &ptraceback);
PyErr_NormalizeException (&ptype, &pvalue, &ptraceback);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment