1. 06 Aug, 2019 1 commit
  2. 05 Aug, 2019 1 commit
  3. 14 Jul, 2018 1 commit
  4. 22 Mar, 2018 1 commit
  5. 14 Nov, 2017 1 commit
    • Jehan's avatar
      Bug 790261 - autogen.sh non-portable use of echo -n. · d6c72d0f
      Jehan authored
      The reporter notes in particular that the -n option does not work
      appropriately on recent versions of macOS.
      From what I know, echo without any option is the most portable. But when
      options are needed, there are too many variants of the command out
      there, and printf becomes more reliable and consistent across platforms.
      It is more recent than echo and therefore non-portable for very very old
      platforms, but let's assume/hope that it old-enough for not being a
      problem anymore.
      d6c72d0f
  6. 24 Mar, 2017 1 commit
    • Jehan's avatar
      autogen: fix and improve automake/aclocal detection. · 8df8cd03
      Jehan authored
      Forgot to edit the first test in commit 6cf26410. If automake/aclocal
      1.11 was installed, autogen.sh breaks, even though other higher versions
      are installed too, because it is the first test.
      Actually I'm not sure I understand this first test. Is it like the
      "preferred" automake version?
      Also add a test for generic `automake` binary in order to handle newer
      versions. Thanks to Éric Hoffman for this proposition.
      8df8cd03
  7. 23 Mar, 2017 1 commit
    • Jehan's avatar
      Bug 780270 - MinGW build fail on Windows (broken m4 macro). · 6cf26410
      Jehan authored
      BUILD_EXEEXT was not properly set (config macro AX_PROG_CC_FOR_BUILD).
      Apparently we need aclocal/automake version 1.13 or higher and to
      distribute ax_prog_cc_for_build.m4 ourselves to benefit from a fix
      released only in autoconf 2.69.
      Thanks to Éric Hoffman for reporting and investigating on this.
      
      Automake 1.13 apparently dates from 2012 and debian testing provides
      a newer version (automake 1.15) so it should be ok to update it. Also
      that's only a build dependency.
      6cf26410
  8. 24 Jan, 2015 1 commit
  9. 07 Nov, 2014 1 commit
  10. 26 Jun, 2013 1 commit
  11. 06 Jan, 2013 1 commit
  12. 10 Sep, 2012 1 commit
  13. 06 May, 2012 1 commit
  14. 09 Nov, 2011 1 commit
  15. 12 Sep, 2011 1 commit
  16. 14 Apr, 2011 1 commit
  17. 10 Aug, 2009 1 commit
  18. 28 Jun, 2009 1 commit
  19. 25 Apr, 2009 1 commit
  20. 13 Jan, 2009 1 commit
  21. 11 Aug, 2008 1 commit
    • Sven Neumann's avatar
      Please re-run autogen.sh after this update, and let me know if there are · e8164033
      Sven Neumann authored
      2008-08-11  Sven Neumann  <sven@gimp.org>
      
      	Please re-run autogen.sh after this update, and let me know if
      	there are any problems.
      
      	* po-*/Makefile.in.in: updated to a version that does not 
      require
      	mkinstalldirs to be present.
      
      	* autogen.sh: removed the call to glib-gettextize and call
      	intltoolize without the --force command-line option. This change
      	makes an end to the po/Makefile.in.in being overwritten.
      
      	* HACKING: changed the documentation accordingly.
      
      
      svn path=/trunk/; revision=26500
      e8164033
  22. 11 Jun, 2008 1 commit
    • Sven Neumann's avatar
      bumped INTLTOOL_REQUIRED_VERSION to 0.35.5. We actually need 0.40.0 on the · acba2bc3
      Sven Neumann authored
      2008-06-11  Sven Neumann  <sven@gimp.org>
      
      	* autogen.sh: bumped INTLTOOL_REQUIRED_VERSION to 0.35.5. We
      	actually need 0.40.0 on the system where the tarball is rolled,
      	however 0.35.5 should be good enough for almost everyone.
      
      	* configure.in: use IT_PROG_INTLTOOL with minimum version instead
      	of the deprecated AC_PROG_INTLTOOL.
      
      	* Makefile.am (EXTRA_DIST): removed intltool-foo.in files as
      	intltool 0.40.0 does not install these any longer. Removed them
      	from DISTCLEANFILES as well.
      
      svn path=/trunk/; revision=25921
      acba2bc3
  23. 23 May, 2008 1 commit
    • Sven Neumann's avatar
      require glib-gettextize 2.16. · 73e717eb
      Sven Neumann authored
      2008-05-23  Sven Neumann  <sven@gimp.org>
      
      	* autogen.sh (GLIB_REQUIRED_VERSION): require glib-gettextize 2.16.
      
      	* libgimp/libgimp-intl.h
      	* plug-ins/pygimp/pygimp-intl.h: synced with gi18n-lib.h from glib
      	2.16. This adds support for the C_() macro.
      
      	* plug-ins/script-fu/script-fu-intl.h: just include gi18n.h instead
      	of duplicating things from this header.
      
      svn path=/trunk/; revision=25775
      73e717eb
  24. 21 Nov, 2007 1 commit
  25. 21 May, 2007 1 commit
    • Sven Neumann's avatar
      also look for automake-1.10. · 4e2a8c5a
      Sven Neumann authored
      2007-05-21  Sven Neumann  <sven@gimp.org>
      
      	* autogen.sh: also look for automake-1.10.
      
      
      svn path=/trunk/; revision=22553
      4e2a8c5a
  26. 20 Jan, 2007 1 commit
  27. 02 Mar, 2006 3 commits
  28. 31 Jan, 2006 1 commit
  29. 29 Jan, 2006 1 commit
  30. 07 Dec, 2005 1 commit
  31. 06 Dec, 2005 1 commit
  32. 19 Sep, 2005 1 commit
  33. 11 Jun, 2005 1 commit
  34. 07 Feb, 2005 1 commit
  35. 20 Jan, 2005 1 commit
    • Sven Neumann's avatar
      HACKING Makefile.am acinclude.m4 applied (modified) patch from Raphaël · e0a6c255
      Sven Neumann authored
      2005-01-20  Sven Neumann  <sven@gimp.org>
      
      	* HACKING
      	* Makefile.am
      	* acinclude.m4
      	* autogen.sh: applied (modified) patch from Raphaël Quinet that
      	allows to build GIMP from CVS without having gtk-doc installed.
      	If you need to do this, pass --disable-gtk-doc to autogen.sh.
      
      	* configure.in: removed --disable-devel-docs option since it has
      	become obsolete now.
      
      	* devel-docs/Makefile.am: require gtk-doc when running 'make dist'.
      e0a6c255
  36. 17 Dec, 2004 1 commit
  37. 13 Dec, 2004 2 commits