Commit fe8b81d8 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

check for pkg-config (>= 0.7)

2001-07-25  Sven Neumann  <sven@gimp.org>

	* configure.in: check for pkg-config (>= 0.7)

	* gimptool-1.4.in: use pkg-config instead of glib-config and
	gtk-config.
parent e5949e43
2001-07-25 Sven Neumann <sven@gimp.org>
* configure.in: check for pkg-config (>= 0.7)
* gimptool-1.4.in: use pkg-config instead of glib-config and
gtk-config.
2001-07-25 Sven Neumann <sven@gimp.org>
* app_procs.c
......
......@@ -91,6 +91,16 @@ ALL_LINGUAS="ca cs da de en_GB es fi fr ga gl hu hr it ja ko nl no pl pt_BR ro r
AM_GNU_GETTEXT
dnl Find pkg-config
AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
if test x$PKG_CONFIG = xno ; then
AC_MSG_ERROR([*** pkg-config not found. See http://pkgconfig.sourceforge.net])
fi
if ! pkg-config --atleast-pkgconfig-version 0.7 ; then
AC_MSG_ERROR([*** pkg-config too old; version 0.7 or better required.])
fi
dnl Check for GTK+
AM_PATH_GTK_2_0(1.3.7,,
AC_MSG_ERROR(Test for GTK failed. See the file 'INSTALL' for help.))
......@@ -738,6 +748,8 @@ AC_SUBST(LT_AGE)
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
AC_SUBST(PKG_CONFIG)
AC_SUBST(HAVE_GLIBC_REGEX)
AC_SUBST(gimpdir)
......
......@@ -89,20 +89,16 @@ if test $# -eq 0; then
usage 1
fi
if test x${GTK_CONFIG+set} != xset ; then
if test x${PKG_CONFIG+set} != xset ; then
gtk_cflags='@GTK_CFLAGS@'
gtk_libs='@GTK_LIBS@'
else
gtk_cflags=`$GTK_CONFIG --cflags`
gtk_libs=`$GTK_CONFIG --libs`
fi
if test x${GLIB_CONFIG+set} != xset ; then
glib_cflags='@GLIB_CFLAGS@'
glib_libs='@GLIB_LIBS@'
else
glib_cflags=`$GLIB_CONFIG --cflags`
glib_libs=`$GLIB_CONFIG --libs`
gtk_cflags=`$PKG_CONFIG --cflags gtk+-2.0`
gtk_libs=`$PKG_CONFIG --libs gtk+-2.0`
glib_cflags=`$PKG_CONFIG --cflags glib-2.0`
glib_libs=`$PKG_CONFIG --libs glib-2.0`
fi
if test x${INSTALL+set} != xset ; then
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment