Commit fb57133d authored by Jehan's avatar Jehan

INSTALL, configure: replace Jasper with OpenJPEG.

Just realizing we haven't updated the INSTALL file with the dependency
change.
parent ddeff314
...@@ -103,7 +103,7 @@ header files installed. ...@@ -103,7 +103,7 @@ header files installed.
12. You may want to install other third party libraries or programs 12. You may want to install other third party libraries or programs
that are needed for some of the available plug-ins. We recommend that are needed for some of the available plug-ins. We recommend
to check that the following libraries are installed: libjasper, to check that the following libraries are installed: openjpeg,
webkit, libmng, librsvg, libwmf, libaa and libgs (Ghostscript). webkit, libmng, librsvg, libwmf, libaa and libgs (Ghostscript).
13. HEIF support depends on the libheif library. If you don't have 13. HEIF support depends on the libheif library. If you don't have
...@@ -176,13 +176,13 @@ header files installed. ...@@ -176,13 +176,13 @@ header files installed.
gs - ghostscript gs - ghostscript
libaa - ASCII art libaa - ASCII art
libheif @LIBHEIF_REQUIRED_VERSION@ HEIF libheif @LIBHEIF_REQUIRED_VERSION@ HEIF
libjasper - JPEG 2000
libmng - MNG libmng - MNG
libwebp @WEBP_REQUIRED_VERSION@ WebP (built with --enable-libwebpmux and --enable-libwebpdemux) libwebp @WEBP_REQUIRED_VERSION@ WebP (built with --enable-libwebpmux and --enable-libwebpdemux)
libwmf @WMF_REQUIRED_VERSION@ WMF libwmf @WMF_REQUIRED_VERSION@ WMF
libXcursor - X11 Mouse Cursor libXcursor - X11 Mouse Cursor
libxpm - XPM libxpm - XPM
openexr @OPENEXR_REQUIRED_VERSION@ OpenEXR openexr @OPENEXR_REQUIRED_VERSION@ OpenEXR
OpenJPEG @OPENJPEG_REQUIRED_VERSION@ JPEG 2000
python 2 @PYTHON2_REQUIRED_VERSION@ Python plug-ins python 2 @PYTHON2_REQUIRED_VERSION@ Python plug-ins
webkit @WEBKITGTK_REQUIRED_VERSION@ Help browser & webpage webkit @WEBKITGTK_REQUIRED_VERSION@ Help browser & webpage
......
...@@ -170,6 +170,7 @@ WMF_REQUIRED_VERSION=wmf_required_version ...@@ -170,6 +170,7 @@ WMF_REQUIRED_VERSION=wmf_required_version
POPPLER_REQUIRED_VERSION=poppler_required_version POPPLER_REQUIRED_VERSION=poppler_required_version
POPPLER_DATA_REQUIRED_VERSION=poppler_data_required_version POPPLER_DATA_REQUIRED_VERSION=poppler_data_required_version
OPENEXR_REQUIRED_VERSION=openexr_required_version OPENEXR_REQUIRED_VERSION=openexr_required_version
OPENJPEG_REQUIRED_VERSION=openjpeg_required_version
INTLTOOL_REQUIRED_VERSION=intltool_required_version INTLTOOL_REQUIRED_VERSION=intltool_required_version
PERL_REQUIRED_VERSION=perl_required_version PERL_REQUIRED_VERSION=perl_required_version
PYTHON2_REQUIRED_VERSION=python2_required_version PYTHON2_REQUIRED_VERSION=python2_required_version
...@@ -201,6 +202,7 @@ AC_SUBST(WMF_REQUIRED_VERSION) ...@@ -201,6 +202,7 @@ AC_SUBST(WMF_REQUIRED_VERSION)
AC_SUBST(POPPLER_REQUIRED_VERSION) AC_SUBST(POPPLER_REQUIRED_VERSION)
AC_SUBST(POPPLER_DATA_REQUIRED_VERSION) AC_SUBST(POPPLER_DATA_REQUIRED_VERSION)
AC_SUBST(OPENEXR_REQUIRED_VERSION) AC_SUBST(OPENEXR_REQUIRED_VERSION)
AC_SUBST(OPENJPEG_REQUIRED_VERSION)
AC_SUBST(INTLTOOL_REQUIRED_VERSION) AC_SUBST(INTLTOOL_REQUIRED_VERSION)
AC_SUBST(PERL_REQUIRED_VERSION) AC_SUBST(PERL_REQUIRED_VERSION)
AC_SUBST(PYTHON2_REQUIRED_VERSION) AC_SUBST(PYTHON2_REQUIRED_VERSION)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment