Commit f9752f39 authored by Jehan's avatar Jehan

meson: add a libmypaint < 1.4.0 warning.

Same as what I did for the configure script. Note that I break commits
in 2 to make the autotools commits easily backportable to gimp-2-10,
i.e. without any meson files.
parent 5da252ca
Pipeline #130517 passed with stages
in 45 minutes and 47 seconds
......@@ -352,6 +352,16 @@ lcms = dependency('lcms2', version: '>=2.8')
libmypaint = dependency('libmypaint', version: '>=1.3.0')
if not libmypaint.version().version_compare('>=1.4.0')
libmypaint_warning='''
libmypaint lower than version 1.4.0 is known to crash when
parsing MyPaint 2 brushes. Please update.
'''
warning(libmypaint_warning)
warnings += libmypaint_warning
endif
mypaint_brushes = dependency('mypaint-brushes-1.0', version: '>=1.3.0')
if relocatable_bundle
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment