Commit f11bf9ec authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

INSTALL allow to disable build of the poppler plug-in.

2005-09-13  Sven Neumann  <sven@gimp.org>

	* INSTALL
	* configure.in: allow to disable build of the poppler plug-in.
parent f114cd8b
2005-09-13 Sven Neumann <sven@gimp.org>
* INSTALL
* configure.in: allow to disable build of the poppler plug-in.
2005-09-13 Sven Neumann <sven@gimp.org>
* app/display/gimpdisplayshell-close.c (gimp_time_since): use
......
......@@ -47,10 +47,11 @@ header files installed.
fetch the tarball from
ftp://ftp.gnome.org/pub/gnome/sources/libart_lgpl/
5. You may want to install other third party libraries or programs that
are needed for some of the available plugins. We recommend to check
that the following libraries are installed: libpng, libjpeg,
libtiff, gimp-print (4.2.x), gtkhtml-2, libmng, librsvg, libwmf.
5. You may want to install other third party libraries or programs
that are needed for some of the available plugins. We recommend
to check that the following libraries are installed: libpng,
libjpeg, libpoppler, libtiff, gimp-print (4.2.x), gtkhtml-2,
libmng, librsvg, libwmf.
6. Configure the GIMP by running the `configure' script. You may want
to pass some options to it, see below.
......@@ -136,6 +137,9 @@ These are:
--without-lcms. If for some reason you want to build GIMP without
using lcms for color support, you can build with --without-lcms.
--without-poppler. If for some reason you don't want to build the PDF
import plug-in that uses libpoppler, you can use --without-poppler.
--with-gif-compression=[lzw|rle|none]. Allows to tune the compression
algorithm used by the GIF plug-in. If you are afraid of Unisys' LZW
patent (which should have expired in most countries by now), you
......
......@@ -1187,26 +1187,36 @@ AC_SUBST(LIBSVG)
# Check for libpoppler
######################
PKG_CHECK_MODULES(POPPLER, poppler-glib >= poppler_required_version gthread-2.0,
POPPLER='poppler$(EXEEXT)'
LIBPOPPLER=$POPPLER_LIBS
AC_DEFINE(HAVE_POPPLER, 1, [Define to 1 if libpoppler is available])
have_poppler=yes,
AC_MSG_WARN([*** PDF import will be by the postscript plugin (poppler or gthread not found) ***]))
AC_ARG_WITH(poppler,[ --without-poppler build without poppler support])
if test "x$with_poppler" != xno; then
PKG_CHECK_MODULES(POPPLER,
poppler-glib >= poppler_required_version gthread-2.0,
POPPLER='poppler$(EXEEXT)'
LIBPOPPLER=$POPPLER_LIBS
AC_DEFINE(HAVE_POPPLER, 1, [Define to 1 if libpoppler is available])
have_poppler=yes,
AC_MSG_WARN([*** PDF will be imported by the postscript plugin (libpoppler not found) ***]))
else
AC_MSG_WARN([*** PDF will be imported by the postscript plugin (libpoppler support disabled)])
fi
AC_SUBST(POPPLER)
AC_SUBST(LIBPOPPLER)
if $PKG_CONFIG --atleast-version=0.4 poppler-glib; then
AC_DEFINE(HAVE_POPPLER_0_4, 1,
[Define to 1 if libpoppler >= 0.4 is available])
fi
if test "x$have_poppler" = xyes; then
if $PKG_CONFIG --atleast-version=0.4 poppler-glib; then
AC_DEFINE(HAVE_POPPLER_0_4, 1,
[Define to 1 if libpoppler >= 0.4 is available])
fi
if $PKG_CONFIG --atleast-version=0.4.1 poppler-glib; then
AC_DEFINE(HAVE_POPPLER_0_4_1, 1,
[Define to 1 if libpoppler >= 0.4.1 is available])
if $PKG_CONFIG --atleast-version=0.4.1 poppler-glib; then
AC_DEFINE(HAVE_POPPLER_0_4_1, 1,
[Define to 1 if libpoppler >= 0.4.1 is available])
fi
fi
#################################################
# Check for gnome-vfs (and optionally libgnomeui)
#################################################
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment