Commit dbd9797a authored by Michael Natterer's avatar Michael Natterer

Switch to version 2.99/3.0 in a lot of places and depend on GTK+ 3.22

and lots of other newer libraries.
parent be7f9b43
......@@ -27,10 +27,10 @@
/cscope.files
/cscope.out
/depcomp
/gimp-2.0.pc
/gimp-3.0.pc
/gimp-zip
/gimpthumb-2.0.pc
/gimpui-2.0.pc
/gimpthumb-3.0.pc
/gimpui-3.0.pc
/git-version.h
/gtk-doc.make
/install-sh
......
......@@ -2,5 +2,5 @@
/Makefile.in
/.deps
/.libs
/gimp-debug-tool-2.0
/gimp-debug-tool-2.0.exe
/gimp-debug-tool-3.0
/gimp-debug-tool-3.0.exe
......@@ -118,8 +118,8 @@ static const gchar system_gimprc_header[] =
"documents the default values and shows what changes are possible.\n"
"\n"
"The variable ${gimp_dir} is set to the value of the environment "
"variable GIMP2_DIRECTORY or, if that is not set, the compiled-in "
"default value is used. If GIMP2_DIRECTORY is not an absolute path, "
"variable GIMP3_DIRECTORY or, if that is not set, the compiled-in "
"default value is used. If GIMP3_DIRECTORY is not an absolute path, "
"it is interpreted relative to your home directory.";
static void
......@@ -255,21 +255,21 @@ static const gchar *man_page_path =
".TP\n"
".I gimp_dir\n"
"The personal gimp directory which is set to the value of the environment\n"
"variable GIMP2_DIRECTORY or to @manpage_gimpdir@.\n"
"variable GIMP3_DIRECTORY or to @manpage_gimpdir@.\n"
".TP\n"
".I gimp_data_dir\n"
"Base for paths to shareable data, which is set to the value of the\n"
"environment variable GIMP2_DATADIR or to the compiled-in default value\n"
"environment variable GIMP3_DATADIR or to the compiled-in default value\n"
"@gimpdatadir@.\n"
".TP\n"
".I gimp_plug_in_dir\n"
"Base to paths for architecture-specific plug-ins and modules, which is set\n"
"to the value of the environment variable GIMP2_PLUGINDIR or to the\n"
"to the value of the environment variable GIMP3_PLUGINDIR or to the\n"
"compiled-in default value @gimpplugindir@.\n"
".TP\n"
".I gimp_sysconf_dir\n"
"Path to configuration files, which is set to the value of the environment\n"
"variable GIMP2_SYSCONFDIR or to the compiled-in default value \n"
"variable GIMP3_SYSCONFDIR or to the compiled-in default value \n"
"@gimpsysconfdir@.\n"
"\n";
......
......@@ -376,9 +376,9 @@ gui_get_initial_monitor (Gimp *gimp,
static gchar *
gui_sanity_check (void)
{
#define GTK_REQUIRED_MAJOR 2
#define GTK_REQUIRED_MINOR 24
#define GTK_REQUIRED_MICRO 10
#define GTK_REQUIRED_MAJOR 3
#define GTK_REQUIRED_MINOR 22
#define GTK_REQUIRED_MICRO 29
const gchar *mismatch = gtk_check_version (GTK_REQUIRED_MAJOR,
GTK_REQUIRED_MINOR,
......
......@@ -171,8 +171,8 @@ static gchar *
sanity_check_glib (void)
{
#define GLIB_REQUIRED_MAJOR 2
#define GLIB_REQUIRED_MINOR 54
#define GLIB_REQUIRED_MICRO 2
#define GLIB_REQUIRED_MINOR 56
#define GLIB_REQUIRED_MICRO 0
const gchar *mismatch = glib_check_version (GLIB_REQUIRED_MAJOR,
GLIB_REQUIRED_MINOR,
......@@ -204,8 +204,8 @@ static gchar *
sanity_check_cairo (void)
{
#define CAIRO_REQUIRED_MAJOR 1
#define CAIRO_REQUIRED_MINOR 12
#define CAIRO_REQUIRED_MICRO 2
#define CAIRO_REQUIRED_MINOR 14
#define CAIRO_REQUIRED_MICRO 0
if (cairo_version () < CAIRO_VERSION_ENCODE (CAIRO_REQUIRED_MAJOR,
CAIRO_REQUIRED_MINOR,
......@@ -234,8 +234,8 @@ static gchar *
sanity_check_pango (void)
{
#define PANGO_REQUIRED_MAJOR 1
#define PANGO_REQUIRED_MINOR 29
#define PANGO_REQUIRED_MICRO 4
#define PANGO_REQUIRED_MINOR 42
#define PANGO_REQUIRED_MICRO 0
const gchar *mismatch = pango_version_check (PANGO_REQUIRED_MAJOR,
PANGO_REQUIRED_MINOR,
......
......@@ -10,30 +10,30 @@ AC_PREREQ(2.54)
# devel-docs/libtool-instructions.txt
m4_define([gimp_major_version], [2])
m4_define([gimp_minor_version], [10])
m4_define([gimp_micro_version], [2])
m4_define([gimp_minor_version], [99])
m4_define([gimp_micro_version], [1])
m4_define([gimp_real_version],
[gimp_major_version.gimp_minor_version.gimp_micro_version])
m4_define([gimp_version], [gimp_real_version])
m4_define([gimp_interface_age], [2])
m4_define([gimp_interface_age], [0])
m4_define([gimp_binary_age],
[m4_eval(100 * gimp_minor_version + gimp_micro_version)])
# For overriding the version string. Comment out if not needed.
# m4_define([gimp_version], [2.10.0])
# m4_define([gimp_version], [2.99.1])
# This is the X.Y used in -lgimp-X.Y
m4_define([gimp_api_version], [2.0])
m4_define([gimp_api_version], [3.0])
# Versions used for apps, plugins, tools, pkg-config files, and data,
# as well as global and user prefs
m4_define([gimp_app_version], [2.10])
m4_define([gimp_plugin_version], [2.0])
m4_define([gimp_tool_version], [2.0])
m4_define([gimp_pkgconfig_version], [2.0])
m4_define([gimp_data_version], [2.0])
m4_define([gimp_sysconf_version], [2.0])
m4_define([gimp_user_version], [2.10])
m4_define([gimp_app_version], [2.99])
m4_define([gimp_plugin_version], [2.99])
m4_define([gimp_tool_version], [2.99])
m4_define([gimp_pkgconfig_version], [3.0])
m4_define([gimp_data_version], [2.99])
m4_define([gimp_sysconf_version], [2.99])
m4_define([gimp_user_version], [2.99])
m4_define([gimp_unstable],
m4_if(m4_eval(gimp_minor_version % 2), [1], [yes], [no]))
......@@ -48,19 +48,18 @@ m4_define([gegl_major_minor_version], [0.4])
m4_define([gegl_micro_version], [2])
m4_define([gegl_required_version],
[gegl_major_minor_version.gegl_micro_version])
m4_define([glib_required_version], [2.54.2])
m4_define([atk_required_version], [2.2.0])
m4_define([gtk_required_version], [2.24.10])
m4_define([gtk_win32_recommended_version], [2.24.32])
m4_define([glib_required_version], [2.56.0])
m4_define([atk_required_version], [2.4.0])
m4_define([gtk_required_version], [3.22.29])
m4_define([gdk_pixbuf_required_version], [2.30.8])
m4_define([cairo_required_version], [1.12.2])
m4_define([cairo_required_version], [1.14.0])
m4_define([cairo_pdf_required_version], [1.12.2])
m4_define([pangocairo_required_version], [1.29.4])
m4_define([pangocairo_required_version], [1.42.0])
m4_define([fontconfig_required_version], [2.12.4])
m4_define([freetype2_required_version], [2.1.7])
m4_define([harfbuzz_required_version], [0.9.19])
m4_define([gtkdoc_required_version], [1.0])
m4_define([webkit_required_version], [1.6.1])
m4_define([webkit_required_version], [2.4.11])
m4_define([alsa_required_version], [1.0.0])
m4_define([rsvg_required_version], [2.40.6])
m4_define([wmf_required_version], [0.2.8])
......@@ -223,7 +222,7 @@ AC_SUBST(LT_CURRENT_MINUS_AGE)
# gettext i18n support
GETTEXT_PACKAGE=gimp20
GETTEXT_PACKAGE=gimp30
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE",
[The prefix for our gettext translation domains.])
......@@ -775,8 +774,8 @@ LIBS=$gimp_save_LIBS
AC_PATH_XTRA
AM_PATH_GTK_2_0(gtk_required_version, :,
add_deps_error([gtk+-2.0 >= gtk_required_version],
AM_PATH_GTK_3_0(gtk_required_version, :,
add_deps_error([gtk+-3.0 >= gtk_required_version],
[Test for GTK+ failed.]))
AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
......@@ -785,37 +784,6 @@ if test "x$GTK_UPDATE_ICON_CACHE" = xno; then
[Could not find gtk-update-icon-cache in your PATH.])
fi
# GTK+ 2.26.0 will never be released, we keep the check around anyway
# because we will need it again after the switch to GTK+ 3.x
AC_MSG_CHECKING([if GTK+ is version 2.26.0 or newer (bogus placeholder check)])
if $PKG_CONFIG --atleast-version=2.26.0 gtk+-2.0; then
have_gtk_2_26=yes
else
have_gtk_2_26=no
fi
AC_MSG_RESULT($have_gtk_2_26)
# Windows platform have a few bugs with GTK+ < 2.24.32.
# In particular: broken shortcuts on non-latin locales.
# Also SVG icons will be broken, hence --enable-vector-icons cannot be used.
# Display a warning when necessary.
# See bugs 769550 and 781020.
have_recommended_gtk=""
if test "x$platform_win32" = "xyes"; then
PKG_CHECK_MODULES(RECOMMENDED_WIN32_GTK, gtk+-2.0 >= gtk_win32_recommended_version,
have_recommended_gtk="yes", have_recommended_gtk="no")
if test "x$have_recommended_gtk" = xno; then
have_recommended_gtk="
WARNING: Your GTK+ version is `$PKG_CONFIG --modversion gtk+-2.0`.
The recommended GTK+ version under Windows is $GTK_WIN32_RECOMMENDED_VERSION or over.
If you continue without updating GTK+, shortcuts won't work with
non-latin locales, and vector icons will be disabled."
else
have_recommended_gtk=""
fi
fi
PKG_CHECK_MODULES(GDK_PIXBUF, gdk-pixbuf-2.0 >= gdk_pixbuf_required_version,,
[add_deps_error([gdk-pixbuf-2.0 >= gdk_pixbuf_required_version])])
......@@ -1326,7 +1294,7 @@ fi
################################
# Check if building for GTK+-X11
gdk_target=`$PKG_CONFIG --variable=target gtk+-2.0`
gdk_target=`$PKG_CONFIG --variable=target gtk+-3.0`
have_libxmu="no (building for $gdk_target)"
......@@ -1734,7 +1702,7 @@ AC_ARG_WITH(webkit, [ --without-webkit don't build the help-browser and
have_webkit=no
if test "x$with_webkit" != xno; then
PKG_CHECK_MODULES(WEBKIT, webkit-1.0 >= webkit_required_version,
PKG_CHECK_MODULES(WEBKIT, webkitgtk-3.0 >= webkitgtk_required_version,
WEB_PAGE='web-page$(EXEEXT)'
have_webkit=yes,
have_webkit="no (WebKit not found)")
......@@ -2132,9 +2100,9 @@ AC_SUBST(MAIL)
gtk_mac_integration_ok=no
if test "x$platform_osx" != xno &&
test "x`$PKG_CONFIG --variable=target gtk+-2.0`" == "xquartz"; then
(echo `pkg-config --variable=targets gtk+-3.0` | grep quartz); then
PKG_CHECK_MODULES(GTK_MAC_INTEGRATION, gtk-mac-integration-gtk2 >= gtk_mac_integration_required_version,
PKG_CHECK_MODULES(GTK_MAC_INTEGRATION, gtk-mac-integration-gtk3 >= gtk_mac_integration_required_version,
gtk_mac_integration_ok=yes,
gtk_mac_integration_ok=no)
......@@ -2476,10 +2444,6 @@ if test "x$have_glib_2_43" != "xyes"; then
CPPFLAGS="${CPPFLAGS} -DG_DISABLE_DEPRECATED"
fi
if test "x$have_gtk_2_26" != "xyes"; then
CPPFLAGS="${CPPFLAGS} -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
fi
if test "x$have_pango_1_32" != "xyes"; then
CPPFLAGS="${CPPFLAGS} -DPANGO_DISABLE_DEPRECATED"
fi
......
/Makefile
/Makefile.in
/gimp-2.*.1
/gimprc-2.*.5
/gimptool-2.0.1
/gimp-2.99.1
/gimp-3.*.1
/gimprc-2.99.5
/gimprc-3.*.5
/gimptool-3.0.1
/Wilber.xcf
/Wilber_Construction_Kit.xcf
......@@ -151,24 +151,24 @@ GIMP respects a number of environment variables.
.B DISPLAY
to get the default host and display number.
.TP 8
.B GIMP2_DIRECTORY
.B GIMP3_DIRECTORY
to get the name of the personal GIMP directory. If unset @manpage_gimpdir@ is
used. If this is an absolute path, it is used as is. If it is a
relative path, it is taken to be a subdirectory of \fB$XDG_CONFIG_HOME\fP.
.TP 8
.B GIMP2_DATADIR
.B GIMP3_DATADIR
to get the base location for data files such as brushes and patterns.
If unset @gimpdatadir@ is used.
.TP 8
.B GIMP2_LOCALEDIR
.B GIMP3_LOCALEDIR
to get the base location for translations. If unset @gimplocaledir@
is used.
.TP 8
.B GIMP2_PLUGINDIR
.B GIMP3_PLUGINDIR
to get the base location for plug-ins and modules. If unset
@gimpplugindir@ is used.
.TP 8
.B GIMP2_SYSCONFDIR
.B GIMP3_SYSCONFDIR
to get the location of configuration files. If unset @gimpsysconfdir@
is used.
......
......@@ -1342,21 +1342,21 @@ There are a few variables that are pre-defined:
.TP
.I gimp_dir
The personal gimp directory which is set to the value of the environment
variable GIMP2_DIRECTORY or to @manpage_gimpdir@.
variable GIMP3_DIRECTORY or to @manpage_gimpdir@.
.TP
.I gimp_data_dir
Base for paths to shareable data, which is set to the value of the
environment variable GIMP2_DATADIR or to the compiled-in default value
environment variable GIMP3_DATADIR or to the compiled-in default value
@gimpdatadir@.
.TP
.I gimp_plug_in_dir
Base to paths for architecture-specific plug-ins and modules, which is set
to the value of the environment variable GIMP2_PLUGINDIR or to the
to the value of the environment variable GIMP3_PLUGINDIR or to the
compiled-in default value @gimpplugindir@.
.TP
.I gimp_sysconf_dir
Path to configuration files, which is set to the value of the environment
variable GIMP2_SYSCONFDIR or to the compiled-in default value
variable GIMP3_SYSCONFDIR or to the compiled-in default value
@gimpsysconfdir@.
.SH FILES
......
......@@ -8,8 +8,8 @@
# documents the default values and shows what changes are possible.
#
# The variable ${gimp_dir} is set to the value of the environment variable
# GIMP2_DIRECTORY or, if that is not set, the compiled-in default value is
# used. If GIMP2_DIRECTORY is not an absolute path, it is interpreted
# GIMP3_DIRECTORY or, if that is not set, the compiled-in default value is
# used. If GIMP3_DIRECTORY is not an absolute path, it is interpreted
# relative to your home directory.
# Sets the folder for temporary storage. Files will appear here during the
......
......@@ -175,13 +175,13 @@ gimp_env_init (gboolean plug_in)
* gimp_directory:
*
* Returns the user-specific GIMP settings directory. If the
* environment variable GIMP2_DIRECTORY exists, it is used. If it is
* environment variable GIMP3_DIRECTORY exists, it is used. If it is
* an absolute path, it is used as is. If it is a relative path, it
* is taken to be a subdirectory of the home directory. If it is a
* relative path, and no home directory can be determined, it is taken
* to be a subdirectory of gimp_data_directory().
*
* The usual case is that no GIMP2_DIRECTORY environment variable
* The usual case is that no GIMP3_DIRECTORY environment variable
* exists, and then we use the GIMPDIR subdirectory of the local
* configuration directory:
*
......@@ -214,17 +214,17 @@ gimp_directory (void)
const gchar *env_gimp_dir;
env_gimp_dir = g_getenv ("GIMP2_DIRECTORY");
env_gimp_dir = g_getenv ("GIMP3_DIRECTORY");
if (gimp_dir)
{
gboolean gimp2_directory_changed = FALSE;
gboolean gimp3_directory_changed = FALSE;
/* We have constructed the gimp_dir already. We can return
* gimp_dir unless some parameter gimp_dir depends on has
* changed. For now we just check for changes to GIMP2_DIRECTORY
* changed. For now we just check for changes to GIMP3_DIRECTORY
*/
gimp2_directory_changed =
gimp3_directory_changed =
(env_gimp_dir == NULL &&
last_env_gimp_dir != NULL) ||
(env_gimp_dir != NULL &&
......@@ -233,7 +233,7 @@ gimp_directory (void)
last_env_gimp_dir != NULL &&
strcmp (env_gimp_dir, last_env_gimp_dir) != 0);
if (! gimp2_directory_changed)
if (! gimp3_directory_changed)
{
return gimp_dir;
}
......@@ -245,7 +245,7 @@ gimp_directory (void)
}
}
/* Remember the GIMP2_DIRECTORY to next invocation so we can check
/* Remember the GIMP3_DIRECTORY to next invocation so we can check
* if it changes
*/
g_free (last_env_gimp_dir);
......@@ -461,7 +461,7 @@ gimp_installation_directory (void)
* gimp_data_directory:
*
* Returns the top directory for GIMP data. If the environment
* variable GIMP2_DATADIR exists, that is used. It should be an
* variable GIMP3_DATADIR exists, that is used. It should be an
* absolute pathname. Otherwise, on Unix the compile-time defined
* directory is used. On Windows, the installation directory as deduced
* from the executable's full filename is used.
......@@ -485,7 +485,7 @@ gimp_data_directory (void)
GIMP_DATA_VERSION,
NULL);
gimp_data_dir = gimp_env_get_dir ("GIMP2_DATADIR", DATADIR, tmp);
gimp_data_dir = gimp_env_get_dir ("GIMP3_DATADIR", DATADIR, tmp);
g_free (tmp);
}
......@@ -496,7 +496,7 @@ gimp_data_directory (void)
* gimp_locale_directory:
*
* Returns the top directory for GIMP locale files. If the environment
* variable GIMP2_LOCALEDIR exists, that is used. It should be an
* variable GIMP3_LOCALEDIR exists, that is used. It should be an
* absolute pathname. Otherwise, on Unix the compile-time defined
* directory is used. On Windows, the installation directory as deduced
* from the executable's full filename is used.
......@@ -522,7 +522,7 @@ gimp_locale_directory (void)
"locale",
NULL);
gimp_locale_dir = gimp_env_get_dir ("GIMP2_LOCALEDIR", LOCALEDIR, tmp);
gimp_locale_dir = gimp_env_get_dir ("GIMP3_LOCALEDIR", LOCALEDIR, tmp);
g_free (tmp);
#ifdef G_OS_WIN32
......@@ -545,7 +545,7 @@ gimp_locale_directory (void)
* gimp_sysconf_directory:
*
* Returns the top directory for GIMP config files. If the environment
* variable GIMP2_SYSCONFDIR exists, that is used. It should be an
* variable GIMP3_SYSCONFDIR exists, that is used. It should be an
* absolute pathname. Otherwise, on Unix the compile-time defined
* directory is used. On Windows, the installation directory as deduced
* from the executable's full filename is used.
......@@ -569,7 +569,7 @@ gimp_sysconf_directory (void)
GIMP_SYSCONF_VERSION,
NULL);
gimp_sysconf_dir = gimp_env_get_dir ("GIMP2_SYSCONFDIR", SYSCONFDIR, tmp);
gimp_sysconf_dir = gimp_env_get_dir ("GIMP3_SYSCONFDIR", SYSCONFDIR, tmp);
g_free (tmp);
}
......@@ -580,7 +580,7 @@ gimp_sysconf_directory (void)
* gimp_plug_in_directory:
*
* Returns the top directory for GIMP plug_ins and modules. If the
* environment variable GIMP2_PLUGINDIR exists, that is used. It
* environment variable GIMP3_PLUGINDIR exists, that is used. It
* should be an absolute pathname. Otherwise, on Unix the compile-time
* defined directory is used. On Windows, the installation directory as
* deduced from the executable's full filename is used.
......@@ -604,7 +604,7 @@ gimp_plug_in_directory (void)
GIMP_PLUGIN_VERSION,
NULL);
gimp_plug_in_dir = gimp_env_get_dir ("GIMP2_PLUGINDIR", PLUGINDIR, tmp);
gimp_plug_in_dir = gimp_env_get_dir ("GIMP3_PLUGINDIR", PLUGINDIR, tmp);
g_free (tmp);
}
......
......@@ -30,6 +30,8 @@
#include "gimp3migration.h"
#if 0
GtkWidget *
gtk_box_new (GtkOrientation orientation,
gint spacing)
......@@ -87,6 +89,9 @@ gtk_separator_new (GtkOrientation orientation)
return gtk_vseparator_new ();
}
#endif /* if 0 */
#if ! GTK_CHECK_VERSION (3, 3, 0)
gboolean
......
......@@ -33,6 +33,8 @@
* along. This file will be removed in GIMP 3.
*/
#if 0
GtkWidget * gtk_box_new (GtkOrientation orientation,
gint spacing);
GtkWidget * gtk_button_box_new (GtkOrientation orientation);
......@@ -43,6 +45,8 @@ GtkWidget * gtk_scrollbar_new (GtkOrientation orientation,
GtkAdjustment *adjustment);
GtkWidget * gtk_separator_new (GtkOrientation orientation);
#endif
typedef enum
{
......
......@@ -3,8 +3,8 @@
/.deps
/.libs
/kernelgen
/gimptool-2.0
/gimptool-2.0.exe
/gimptool-3.0
/gimptool-3.0.exe
/test-clipboard
/test-clipboard.exe
/invert-svg
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment