Commit daa5f9e6 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

HACKING require libtool version 1.5.0 or newer when building on Win32.

2003-09-03  Sven Neumann  <sven@gimp.org>

	* HACKING
	* autogen.sh: require libtool version 1.5.0 or newer when building
	on Win32. Completely untested but it should fix bug #120953.
parent 008e3e20
......@@ -7,7 +7,7 @@ to have the following packages (or newer versions) installed:
- ftp://ftp.gnu.org/gnu/autoconf/
* GNU automake 1.6
- ftp://ftp.gnu.org/gnu/automake/
* GNU libtool 1.3.4
* GNU libtool 1.3.4 (1.5.0 if you are compiling on Win32)
- ftp://ftp.gnu.org/gnu/libtool/
Fine GNU mirrors are listed at http://www.gnu.org/prep/ftp.html
......
......@@ -15,6 +15,7 @@ TEST_TYPE=-d
FILE=plug-ins
LIBTOOL_REQUIRED_VERSION=1.3.4
LIBTOOL_WIN32=1.5.0
AUTOCONF_REQUIRED_VERSION=2.54
AUTOMAKE_REQUIRED_VERSION=1.6
GLIB_REQUIRED_VERSION=2.0.0
......@@ -45,6 +46,17 @@ echo
DIE=0
OS=`uname -s`
case $OS in
*ygwin* | *ingw*)
echo "Looks like Win32, you will need libtool $LIBTOOL_WIN32 or newer."
echo
LIBTOOL_REQUIRED_VERSION=$LIBTOOL_WIN32
;;
esac
echo -n "checking for libtool >= $LIBTOOL_REQUIRED_VERSION ... "
if (libtoolize --version) < /dev/null > /dev/null 2>&1; then
VER=`libtoolize --version \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment