Commit d86fa542 authored by Marc Lehmann's avatar Marc Lehmann

changed order in library search path for the perl plug-in.

        * configure.in: changed order in library search path
        for the perl plug-in.
parent b0964a4c
Sun Oct 25 18:59:56 CET 1998 Marc Lehmann <pcg@goof.com>
* configure.in: changed order in library search path
for the perl plug-in.
Sat Oct 24 22:42:10 PDT 1998 Manish Singh <yosh@gimp.org>
* applied gimp-joke-981006-0, portabilty patch
......
......@@ -2,9 +2,9 @@ There are three basic steps to building and installing the
GIMP on unix:
1. You need to have installed GTK version 1.0.1 or better
2. You may want to install other third party libraries that
are needed for some of the available plugins: TIFF, PNG,
JPEG, MPEG, etc.
2. You may want to install other third party libraries or programs that
are needed for some of the available plugins: TIFF, PNG, JPEG, MPEG,
perl, etc.
3. Configure the GIMP by running the `configure' script.
4. Build the GIMP by running `make'.
5. Install the GIMP by running `make install'.
......@@ -29,7 +29,7 @@ The `configure' script examines your system, and adapts the GIMP to
run on it. The script has many options, some of which are described in
the generic instructions included at the end of this file. All of the
options can be listed using the command `./configure --help'. There
are six commands special options the GIMP `configure' script
are five commands special options the GIMP `configure' script
recognizes. These are:
1. --enable-shared and --disable-shared. This option affects whether
......@@ -53,6 +53,10 @@ recognizes. These are:
4. --enable-gimpdir=DIR. This option changes the default directory
the gimp uses to search for its configuration files from ~/.gimp (the
directory .gimp in the users home directory) to DIR.
5. --enable-perl and --disable-perl. The perl extension does not build on
all systems. If you experience problems use --disable-perl and gimp
will not even try to built it.
The `make' command builds several things:
- The libraries `libgimp/libgimp.la', `libgimp/libgimpi.la' and
......@@ -104,6 +108,13 @@ several reasons why this might fail:
Fix: remove the old libraries and include files.
* The perl extension does not detect all combinations of libraries and
packages it needs to built properly, causing compilation to stop
prematurely.
Fix: use configure with the "--disable-perl" switch or install perl
(version>=5.005) and the Perl-Gtk-interface.
A detailed log of the ./configure output is written to the file
config.log. This may help diagnose problems.
......
......@@ -31,6 +31,9 @@
/* Define if you have the vprintf function. */
#undef HAVE_VPRINTF
/* Define if you have the vsnprintf function. */
#undef HAVE_VSNPRINTF
/* Define as __inline if that's what the C compiler calls it. */
#undef inline
......@@ -80,7 +83,6 @@
#undef HAVE_SYS_SELECT_H
#undef HAVE_SYS_TIME_H
#undef HAVE_UNISTD_H
#undef HAVE_VPRINTF
#undef HAVE_XSHM_H
#undef IPC_RMID_DEFERRED_RELEASE
......@@ -173,3 +175,4 @@
/* Define if you have the i library (-li). */
#undef HAVE_LIBI
......@@ -9,6 +9,7 @@ SUBDIRS = \
@AA@ \
@JPEG@ \
@MPEG@ \
@GIMP_PERL@ \
@PNG@ \
@TIFF@ \
@WEBBROWSER@ \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment