Commit cef547b0 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

INSTALL bumped the required version of glib to 2.8.

2005-09-26  Sven Neumann  <sven@gimp.org>

	* INSTALL
	* configure.in: bumped the required version of glib to 2.8.

	* app/main.c: use G_OPTION_ARG_NONE flag with callback options
	that take no argument. Fixes command-line options needed for 'make
	dist', such as '--dump-gimprc'
parent 49a0a7a1
2005-09-26 Sven Neumann <sven@gimp.org>
* INSTALL
* configure.in: bumped the required version of glib to 2.8.
* app/main.c: use G_OPTION_ARG_NONE flag with callback options
that take no argument. Fixes command-line options needed for 'make
dist', such as '--dump-gimprc'
2005-09-26 Michael Natterer <mitch@gimp.org>
* plug-ins/script-fu/scripts/carve-it.scm
......
......@@ -29,11 +29,11 @@ header files installed.
from http://www.freedesktop.org/software/pkgconfig/.
2. You need to have installed GTK+ version 2.6.0 or newer. Do not
try to use an older GTK+ version (1.2.x), it will not work.
GTK+ itself needs recent versions of GLib (>= 2.6.0),
Pango (>= 1.8.0) and ATK. Sources for these can be grabbed from
ftp://ftp.gtk.org/. GTK+-2.x and friends can be installed side
by side with GTK+-1.2.
try to use an older GTK+ version (1.2.x), it will not work. GIMP
needs an even more recent version of GLib (>= 2.8.0). It also
wants Pango (>= 1.8.0) and ATK. Sources for these can be grabbed
from ftp://ftp.gtk.org/. GTK+-2.x and friends can be installed
side by side with GTK+-1.2.
3. We require PangoFT2, a Pango backend that uses FreeType2. Make
sure you have FreeType2 and fontconfig installed before you
......
......@@ -85,38 +85,38 @@ static void gimp_sigfatal_handler (gint sig_num) G_GNUC_NORETURN;
#endif
static const gchar *system_gimprc = NULL;
static const gchar *user_gimprc = NULL;
static const gchar *session_name = NULL;
static const gchar *batch_interpreter = NULL;
static const gchar **batch_commands = NULL;
static const gchar **filenames = NULL;
static gboolean no_interface = FALSE;
static gboolean no_data = FALSE;
static gboolean no_fonts = FALSE;
static gboolean no_splash = FALSE;
static gboolean be_verbose = FALSE;
static const gchar *system_gimprc = NULL;
static const gchar *user_gimprc = NULL;
static const gchar *session_name = NULL;
static const gchar *batch_interpreter = NULL;
static const gchar **batch_commands = NULL;
static const gchar **filenames = NULL;
static gboolean no_interface = FALSE;
static gboolean no_data = FALSE;
static gboolean no_fonts = FALSE;
static gboolean no_splash = FALSE;
static gboolean be_verbose = FALSE;
#if defined (USE_SYSV_SHM) || defined (USE_POSIX_SHM) || defined (G_OS_WIN32)
static gboolean use_shm = TRUE;
static gboolean use_shm = TRUE;
#else
static gboolean use_shm = FALSE;
static gboolean use_shm = FALSE;
#endif
static gboolean use_cpu_accel = TRUE;
static gboolean console_messages = FALSE;
static gboolean use_debug_handler = FALSE;
static gboolean use_cpu_accel = TRUE;
static gboolean console_messages = FALSE;
static gboolean use_debug_handler = FALSE;
#ifdef GIMP_UNSTABLE
static GimpStackTraceMode stack_trace_mode = GIMP_STACK_TRACE_QUERY;
static GimpPDBCompatMode pdb_compat_mode = GIMP_PDB_COMPAT_WARN;
static GimpStackTraceMode stack_trace_mode = GIMP_STACK_TRACE_QUERY;
static GimpPDBCompatMode pdb_compat_mode = GIMP_PDB_COMPAT_WARN;
#else
static GimpStackTraceMode stack_trace_mode = GIMP_STACK_TRACE_NEVER;
static GimpPDBCompatMode pdb_compat_mode = GIMP_PDB_COMPAT_ON;
static GimpStackTraceMode stack_trace_mode = GIMP_STACK_TRACE_NEVER;
static GimpPDBCompatMode pdb_compat_mode = GIMP_PDB_COMPAT_ON;
#endif
static const GOptionEntry main_entries[] =
{
{ "version", 'v', 0,
{ "version", 'v', G_OPTION_FLAG_NO_ARG,
G_OPTION_ARG_CALLBACK, (GOptionArgFunc) gimp_show_version,
N_("Show version information and exit"), NULL
},
......@@ -198,27 +198,27 @@ static const GOptionEntry main_entries[] =
N_("Debug in case of a crash (never|query|always)"), "<mode>"
},
{
"debug-handlers", 0, 0,
"debug-handlers", 0, G_OPTION_FLAG_NO_ARG,
G_OPTION_ARG_NONE, &use_debug_handler,
N_("Enable non-fatal debugging signal handlers"), NULL
},
{
"g-fatal-warnings", 0, 0,
"g-fatal-warnings", 0, G_OPTION_FLAG_NO_ARG,
G_OPTION_ARG_CALLBACK, gimp_option_fatal_warnings,
N_("Make all warnings fatal"), NULL
},
{
"dump-gimprc", 0, 0,
"dump-gimprc", 0, G_OPTION_FLAG_NO_ARG,
G_OPTION_ARG_CALLBACK, gimp_option_dump_gimprc,
N_("Output a gimprc file with default settings"), NULL
},
{
"dump-gimprc-system", 0, G_OPTION_FLAG_HIDDEN,
"dump-gimprc-system", 0, G_OPTION_FLAG_NO_ARG | G_OPTION_FLAG_HIDDEN,
G_OPTION_ARG_CALLBACK, gimp_option_dump_gimprc,
NULL, NULL
},
{
"dump-gimprc-manpage", 0, G_OPTION_FLAG_HIDDEN,
"dump-gimprc-manpage", 0, G_OPTION_FLAG_NO_ARG | G_OPTION_FLAG_HIDDEN,
G_OPTION_ARG_CALLBACK, gimp_option_dump_gimprc,
NULL, NULL
},
......
......@@ -40,7 +40,7 @@ m4_define([gimp_stable],
m4_define([gimp_full_name], [GNU Image Manipulation Program])
# required versions of other packages
m4_define([glib_required_version], [2.6.0])
m4_define([glib_required_version], [2.8.0])
m4_define([gtk_required_version], [2.6.0])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([pangoft2_required_version], [1.8.0])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment