Commit c6f42dda authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

set GIMP_VERSION to 2.0pre1.

2004-01-07  Sven Neumann  <sven@gimp.org>

        * configure.in: set GIMP_VERSION to 2.0pre1.

        * HACKING
        * INSTALL
        * NEWS
        * README: updated and changed accordingly.
parent 6d33e775
2004-01-07 Sven Neumann <sven@gimp.org>
* configure.in: set GIMP_VERSION to 2.0pre1.
* HACKING
* INSTALL
* NEWS
* README: updated and changed accordingly.
2004-01-07 Simon Budig <simon@gimp.org>
* app/gui/about-dialog.c: Changed the string that is intended
......@@ -5,7 +5,7 @@ to have the following packages (or newer versions) installed:
* GNU autoconf 2.52
- ftp://ftp.gnu.org/gnu/autoconf/
* GNU automake 1.6
* GNU automake 1.7 (1.6 will also work)
- ftp://ftp.gnu.org/gnu/automake/
* GNU libtool 1.3.4 (1.5.0 if you are compiling on Win32)
- ftp://ftp.gnu.org/gnu/libtool/
......@@ -13,10 +13,10 @@ to have the following packages (or newer versions) installed:
Fine GNU mirrors are listed at http://www.gnu.org/prep/ftp.html
Beta software can be found at alpha.gnu.org.
* pkg-config 0.7.0 (or a newer version)
* pkg-config 0.7.0 (or preferably a newer version)
- http://www.freedesktop.org/software/pkgconfig/
* intltoolize 0.17 (or a newer version)
* intltoolize 0.17 (or preferably a newer version)
- ftp://ftp.gnome.org/pub/gnome/sources/intltool/
These are only the additional requirements if you want to compile from
......
THIS IS A DEVELOPMENT VERSION OF THE GIMP!
If you are looking for the stable version, use GIMP 1.2. We do
however encourage you to try GIMP-1.3. Read on further to learn more
about the installation process...
however encourage you to try this GIMP-2.0 prerelease. Read on
further to learn more about the installation process...
There are some basic steps to building and installing the GIMP.
......@@ -12,7 +12,7 @@ are fulfilled. We depend on a number of tools and libraries which are
listed below. For libraries this means you need to also have the
header files installed.
Please note that GIMP-1.2 and GIMP-1.3 peacefully coexist. You don't
Please note that GIMP-1.2 and GIMP-1.3/2.0 peacefully coexist. You don't
need to deinstall the 1.2 version.
1. You need to have installed a recent version of pkg-config available
......
......@@ -7,8 +7,9 @@ GIMP 1.3 is the development branch of The GIMP. Here's where the
development takes place on the road to the next stable release
GIMP version 2.0.
Overview of Changes in GIMP 2.0 pre1
==================================
Overview of Changes in GIMP 2.0pre1
===================================
- Persistent user preferences for PNG save [Yosh]
- Replaced old "About" dialog [Simon]
- Allow removal of text attributes from text layer [Sven]
- Add optimisation option to png (clear transparent pixels) [Joao]
......
The GIMP: The GNU Image Manipulation Program
============================================
This is version 1.3, the developers version of The GIMP. Only use it
if you are brave and curious and want to participate development
towards the next stable release GIMP version 2.0. This is a developers
version. We know it has bugs and it might not even compile. You have
been warned!
This is a pre-release of GIMP version 2.0. Actually it still is GIMP-1.3,
the developers version of The GIMP. But we got pretty close to the final
2.0 release, the plug-in API has settled and you are encouraged to try
this software. Your feedback can help to make the 2.0 release a success.
If you encounter any problems, please report them to our bug-tracker at
bugzilla.gnome.org. There are still a number of known problems, so please
check first if your problem has already been reported.
Some features that were present in GIMP 1.2 are disabled or not even
included in this release. The perl bindings as well as all the perl
scripts are not any longer included in this source tree. They have
been moved into its own module called gimp-perl and await being
porting to GIMP-1.3 and GTK+-2.0.
GIMP-2.0 installs side-by-side with GIMP-1.2 so there's no need to
uninstall GIMP-1.2 (but sooner or later you will not be using it any
longer...).
The new text tool is only halfway done and various other tools and
functions are broken. Almost everything is under construction. Don't
even think about using this for daily work. If you are a software
distributor, dont' dare to ship this package to innocent users.
Some features that were present in GIMP 1.2 are not included in this
release. The perl bindings as well as all the perl scripts are not any
longer included in this source tree. They have been moved into its own
module called gimp-perl. Sooner or later there will be a gimp-perl
release for GIMP-2.0. GAP, a set of plug-ins that used to live in the
Video submenu has also become a separate package. Expect a preview
release of this software for GIMP-2.0 soon.
For installation instructions, see the file INSTALL.
For detailed installation instructions, see the file INSTALL.
1. Web Resources
......@@ -90,7 +93,7 @@ Many of the developers hang out there. One of the Byxnet servers are:
==============
The look of GIMP's interface can be customized like any other GTK app
by editing the ~/.gtkrc file or by using "themes" (ready-made
by editing the ~/.gtkrc-2.0 file or by using "themes" (ready-made
customizations). For downloadable themes and further details, see
http://gtk.themes.org. Additionally GIMP reads ~/.gimp-1.3/gtkrc so
you can have settings that only apply to The GIMP.
......@@ -101,27 +104,6 @@ to ~/.gimp-1.3/menurc. You can also manually change the keybindings to
any of your choice by editing ~/.gimp-1.3/menurc.
5. Bugs
=======
Since this is a developers version, we are at the moment not really
interested in receiving too many bug-reports. Some parts of the code
are unfinished and under heavy development and we know that.
Bug-reports for incomplete or missing are features are therefore often
not helpful. Instead of filing a bug you should try to contact the
person who is working on this particular part of the program (see the
ChangeLog) or try to fix it yourself. You should report crashes and
other severe bugs at Bugzilla (http://bugzilla.gnome.org/). Your
bug-report needs to provide detailed instruction of how to reproduce
the problem. For reports on crashes, please also include a stack
trace.
If you experience crashes whenever you try to start gimp-1.3, you are
most probably using gdkxft or another LD_PRELOAD hack designed for
gtk+-1.2. These hacks will not work with GTK+-2.0 applications like
this version of The GIMP.
Have fun,
Spencer Kimball
......@@ -130,3 +112,4 @@ Have fun,
Manish Singh
Sven Neumann
Michael Natterer
Dave Neary
......@@ -50,7 +50,8 @@ GIMP_MINOR_VERSION=3
GIMP_MICRO_VERSION=24
GIMP_INTERFACE_AGE=0
GIMP_BINARY_AGE=0
GIMP_VERSION=$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION.$GIMP_MICRO_VERSION
#GIMP_VERSION=$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION.$GIMP_MICRO_VERSION
GIMP_VERSION=2.0pre1
AC_SUBST(GIMP_MAJOR_VERSION)
AC_SUBST(GIMP_MINOR_VERSION)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment