Commit c0237467 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

INSTALL require GEGL >= 0.0.14.

2007-12-20  Sven Neumann  <sven@gimp.org>

	* INSTALL
	* configure.in: require GEGL >= 0.0.14.

	* app/Makefile.am
	* app/app.c: initialize the GEGL library.

svn path=/trunk/; revision=24413
parent 512af808
2007-12-20 Sven Neumann <sven@gimp.org>
* INSTALL
* configure.in: require GEGL >= 0.0.14.
* app/Makefile.am
* app/app.c: initialize the GEGL library.
2007-12-20 Sven Neumann <sven@gimp.org>
* app/paint/gimpink.c: minor cleanup.
......
......@@ -28,11 +28,14 @@ header files installed.
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need to have installed GTK+ version 2.12.1 or newer. GIMP
2. You need to have installed GEGL version 0.0.14 or newer.
The GEGL sources can be grabbed from ftp://ftp.gimp.org/pub/gegl/.
3. You need to have installed GTK+ version 2.12.1 or newer. GIMP
also need a recent versions of GLib (>= 2.14.1) and Pango (>= 1.12.2).
Sources for these can be grabbed from ftp://ftp.gtk.org/.
3. We require PangoFT2, a Pango backend that uses FreeType2. Make
4. We require PangoFT2, a Pango backend that uses FreeType2. Make
sure you have FreeType2 and fontconfig installed before you
compile Pango. FreeType2 can be downloaded from
http://www.freetype.org/. Fontconfig from
......@@ -41,30 +44,30 @@ header files installed.
Older versions are known to have bugs that seriously affect
stability of GIMP.
4. We use libart2. Grab the module libart_lgpl out of GNOME SVN or
5. We use libart2. Grab the module libart_lgpl out of GNOME SVN or
fetch the tarball from
ftp://ftp.gnome.org/pub/gnome/sources/libart_lgpl/
5. We use dbus-glib if available. Grab it from
6. We use dbus-glib if available. Grab it from
http://dbus.freedesktop.org/releases/dbus-glib/
6. You may want to install other third party libraries or programs
7. You may want to install other third party libraries or programs
that are needed for some of the available plugins. We recommend
to check that the following libraries are installed: libpng,
libjpeg, libpoppler, libtiff, gtkhtml-2, libmng, librsvg, libwmf.
7. The Python extension requires Python development headers to be
8. The Python extension requires Python development headers to be
present. You will also need PyGTK and the respective development
headers.
8. Configure GIMP by running the `configure' script. You may want
9. Configure GIMP by running the `configure' script. You may want
to pass some options to it, see below.
9. Build GIMP by running `make'. The use of GNU make is recommended.
10. Build GIMP by running `make'. The use of GNU make is recommended.
If you need to tweak the build to make it work with other flavours
of make, we'd appreciate if you'd send us a patch with the changes.
10. Install GIMP by running `make install'. In order to avoid clashes
11. Install GIMP by running `make install'. In order to avoid clashes
with other versions of GIMP, we install a binary called gimp-2.5.
By default there's also a link created so that you can type 'gimp'
to start gimp-2.5.
......
......@@ -84,6 +84,7 @@ INCLUDES = \
$(GTK_CFLAGS) \
$(PANGOFT2_CFLAGS) \
$(DBUS_GLIB_CFLAGS) \
$(GEGL_CFLAGS) \
-I$(includedir)
AM_LDFLAGS = $(mwindows) $(munix) \
......@@ -128,6 +129,7 @@ gimp_2_5_LDADD = \
$(FONTCONFIG_LIBS) \
$(FREETYPE_LIBS) \
$(DBUS_GLIB_LIBS) \
$(GEGL_LIBS) \
$(RT_LIBS) \
$(INTLLIBS) \
$(GIMPICONRC)
......@@ -170,7 +172,7 @@ gimp_console_2_5_LDADD = \
$(PANGOFT2_LIBS) \
$(FONTCONFIG_LIBS) \
$(FREETYPE_LIBS) \
$(GLIB_LIBS) \
$(GEGL_LIBS) \
$(RT_LIBS) \
$(INTLLIBS) \
$(GIMPICONRC)
......
......@@ -32,6 +32,8 @@
#include <glib-object.h>
#include <gegl.h>
#include "libgimpbase/gimpbase.h"
#include "libgimpconfig/gimpconfig.h"
......@@ -76,12 +78,12 @@ void
app_libs_init (GOptionContext *context,
gboolean no_interface)
{
if (no_interface)
{
g_type_init ();
}
g_option_context_add_group (context, gegl_get_option_group ());
#ifndef GIMP_CONSOLE_COMPILATION
else
if (! no_interface)
{
gui_libs_init (context);
}
......
......@@ -40,6 +40,7 @@ m4_define([gimp_stable],
m4_define([gimp_full_name], [GNU Image Manipulation Program])
# required versions of other packages
m4_define([gegl_required_version], [0.0.14])
m4_define([glib_required_version], [2.14.1])
m4_define([gtk_required_version], [2.12.1])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
......@@ -125,25 +126,8 @@ LT_CURRENT_MINUS_AGE=m4_eval(lt_current - lt_age)
AC_SUBST(LT_VERSION_INFO)
AC_SUBST(LT_CURRENT_MINUS_AGE)
GLIB_REQUIRED_VERSION=glib_required_version
GTK_REQUIRED_VERSION=gtk_required_version
GDK_PIXBUF_REQUIRED_VERSION=gdk_pixbuf_required_version
PANGOFT2_REQUIRED_VERSION=pangoft2_required_version
FONTCONFIG_REQUIRED_VERSION=fontconfig_required_version
GTKDOC_REQUIRED_VERSION=gtkdoc_required_version
GTKHTML2_REQUIRED_VERSION=gtkhtml2_required_version
RSVG_REQUIRED_VERSION=rsvg_required_version
WMF_REQUIRED_VERSION=wmf_required_version
AC_SUBST(GLIB_REQUIRED_VERSION)
AC_SUBST(GTK_REQUIRED_VERSION)
AC_SUBST(GDK_PIXBUF_REQUIRED_VERSION)
AC_SUBST(PANGOFT2_REQUIRED_VERSION)
AC_SUBST(FONTCONFIG_REQUIRED_VERSION)
AC_SUBST(GTKDOC_REQUIRED_VERSION)
AC_SUBST(GTKHTML2_REQUIRED_VERSION)
AC_SUBST(RSVG_REQUIRED_VERSION)
AC_SUBST(WMF_REQUIRED_VERSION)
# gettext i18n support
GETTEXT_PACKAGE=gimp20
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE",
......@@ -415,6 +399,11 @@ AM_GLIB_GNU_GETTEXT
# Checks for required libraries
###############################
PKG_CHECK_MODULES(GEGL, gegl >= gegl_required_version, :,
AC_MSG_ERROR([Test for GEGL failed. Please get it from http://gegl.org/]))
AM_PATH_GLIB_2_0(glib_required_version, :,
AC_MSG_ERROR(Test for GLIB failed. See the file 'INSTALL' for help.),
gobject gthread)
......@@ -429,6 +418,7 @@ else
fi
AC_MSG_RESULT($have_glib_2_17)
dnl Check for bind_textdomain_codeset, including -lintl if GLib brings it in.
gimp_save_LIBS=$LIBS
LIBS="$LIBS $GLIB_LIBS"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment