Commit b202fb85 authored by Michael Natterer's avatar Michael Natterer Committed by Michael Natterer

require fontconfig >= 2.2.0 (bug #121752), check for gdk-pixbuf-2.0

2003-09-10  Michael Natterer  <mitch@gimp.org>

	* configure.in: require fontconfig >= 2.2.0 (bug #121752), check
	for gdk-pixbuf-2.0 explicitly, added --enable-gimp-console
	configure option, bumped version number to 1.3.21.

	* app/core/Makefile.am: replaced GTK_CFLAGS by GDK_PIXBUF_CFLAGS.

	* app/Makefile.am: removed -export-dynamic from LDFLAGS since we
	don't export symbols to modules or libraries any more. Reordered
	SUBDIRS a bit.

	If --enable-gimp-console is given, try to build a second binary
	called gimp-console-1.3 which does not link against GTK+.
	Of course this fails badly since core/ui separation is not
	complete yet, but the output of the failing linker is a nice list
	of what needs to be done.
parent a280beda
2003-09-10 Michael Natterer <mitch@gimp.org>
* configure.in: require fontconfig >= 2.2.0 (bug #121752), check
for gdk-pixbuf-2.0 explicitly, added --enable-gimp-console
configure option, bumped version number to 1.3.21.
* app/core/Makefile.am: replaced GTK_CFLAGS by GDK_PIXBUF_CFLAGS.
* app/Makefile.am: removed -export-dynamic from LDFLAGS since we
don't export symbols to modules or libraries any more. Reordered
SUBDIRS a bit.
If --enable-gimp-console is given, try to build a second binary
called gimp-console-1.3 which does not link against GTK+.
Of course this fails badly since core/ui separation is not
complete yet, but the output of the failing linker is a nice list
of what needs to be done.
2003-09-09 Michael Natterer <mitch@gimp.org>
* app/gui/menus.c (menus_last_opened_add): removed redundant
## Process this file with automake to produce Makefile.in
if OS_WIN32
mwindows = -mwindows
endif
SUBDIRS = \
paint-funcs \
composite \
base \
core \
config \
core \
paint \
text \
vectors \
......@@ -18,13 +14,17 @@ SUBDIRS = \
plug-in \
tools \
widgets \
gui \
display \
gui \
pdb
scriptdata =
if ENABLE_GIMP_CONSOLE
bin_PROGRAMS = gimp-1.3 gimp-console-1.3
else
bin_PROGRAMS = gimp-1.3
endif
gimp_1_3_SOURCES = \
app_procs.c \
......@@ -49,7 +49,9 @@ else
REGEXREPL = $(top_builddir)/regexrepl/libregex.a
endif
gimp_1_3_LDFLAGS = -export-dynamic $(mwindows)
if OS_WIN32
gimp_1_3_LDFLAGS = -mwindows
endif
AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"Gimp\" \
......@@ -94,14 +96,53 @@ gimp_1_3_LDADD = \
$(INTLLIBS) \
$(REGEXREPL)
if ENABLE_GIMP_CONSOLE
gimp_console_1_3_SOURCES = $(gimp_1_3_SOURCES)
gimp_console_1_3_LDADD = \
config/libappconfig.a \
core/libappcore.a \
pdb/libapppdb.a \
paint/libapppaint.a \
xcf/libappxcf.a \
text/libapptext.a \
vectors/libappvectors.a \
file/libappfile.a \
plug-in/libappplug-in.a \
paint-funcs/libapppaint-funcs.a \
base/libappbase.a \
composite/libappcomposite.a \
$(top_builddir)/libgimpcolor/libgimpcolor-$(LT_RELEASE).la \
$(top_builddir)/libgimpmath/libgimpmath-$(LT_RELEASE).la \
$(top_builddir)/libgimpbase/libgimpbase-$(LT_RELEASE).la \
$(top_builddir)/libgimpmodule/libgimpmodule-$(LT_RELEASE).la \
$(GDK_PIXBUF_LIBS) \
$(LIBART_LIBS) \
$(PANGOFT2_LIBS) \
$(FONTCONFIG_LIBS) \
$(FREETYPE_LIBS) \
$(GIMP_THREAD_LIBS) \
$(GIMP_MP_LIBS) \
$(INTLLIBS) \
$(REGEXREPL)
endif
install-exec-hook:
if DEFAULT_BINARY
cd $(DESTDIR)$(bindir) \
&& rm -f gimp$(EXEEXT) \
&& $(LN_S) gimp-$(LT_RELEASE)$(EXEEXT) gimp$(EXEEXT)
if ENABLE_GIMP_CONSOLE
cd $(DESTDIR)$(bindir) \
&& rm -f gimp-console$(EXEEXT) \
&& $(LN_S) gimp-console-$(LT_RELEASE)$(EXEEXT) gimp-console$(EXEEXT)
endif
endif
uninstall-local:
if DEFAULT_BINARY
rm -f $(DESTDIR)$(bindir)/gimp$(EXEEXT)
if ENABLE_GIMP_CONSOLE
rm -f $(DESTDIR)$(bindir)/gimp-console-$(EXEEXT)
endif
endif
......@@ -9,7 +9,7 @@ AM_CPPFLAGS = \
INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/app \
$(GTK_CFLAGS) \
$(GDK_PIXBUF_CFLAGS) \
$(LIBART_CFLAGS) \
-I$(includedir)
......
......@@ -16,7 +16,9 @@ AC_INIT(app/core/gimp.c)
GLIB_REQUIRED_VERSION=2.2.0
GTK_REQUIRED_VERSION=$GLIB_REQUIRED_VERSION
GDKPIXBUF_REQUIRED_VERSION=$GTK_REQUIRED_VERSION
PANGOFT2_REQUIRED_VERSION=1.2.0
FONTCONFIG_REQUIRED_VERSION=2.2.0
GTKDOC_REQUIRED_VERSION=1.0
GTKHTML2_REQUIRED_VERSION=2.0.0
GIMPPRINT_REQUIRED_VERSION=4.2.0
......@@ -33,7 +35,7 @@ GIMPPRINT_TOONEW_VERSION=4.3.0
#
GIMP_MAJOR_VERSION=1
GIMP_MINOR_VERSION=3
GIMP_MICRO_VERSION=20
GIMP_MICRO_VERSION=21
GIMP_INTERFACE_AGE=0
GIMP_BINARY_AGE=0
GIMP_VERSION=$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION.$GIMP_MICRO_VERSION
......@@ -326,6 +328,8 @@ if test x$gimp_broken_gtk = xyes; then
AC_MSG_ERROR(Test for GTK failed. See the file 'INSTALL' for help.))
fi
PKG_CHECK_MODULES(GDK_PIXBUF, gdk-pixbuf-2.0 >= $GDKPIXBUF_REQUIRED_VERSION)
AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource, no)
if test x$GDK_PIXBUF_CSOURCE = xno; then
AC_MSG_ERROR(Could not find gdk-pixbuf-csource in your PATH)
......@@ -342,7 +346,7 @@ PKG_CHECK_MODULES(PANGOFT2, pangoft2 >= $PANGOFT2_REQUIRED_VERSION,,
AC_SUBST(PANGOFT2_CFLAGS)
AC_SUBST(PANGOFT2_LIBS)
PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 1.0.1, have_fontconfig=true, :)
PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= $FONTCONFIG_REQUIRED_VERSION)
AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
if test "x$FREETYPE_CONFIG" != "xno" ; then
......@@ -1138,6 +1142,19 @@ AC_ARG_ENABLE(default-binary, [ --enable-default-binary install this as the def
AM_CONDITIONAL(DEFAULT_BINARY, test x$enable_default_binary = xyes)
AC_ARG_ENABLE(gimp-console, [ --enable-gimp-console build a console-only binary which does not link GTK+ (default=no)], , enable_gimp_console=no)
AM_CONDITIONAL(ENABLE_GIMP_CONSOLE, test x$enable_gimp_console = xyes)
if test x$enable_gimp_console = xyes ; then
AC_MSG_WARN([--enable-gimp-console... are you nuts?
***
*** --enable-gimp-console is for crazy hackers only!
*** The build will fail badly in the app/ directory.
*** You have been warned ;)
***])
fi
dnl Possibly change default gimpdir from .gimp-major.minor
gimpdir=.$PACKAGE-$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
AC_ARG_ENABLE(gimpdir, [ --enable-gimpdir=DIR change default gimpdir from .gimp-1.3 to DIR],
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment