Commit a77d6ed6 authored by Akkana Peck's avatar Akkana Peck

Print a table of features enabled/disabled at the end (as discussed in bug

	* configure.in: Print a table of features enabled/disabled
        at the end (as discussed in bug 303383c11 and c13).
parent 03927740
2006-01-29 Akkana Peck <akkana@cvs.gnome.org>
* configure.in: Print a table of features enabled/disabled
at the end (as discussed in bug 303383c11 and c13).
2006-01-29 Roman Joost <romanofski@gimp.org>
* plug-ins/script-fu/scripts/web-browser.scm: adds eight
......
......@@ -897,6 +897,7 @@ if test "$gdk_target" = x11; then
DOC_SHOOTER=doc-shooter
dnl Test for Xmu
have_gimp_remote=yes
if test -z "$LIBXMU"; then
gimp_save_CFLAGS="$CFLAGS"
gimp_save_LDFLAGS="$LDFLAGS"
......@@ -907,13 +908,12 @@ if test "$gdk_target" = x11; then
GIMP_REMOTE='gimp-remote-gimp_app_version$(EXEEXT)';
have_libxmu=yes
LIBXMU="$X_LIBS $X_PRE_LIBS -lX11 -lXmu -lXt",
[AC_MSG_WARN(*** gimp-remote will not be built (XMU header file not found) ***)],[#include <gdk/gdkx.h>])],
[AC_MSG_WARN(*** gimp-remote will not be built (XMU library not found) ***)], -lXt -lX11)
[have_gimp_remote="no (XMU header file not found)"],[#include <gdk/gdkx.h>])],
[have_gimp_remote="no (XMU library not found)"], -lXt -lX11)
CFLAGS="$gimp_save_CFLAGS"
LDFLAGS="$gimp_save_LDFLAGS"
LIBSCREENSHOT="$LIBXMU"
fi
fi
AC_SUBST(LIBXMU)
......@@ -926,21 +926,23 @@ AC_SUBST(DOC_SHOOTER)
# Check for libtiff
###################
have_libtiff=no
AC_ARG_WITH(libtiff, [ --without-libtiff build without TIFF support])
have_libtiff=yes
if test x$with_libtiff != xno && test -z "$LIBTIFF"; then
AC_CHECK_LIB(tiff, TIFFReadScanline,
[AC_CHECK_HEADER(tiffio.h,
TIFF='tiff$(EXEEXT)'; LIBTIFF='-ltiff',
[AC_MSG_WARN(*** TIFF plug-in will not be built (TIFF header files not found) ***)])],
[have_libtiff="no (TIFF header files not found)"])],
[AC_CHECK_LIB(tiff, TIFFWriteScanline,
[AC_CHECK_HEADER(tiffio.h,
TIFF='tiff$(EXEEXT)'; LIBTIFF='-ltiff -ljpeg -lz',
[AC_MSG_WARN(*** TIFF plug-in will not be built (TIFF header files not found) ***)])],
[have_libtiff="no (TIFF header files not found)"])],
[AC_CHECK_LIB(tiff34, TIFFFlushData,
[AC_CHECK_HEADER(tiffio.h,
TIFF='tiff$(EXEEXT)'; LIBTIFF='-ltiff34 -ljpeg -lz',
[AC_MSG_WARN(*** TIFF plug-in will not be built (TIFF header files not found) ***)])],
[AC_MSG_WARN(*** TIFF plug-in will not be built (TIFF library not found) ***)], -ljpeg -lz -lm)], -ljpeg -lz -lm)], -lm)
[have_libtiff="no (TIFF header files not found)"])],
[have_libtiff="no (TIFF library not found)"], -ljpeg -lz -lm)], -ljpeg -lz -lm)], -lm)
fi
if test x$with_libtiff != xno && test -z "$LIBTIFF"; then
......@@ -961,8 +963,7 @@ AC_ARG_WITH(libjpeg, [ --without-libjpeg build without JPEG support])
if test x$with_libjpeg != xno && test -z "$LIBJPEG"; then
AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
jpeg_ok=yes,
[jpeg_ok=no
AC_MSG_WARN(*** JPEG plug-in will not be built (JPEG library not found) ***)
[jpeg_ok="no (JPEG library not found)"
AC_MSG_WARN(*** XJT plug-in will not be built (JPEG library not found) ***)])
if test "$jpeg_ok" = yes; then
AC_MSG_CHECKING([for jpeglib.h])
......@@ -974,17 +975,14 @@ AC_ARG_WITH(libjpeg, [ --without-libjpeg build without JPEG support])
#undef VERSION
#include <jpeglib.h>],
jpeg_ok=yes,
jpeg_ok=no)
jpeg_ok="no (Can't include jpeglib.h)")
AC_MSG_RESULT($jpeg_ok)
if test "$jpeg_ok" = yes; then
AC_CHECK_LIB(jpeg, jpeg_save_markers,
JPEG='jpeg$(EXEEXT)'; LIBJPEG='-ljpeg',
[jpeg_ok=no
AC_MSG_WARN(*** JPEG plug-in will not be built (JPEG library is too old) ***)
AC_MSG_WARN(*** XJT plug-in will not be built (JPEG library is too old) ***)])
jpeg_ok="no (JPEG library is too old)")
else
AC_MSG_WARN(*** JPEG plug-in will not be built (JPEG header file not found) ***)
AC_MSG_WARN(*** XJT plug-in will not be built (JPEG header file not found) ***)
jpeg_ok="no (JPEG header file not found)"
fi
fi
fi
......@@ -1007,12 +1005,13 @@ AM_CONDITIONAL(BUILD_XJT, test x$jpeg_ok = xyes && test x"$os_win32" = xno)
# Check for libz
################
have_zlib=yes
if test -z "$LIBZ"; then
AC_CHECK_LIB(z, gzsetparams,
[AC_CHECK_HEADER(zlib.h,
PSP='psp$(EXEEXT)'; LIBZ='-lz',
[AC_MSG_WARN(*** PSP and PNG plug-ins will not be built (ZLIB header files not found) ***)])],
[AC_MSG_WARN(*** PSP and PNG plug-ins will not be built (ZLIB library not found) ***)])
[have_zlib="no (ZLIB header files not found)"])],
[have_zlib="no (ZLIB library not found)"])
fi
AC_SUBST(LIBZ)
......@@ -1023,13 +1022,15 @@ AC_SUBST(PSP)
# Check for libpng
##################
have_libpng=no
AC_ARG_WITH(libpng, [ --without-libpng build without PNG support])
have_libpng=yes
if test x$with_libpng != xno && test -z "$LIBPNG" && test -n "$LIBZ"; then
AC_CHECK_LIB(png, png_read_info,
[AC_CHECK_HEADER(png.h,
png_ok=yes,
png_ok=no)],
[AC_MSG_WARN(*** PNG plug-in will not be built (PNG library not found) ***)], -lz -lm)
[have_libpng="no (PNG library not found)"], -lz -lm)
if test "$png_ok" = yes; then
AC_MSG_CHECKING([for png_structp in png.h])
AC_TRY_COMPILE([#include <png.h>],
......@@ -1040,10 +1041,10 @@ AC_ARG_WITH(libpng, [ --without-libpng build without PNG support])
if test "$png_ok" = yes; then
PNG='png$(EXEEXT)'; LIBPNG="-lpng $LIBZ"
else
AC_MSG_WARN(*** PNG plug-in will not be built (PNG library is too old) ***)
have_libpng="no (PNG library is too old)"
fi
else
AC_MSG_WARN(*** PNG plug-in will not be built (PNG header file not found) ***)
have_libpng="no (PNG header file not found)"
fi
fi
......@@ -1061,16 +1062,18 @@ AC_SUBST(LIBPNG)
# Check for libmng
##################
have_libmng=no
AC_ARG_WITH(libmng, [ --without-libmng build without MNG support])
have_libmng=yes
if test x$with_libmng != xno && test -z "$LIBMNG" &&
test -n "$LIBPNG" && test -n "$LIBJPEG" && test -n "$LIBZ"; then
AC_CHECK_LIB(mng, mng_create,
[AC_CHECK_HEADER(libmng.h, mng_ok=yes)],
[AC_MSG_WARN(*** MNG plug-in will not be built (MNG library not found) ***)], -lz -lm)
[have_libmng="no (MNG library not found)"], -lz -lm)
if test "$mng_ok" = yes; then
MNG='mng$(EXEEXT)'; LIBMNG="-lmng $LIBJPEG $LIBPNG"
else
AC_MSG_WARN(*** MNG plug-in will not be built (MNG header file not found) ***)
have_libmng="no (MNG header file not found)"
fi
fi
......@@ -1084,13 +1087,13 @@ AC_SUBST(LIBMNG)
# avoid destruction, but no data modification is performed.
############################################################
have_libexif=no
AC_ARG_WITH(libexif, [ --without-libexif build without EXIF support])
if test x$with_libexif != xno && test -z "$LIBEXIF" && test -n "$LIBJPEG"; then
have_libexif=yes
PKG_CHECK_MODULES(EXIF, libexif,
AC_DEFINE(HAVE_EXIF, 1, [Define to 1 if libexif is available]),
AC_MSG_WARN([libexif not found!
EXIF support will not be built into the JPEG plug-in.
libexif is available from http://www.sourceforge.net/projects/libexif]))
have_libexif="no (libexif not found)")
AC_MSG_CHECKING([if libexif is version 0.6.0 or newer])
if $PKG_CONFIG --atleast-version=0.6.0 libexif; then
have_exif_0_6=yes
......@@ -1113,13 +1116,15 @@ AC_SUBST(EXIF_LIBS)
#################
have_libaa=no
AC_ARG_WITH(aa, [ --without-aa do not build the AA plug-in])
if test x$with_aa != xno && test -z "$LIBAA"; then
have_libaa=yes
AC_CHECK_LIB(aa, aa_printf,
[AC_CHECK_HEADER(aalib.h,
AA='aa$(EXEEXT)'; LIBAA='-laa',
[AC_MSG_WARN(*** AA plug-in will not be built (AA header file not found) ***)])],
[AC_MSG_WARN(*** AA plug-in will not be built (AA library not found) ***)])
[have_libaa="no (AA header file not found)"])],
[have_libaa="no (AA library not found)"])
fi
AC_SUBST(AA)
......@@ -1137,12 +1142,13 @@ LDFLAGS="$LDFLAGS $X_LIBS"
if test "$gdk_target" = x11; then
lib_X11=-lX11
fi
have_libxpm=yes
if test -z "$LIBXPM"; then
AC_CHECK_LIB(Xpm, XpmReadFileToXpmImage,
[AC_CHECK_HEADER(X11/xpm.h,
XPM='xpm$(EXEEXT)'; LIBXPM="$X_LIBS $X_PRE_LIBS $lib_X11 -lXpm",
[AC_MSG_WARN(*** XPM plug-in will not be built (XPM header file not found) ***)])],
[AC_MSG_WARN(*** XPM plug-in will not be built (XPM library not found) ***)], $X_PRE_LIBS $lib_X11)
[have_libxpm="no (XPM header file not found)"])],
[have_libxpm="no (XPM library not found)"], $X_PRE_LIBS $lib_X11)
fi
CFLAGS="$gimp_save_CFLAGS"
LDFLAGS="$gimp_save_LDFLAGS"
......@@ -1161,9 +1167,9 @@ have_gtkhtml2=no
if test "x$with_gtkhtml2" != xno; then
PKG_CHECK_MODULES(GTKHTML2, libgtkhtml-2.0 >= gtkhtml2_required_version,
have_gtkhtml2=yes,
AC_MSG_WARN([*** Help browser plug-in will not be built (GtkHtml2 not found) ***]))
have_gtkhtml2="no (GtkHtml2 not found)")
else
AC_MSG_WARN([*** Help browser plug-in will not be built (GtkHtml2 support disabled) ***])
have_gtkhtml2="no (GtkHtml2 support disabled)"
fi
AM_CONDITIONAL(BUILD_HELPBROWSER, test x$have_gtkhtml2 = xyes)
......@@ -1175,13 +1181,15 @@ AM_CONDITIONAL(BUILD_HELPBROWSER, test x$have_gtkhtml2 = xyes)
AC_ARG_WITH(librsvg,[ --without-librsvg build without librsvg support])
have_librsvg=no
if test "x$with_librsvg" != xno; then
have_librsvg=yes
PKG_CHECK_MODULES(SVG, librsvg-2.0 >= rsvg_required_version,
SVG='svg$(EXEEXT)'
LIBSVG=$SVG_LIBS,
AC_MSG_WARN([*** SVG import plug-in will not be built (librsvg not found) ***]))
have_librsvg="no (librsvg not found)")
else
AC_MSG_WARN([*** SVG import plug-in will not be built (librsvg support disabled) ***])
have_librsvg="no (librsvg support disabled)"
fi
AC_SUBST(SVG)
......@@ -1192,6 +1200,7 @@ AC_SUBST(LIBSVG)
# Check for libpoppler
######################
have_poppler=no
AC_ARG_WITH(poppler,[ --without-poppler build without poppler support])
if test "x$with_poppler" != xno; then
......@@ -1201,9 +1210,9 @@ if test "x$with_poppler" != xno; then
LIBPOPPLER=$POPPLER_LIBS
AC_DEFINE(HAVE_POPPLER, 1, [Define to 1 if libpoppler is available])
have_poppler=yes,
AC_MSG_WARN([*** PDF will be imported by the postscript plugin (libpoppler not found) ***]))
have_poppler="Using PostScript plug-in (libpoppler not found)")
else
AC_MSG_WARN([*** PDF will be imported by the postscript plugin (libpoppler support disabled)])
have_poppler="Using PostScript plug-in (libpoppler support disabled)"
fi
AC_SUBST(POPPLER)
......@@ -1232,19 +1241,19 @@ if $PKG_CONFIG --atleast-version=gnomeui_required_version libgnomeui-2.0; then
have_gnomeui=yes
uri_modules="$uri_modules libgnomeui-2.0"
else
AC_MSG_WARN([*** URI plug-in will be built without libgnomeui support (libgnomeui-2.0 not found) ***])
have_gnomeui="no (libgnomeui-2.0 not found)"
fi
if $PKG_CONFIG --atleast-version=gnome_keyring_required_version gnome-keyring-1; then
have_gnome_keyring=yes
uri_modules="$uri_modules gnome-keyring-1"
else
AC_MSG_WARN([*** URI plug-in will be built without gnome-keyring support (gnome-keyring-1 not found) ***])
have_gnome_keyring="no (gnome-keyring-1 not found)"
fi
PKG_CHECK_MODULES(URI, $uri_modules,
have_gnomevfs=yes,
AC_MSG_WARN([*** URI plug-in will be built without gnome-vfs support (gnome-vfs-2.0 not found) ***]))
have_gnomevfs="no (gnome-vfs-2.0 not found)")
AM_CONDITIONAL(HAVE_GNOMEVFS, test x$have_gnomevfs = xyes)
......@@ -1267,7 +1276,7 @@ if test "x$with_gnomeprint" != xno; then
PKG_CHECK_MODULES(GNOMEPRINT,
libgnomeprintui-2.2 >= gnome_print_required_version,
have_gnomeprint=yes,
AC_MSG_WARN([libgnomeprintui not found!]))
have_gnomeprint="no (libgnomeprintui not found!)")
fi
AM_CONDITIONAL(HAVE_GNOMEPRINT, test x$have_gnomeprint = xyes)
......@@ -1286,12 +1295,14 @@ AC_SUBST(LIBGNOMEPRINT)
# Check for gimp-print
######################
have_gimp_print=no
AC_ARG_WITH(gimpprint, [ --without-gimpprint disable build of gimpprint plug-in])
if test "x$with_gimpprint" != xno; then
AM_PATH_GIMPPRINT(gimpprint_required_version,
[print_version=`$GIMPPRINT_CONFIG --version`
if expr $print_version \>= gimpprint_toonew_version >/dev/null; then
have_gimp_print="no (you have a version that's too new!)"
AC_MSG_WARN([
*** libgimpprint version $print_version is too new.
*** It is likely an unstable development version.
......@@ -1317,8 +1328,10 @@ AM_CONDITIONAL(BUILD_PRINT, test x$have_gimp_print = xyes)
# Check for libwmf2
###################
have_libwmf=no
AC_PATH_PROG(WMF_CONFIG, libwmf-config, no)
if test "x$WMF_CONFIG" != "xno" ; then
have_libwmf=yes
AC_MSG_CHECKING(for libwmf >= wmf_required_version)
wmf_version=`$WMF_CONFIG --version`
if expr $wmf_version \>= wmf_required_version >/dev/null; then
......@@ -1327,10 +1340,10 @@ if test "x$WMF_CONFIG" != "xno" ; then
LIBWMF=`$WMF_CONFIG --libs`
WMF_CFLAGS=`$WMF_CONFIG --cflags`
else
AC_MSG_WARN([*** WMF plug-in will not be built (libwmf is too old)])
have_libwmf="no (libwmf is too old)"
fi
else
AC_MSG_WARN([*** WMF plug-in will not be built (libwmf not found) ***])
have_libwmf="no (libwmf not found)"
fi
AC_SUBST(LIBWMF)
AC_SUBST(WMF_CFLAGS)
......@@ -1356,10 +1369,10 @@ if test "x$with_lcms" != xno; then
if test $have_lcms = yes; then
LCMS_LIBS="-llcms"
else
AC_MSG_WARN([*** color proof module will not be built (lcms not found or unusable) ***])
have_lcms="no (lcms not found or unusable)"
fi
else
AC_MSG_WARN([*** color proof module will not be built (lcms support disabled) ***])
have_lcms="no (lcms support disabled)"
fi
AC_SUBST(LCMS_LIBS)
......@@ -1370,12 +1383,14 @@ AM_CONDITIONAL(HAVE_LCMS, test $have_lcms = yes)
# Check for alsa
################
have_alsa=no
AC_ARG_WITH(alsa, [ --without-alsa disable alsa support in midi input controller])
if test "x$with_alsa" != xno; then
have_alsa=yes
AM_PATH_ALSA(alsa_required_version,
AC_DEFINE(HAVE_ALSA, 1, [Define to 1 if alsa is available]),
AC_MSG_WARN([*** midi input controller will be built without alsa support (alsa not found or unuseable) ***]))
have_alsa="no (alsa not found or unuseable)")
fi
......@@ -1880,3 +1895,34 @@ sed -e "/POTFILES =/r po-script-fu/POTFILES" po-script-fu/Makefile.in > po-scrip
sed -e "/POTFILES =/r po-tips/POTFILES" po-tips/Makefile.in > po-tips/Makefile])
AC_OUTPUT
dnl Print a summary of features enabled/disabled:
AC_MSG_RESULT([
Building GIMP with prefix=$prefix
GIMP Features:
gimp-remote: $have_gimp_remote
tiff: $have_libtiff
jpeg: $jpeg_ok
xjt: $jpeg_ok
tiff: $have_libtiff
zlib: $have_zlib
png: $have_libpng
mng: $have_libmng
exif: $have_libexif
aa: $have_libaa
xpm: $have_libxpm
help: $have_gtkhtml2
svg: $have_librsvg
poppler: $have_poppler
gnome ui: $have_gnomeui
keyring: $have_gnome_keyring
gnome vfs: $have_gnomevfs
gnomeprint: $have_gnomeprint
gimp-print: $have_gimp_print
wmf: $have_libwmf
littlecms: $have_lcms
alsa: $have_alsa
linux input: $have_linux_input
perl pdbgen: $with_pdbgen
]);
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment