Commit 95ad3a13 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

readded version check for glib-gettextize.

2006-03-02  Sven Neumann  <sven@gimp.org>

	* autogen.sh: readded version check for glib-gettextize.
parent e874984f
2006-03-02 Sven Neumann <sven@gimp.org>
* autogen.sh: readded version check for glib-gettextize.
2005-03-02 Øyvind Kolås <pippin@gimp.org>
* autogen.sh: added improved check_version() function that handles
......
......@@ -17,10 +17,12 @@ LIBTOOLIZE=${LIBTOOLIZE-libtoolize}
AUTOCONF_REQUIRED_VERSION=2.54
AUTOMAKE_REQUIRED_VERSION=1.8.3
GLIB_REQUIRED_VERSION=2.2.0
INTLTOOL_REQUIRED_VERSION=0.31
LIBTOOL_REQUIRED_VERSION=1.4
LIBTOOL_WIN32=1.5
PROJECT="GNU Image Manipulation Program"
TEST_TYPE=-d
FILE=plug-ins
......@@ -31,6 +33,7 @@ test -z "$srcdir" && srcdir=.
ORIGDIR=`pwd`
cd $srcdir
check_version ()
{
VERSION_A=$1
......@@ -181,7 +184,9 @@ fi
echo -n "checking for glib-gettextize ... "
if (glib-gettextize --version) < /dev/null > /dev/null 2>&1; then
echo "yes"
VER=`glib-gettextize --version \
| grep glib-gettextize | sed "s/.* \([0-9.]*\)/\1/"`
check_version $VER $GLIB_REQUIRED_VERSION
else
echo
echo " You must have glib-gettextize installed to compile $PROJECT."
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment