Commit 950a71b9 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

HACKING dropped support for automake 1.8 and require automake >= 1.9.6.

2007-11-21  Sven Neumann  <sven@gimp.org>

	* HACKING
	* autogen.sh: dropped support for automake 1.8 and require
	automake >= 1.9.6. Require libtool 1.5 for all platforms.

svn path=/trunk/; revision=24210
parent a34cdad6
2007-11-21 Sven Neumann <sven@gimp.org>
* HACKING
* autogen.sh: dropped support for automake 1.8 and require
automake >= 1.9.6. Require libtool 1.5 for all platforms.
2007-11-20 Michael Natterer <mitch@gimp.org>
* app/widgets/gimpcontainercombobox.c: set the combo insensitive
......
......@@ -5,15 +5,15 @@ to have the following packages (or newer versions) installed:
* GNU autoconf 2.54
- ftp://ftp.gnu.org/gnu/autoconf/
* GNU automake 1.9 (automake 1.8 should also work)
* GNU automake 1.9 (automake 1.10 should also work)
- ftp://ftp.gnu.org/gnu/automake/
* GNU libtool 1.4 (libtool 1.5 if you are compiling on Win32)
* GNU libtool 1.5
- ftp://ftp.gnu.org/gnu/libtool/
Fine GNU mirrors are listed at http://www.gnu.org/prep/ftp.html
Beta software can be found at alpha.gnu.org.
* pkg-config 0.15.0 (or preferably a newer version)
* pkg-config 0.16.0 (or preferably a newer version)
- http://www.freedesktop.org/software/pkgconfig/
* intltoolize 0.31.1 (or preferably a newer version)
......
......@@ -16,11 +16,10 @@ AUTOMAKE=${AUTOMAKE-automake-1.9}
LIBTOOLIZE=${LIBTOOLIZE-libtoolize}
AUTOCONF_REQUIRED_VERSION=2.54
AUTOMAKE_REQUIRED_VERSION=1.8.3
GLIB_REQUIRED_VERSION=2.2.0
AUTOMAKE_REQUIRED_VERSION=1.9.6
GLIB_REQUIRED_VERSION=2.10.0
INTLTOOL_REQUIRED_VERSION=0.31
LIBTOOL_REQUIRED_VERSION=1.4
LIBTOOL_WIN32=1.5
LIBTOOL_REQUIRED_VERSION=1.5
PROJECT="GNU Image Manipulation Program"
......@@ -82,16 +81,6 @@ echo
DIE=0
OS=`uname -s`
case $OS in
*YGWIN* | *INGW*)
echo "Looks like Win32, you will need libtool $LIBTOOL_WIN32 or newer."
echo
LIBTOOL_REQUIRED_VERSION=$LIBTOOL_WIN32
;;
esac
echo -n "checking for libtool >= $LIBTOOL_REQUIRED_VERSION ... "
if ($LIBTOOLIZE --version) < /dev/null > /dev/null 2>&1; then
LIBTOOLIZE=$LIBTOOLIZE
......@@ -166,9 +155,6 @@ elif (automake-1.10 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.9
ACLOCAL=aclocal-1.9
elif (automake-1.8 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.8
ACLOCAL=aclocal-1.8
else
echo
echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT."
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment