Commit 930e08d8 authored by Manish Singh's avatar Manish Singh Committed by Manish Singh

if any of the pygimp dependencies aren't fulfilled, display a more

2005-06-11  Manish Singh  <yosh@gimp.org>

        * configure.in: if any of the pygimp dependencies aren't fulfilled,
        display a more informative message.

        * autogen.sh: depend on automake 1.8, so AM_PATH_PYTHON has a user
        defined failure mode. Also prefer automake 1.9.
parent cb940554
2005-06-11 Manish Singh <yosh@gimp.org>
* configure.in: if any of the pygimp dependencies aren't fulfilled,
display a more informative message.
* autogen.sh: depend on automake 1.8, so AM_PATH_PYTHON has a user
defined failure mode. Also prefer automake 1.9.
2005-06-11 Sven Neumann <sven@gimp.org>
* libgimpwidgets/gimppropwidgets.c: connect to "selection-changed"
......
......@@ -17,7 +17,7 @@ FILE=plug-ins
LIBTOOL_REQUIRED_VERSION=1.4
LIBTOOL_WIN32=1.5
AUTOCONF_REQUIRED_VERSION=2.54
AUTOMAKE_REQUIRED_VERSION=1.7
AUTOMAKE_REQUIRED_VERSION=1.8.3
GLIB_REQUIRED_VERSION=2.2.0
INTLTOOL_REQUIRED_VERSION=0.31
......@@ -122,19 +122,15 @@ fi
echo -n "checking for automake >= $AUTOMAKE_REQUIRED_VERSION ... "
if (automake-1.7 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.7
ACLOCAL=aclocal-1.7
if (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.9
ACLOCAL=aclocal-1.9
elif (automake-1.8 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.8
ACLOCAL=aclocal-1.8
AUTOMAKE_REQUIRED_VERSION=1.8.3
elif (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.9
ACLOCAL=aclocal-1.9
else
echo
echo " You must have automake 1.7 or newer installed to compile $PROJECT."
echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT."
echo " Download the appropriate package for your distribution,"
echo " or get the source tarball at ftp://ftp.gnu.org/pub/gnu/automake/"
echo
......
......@@ -1345,17 +1345,26 @@ AC_ARG_ENABLE(python,
AC_HELP_STRING([--disable-python],
[do not build the python extension]))
m4_define([pycheck_error], [
*** Could not find $1.
*** Please install $2, or skip building the python scripting extension by
*** passing --disable-python to configure (but then you will not be able
*** to use scripts for GIMP that are written in Python).])
if test "x$enable_python" != xno; then
dnl check for Python
AM_PATH_PYTHON(2.2.1)
AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
AM_PATH_PYTHON(2.2.1,,
[AC_MSG_ERROR([pycheck_error([Python 2.2.1 or better], [it])])])
AM_CHECK_PYTHON_HEADERS(,
[AC_MSG_ERROR([pycheck_error([Python headers], [them])])])
dnl check for PyGTK
PKG_CHECK_MODULES(PYGTK, pygtk-2.0 >= pygtk_required_version)
PKG_CHECK_MODULES(PYGTK, pygtk-2.0 >= pygtk_required_version,,
[AC_MSG_ERROR([pycheck_error([PyGTK], [it])])])
AC_PATH_PROG(PYGTK_CODEGEN, pygtk-codegen-2.0, no)
if test "x$PYGTK_CODEGEN" = xno; then
AC_MSG_ERROR(could not find pygtk-codegen-2.0 script)
AC_MSG_ERROR([pycheck_error([pygtk-codegen-2.0 script], [it])])
fi
AC_MSG_CHECKING(for pygtk defs)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment