Commit 8df8cd03 authored by Jehan's avatar Jehan

autogen: fix and improve automake/aclocal detection.

Forgot to edit the first test in commit 6cf26410. If automake/aclocal
1.11 was installed, autogen.sh breaks, even though other higher versions
are installed too, because it is the first test.
Actually I'm not sure I understand this first test. Is it like the
"preferred" automake version?
Also add a test for generic `automake` binary in order to handle newer
versions. Thanks to Éric Hoffman for this proposition.
parent 8322ffda
......@@ -9,10 +9,10 @@
# tools and you shouldn't use this script. Just call ./configure
# directly.
ACLOCAL=${ACLOCAL-aclocal-1.11}
ACLOCAL=${ACLOCAL-aclocal-1.13}
AUTOCONF=${AUTOCONF-autoconf}
AUTOHEADER=${AUTOHEADER-autoheader}
AUTOMAKE=${AUTOMAKE-automake-1.11}
AUTOMAKE=${AUTOMAKE-automake-1.13}
LIBTOOLIZE=${LIBTOOLIZE-libtoolize}
AUTOCONF_REQUIRED_VERSION=2.54
......@@ -166,6 +166,9 @@ elif (automake-1.14 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.13 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.13
ACLOCAL=aclocal-1.13
elif (automake --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake
ACLOCAL=aclocal
else
echo
echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT."
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment