Commit 8797a355 authored by Jehan's avatar Jehan

INSTALL: add fontconfig, gettext versions and optional dependencies.

parent 880299bd
......@@ -29,12 +29,14 @@ header files installed.
******************************************************************
1. You need to have installed a recent version of pkg-config available
1. You need to have installed a recent version of pkg-config (>= @GIMP_PKGCONFIG_VERSION@) available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need intltool (at least @INTLTOOL_REQUIRED_VERSION@, but preferably a newer version).
Intltool can be downloaded from
http://ftp.gnome.org/pub/gnome/sources/intltool/
You are recommended to install gettext version @XGETTEXT_RECOMMENDED_VERSION@ or over. Earlier gettext had
issues with script-fu localization, ending up in incomplete GIMP localization.
3. You need to have GEGL version @GEGL_REQUIRED_VERSION@ or newer and babl version
@BABL_REQUIRED_VERSION@ or newer. You can get them from http://gegl.org/ or clone
......@@ -106,7 +108,6 @@ header files installed.
ATK: @ATK_REQUIRED_VERSION@
babl: @BABL_REQUIRED_VERSION@
libbzip2
cairo: @CAIRO_REQUIRED_VERSION@
Fontconfig: @FONTCONFIG_REQUIRED_VERSION@
freetype2: @FREETYPE2_REQUIRED_VERSION@
......@@ -115,6 +116,7 @@ header files installed.
GLib: @GLIB_REQUIRED_VERSION@
GTK+: @GTK_REQUIRED_VERSION@
HarfBuzz: @HARFBUZZ_REQUIRED_VERSION@
libbzip2
libjpeg
libpng: @LIBPNG_REQUIRED_VERSION@
liblzma: @LIBLZMA_REQUIRED_VERSION@
......@@ -122,6 +124,26 @@ header files installed.
pangocairo: @PANGOCAIRO_REQUIRED_VERSION@
zlib
17. Summary of optional packages:
Package Name | Version | Feature
libaa - ASCII art
gs - ghostscript
webkit @WEBKIT_REQUIRED_VERSION@ Help browser & webpage
libjasper - JPEG 2000
libmng - MNG
openexr @OPENEXR_REQUIRED_VERSION@ OpenEXR
libpoppler @POPPLER_REQUIRED_VERSION@ PDF import
cairo-pdf @CAIRO_PDF_REQUIRED_VERSION@ PDF export
python 2 @PYTHON2_REQUIRED_VERSION@ Python plug-ins
librsvg @RSVG_REQUIRED_VERSION@ SVG
libtiff - TIFF
libwmf @WMF_REQUIRED_VERSION@ WMF
libXcursor - X11 Mouse Cursor
libxpm - XPM
Please make sure you don't have any old GTK+-2.x, jpeg, etc. libraries
lying around on your system, otherwise configure may fail to find the
new ones.
......
......@@ -130,6 +130,7 @@ GLIB_REQUIRED_VERSION=glib_required_version
GDK_PIXBUF_REQUIRED_VERSION=gdk_pixbuf_required_version
GTK_REQUIRED_VERSION=gtk_required_version
CAIRO_REQUIRED_VERSION=cairo_required_version
CAIRO_PDF_REQUIRED_VERSION=cairo_pdf_required_version
GEGL_REQUIRED_VERSION=gegl_required_version
GEXIV2_REQUIRED_VERSION=gexiv2_required_version
LCMS_REQUIRED_VERSION=lcms_required_version
......@@ -140,13 +141,20 @@ BABL_REQUIRED_VERSION=babl_required_version
FONTCONFIG_REQUIRED_VERSION=fontconfig_required_version
FREETYPE2_REQUIRED_VERSION=freetype2_required_version
HARFBUZZ_REQUIRED_VERSION=harfbuzz_required_version
WEBKIT_REQUIRED_VERSION=webkit_required_version
ATK_REQUIRED_VERSION=atk_required_version
RSVG_REQUIRED_VERSION=rsvg_required_version
WMF_REQUIRED_VERSION=wmf_required_version
POPPLER_REQUIRED_VERSION=poppler_required_version
OPENEXR_REQUIRED_VERSION=openexr_required_version
INTLTOOL_REQUIRED_VERSION=intltool_required_version
PYTHON2_REQUIRED_VERSION=python2_required_version
XGETTEXT_RECOMMENDED_VERSION=xgettext_recommended_version
AC_SUBST(GLIB_REQUIRED_VERSION)
AC_SUBST(GDK_PIXBUF_REQUIRED_VERSION)
AC_SUBST(GTK_REQUIRED_VERSION)
AC_SUBST(CAIRO_REQUIRED_VERSION)
AC_SUBST(CAIRO_PDF_REQUIRED_VERSION)
AC_SUBST(GEGL_REQUIRED_VERSION)
AC_SUBST(GEXIV2_REQUIRED_VERSION)
AC_SUBST(LCMS_REQUIRED_VERSION)
......@@ -157,9 +165,15 @@ AC_SUBST(BABL_REQUIRED_VERSION)
AC_SUBST(FONTCONFIG_REQUIRED_VERSION)
AC_SUBST(FREETYPE2_REQUIRED_VERSION)
AC_SUBST(HARFBUZZ_REQUIRED_VERSION)
AC_SUBST(WEBKIT_REQUIRED_VERSION)
AC_SUBST(ATK_REQUIRED_VERSION)
AC_SUBST(RSVG_REQUIRED_VERSION)
AC_SUBST(WMF_REQUIRED_VERSION)
AC_SUBST(POPPLER_REQUIRED_VERSION)
AC_SUBST(OPENEXR_REQUIRED_VERSION)
AC_SUBST(INTLTOOL_REQUIRED_VERSION)
AC_SUBST(PYTHON2_REQUIRED_VERSION)
AC_SUBST(XGETTEXT_RECOMMENDED_VERSION)
# The symbol GIMP_UNSTABLE is defined above for substitution in
# Makefiles and conditionally defined here as a preprocessor symbol
......@@ -491,7 +505,6 @@ AM_GLIB_GNU_GETTEXT
# Testing xgettext version since we had some problem with localizing script-fu. See bug 720052.
AC_MSG_CHECKING([for recommended xgettext version (>= xgettext_recommended_version)])
XGETTEXT_RECOMMENDED_VERSION=xgettext_recommended_version
XGETTEXT_RECOMMENDED_VERSION_MAJOR=`echo $XGETTEXT_RECOMMENDED_VERSION | awk -F. '{ print $ 1; }'`
XGETTEXT_RECOMMENDED_VERSION_MINOR_1=`echo $XGETTEXT_RECOMMENDED_VERSION | awk -F. '{ print $ 2; }'`
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment