Commit 81e955ed authored by Mukund Sivaraman's avatar Mukund Sivaraman

build: Add HarfBuzz dependency

parent 7f23fbec
......@@ -57,6 +57,11 @@ header files installed.
and fontconfig @FONTCONFIG_REQUIRED_VERSION@ or newer. Older versions are known to have
bugs that seriously affect the stability of GIMP.
We also require HarfBuzz @HARFBUZZ_REQUIRED_VERSION@ or newer, an
OpenType text shaping tool. As this is a dependency for Pango, you
will likely have it installed, but you may have to install a
development package for the headers.
7. Access of remote files is implemented in the URI plug-in. There
are several possible implementations for this. The implementation
used is determined when you configure GIMP. By default the
......
......@@ -175,6 +175,7 @@ gimpconsoleldadd = \
$(FREETYPE_LIBS) \
$(FONTCONFIG_LIBS) \
$(PANGOCAIRO_LIBS) \
$(HARFBUZZ_LIBS) \
$(CAIRO_LIBS) \
$(GEGL_LIBS) \
$(GLIB_LIBS) \
......
......@@ -122,6 +122,7 @@ LDADD = \
$(FREETYPE_LIBS) \
$(FONTCONFIG_LIBS) \
$(PANGOCAIRO_LIBS) \
$(HARFBUZZ_LIBS) \
$(CAIRO_LIBS) \
$(GEGL_LIBS) \
$(GIO_LIBS) \
......
......@@ -8,6 +8,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/app \
$(GEGL_CFLAGS) \
$(PANGOCAIRO_CFLAGS) \
$(HARFBUZZ_CFLAGS) \
$(GDK_PIXBUF_CFLAGS) \
-I$(includedir)
......
......@@ -51,6 +51,7 @@ m4_define([cairo_pdf_required_version], [1.12.2])
m4_define([pangocairo_required_version], [1.29.4])
m4_define([fontconfig_required_version], [2.2.0])
m4_define([freetype2_required_version], [2.1.7])
m4_define([harfbuzz_required_version], [0.9.27])
m4_define([gtkdoc_required_version], [1.0])
m4_define([webkit_required_version], [1.6.1])
m4_define([alsa_required_version], [1.0.0])
......@@ -130,6 +131,7 @@ PANGOCAIRO_REQUIRED_VERSION=pangocairo_required_version
BABL_REQUIRED_VERSION=babl_required_version
FONTCONFIG_REQUIRED_VERSION=fontconfig_required_version
FREETYPE2_REQUIRED_VERSION=freetype2_required_version
HARFBUZZ_REQUIRED_VERSION=harfbuzz_required_version
ATK_REQUIRED_VERSION=atk_required_version
INTLTOOL_REQUIRED_VERSION=intltool_required_version
AC_SUBST(GLIB_REQUIRED_VERSION)
......@@ -142,6 +144,7 @@ AC_SUBST(PANGOCAIRO_REQUIRED_VERSION)
AC_SUBST(BABL_REQUIRED_VERSION)
AC_SUBST(FONTCONFIG_REQUIRED_VERSION)
AC_SUBST(FREETYPE2_REQUIRED_VERSION)
AC_SUBST(HARFBUZZ_REQUIRED_VERSION)
AC_SUBST(ATK_REQUIRED_VERSION)
AC_SUBST(INTLTOOL_REQUIRED_VERSION)
......@@ -624,6 +627,8 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
fi
AC_SUBST(FREETYPE_LIBS)
PKG_CHECK_MODULES(HARFBUZZ, harfbuzz >= harfbuzz_required_version)
PKG_CHECK_MODULES(GEXIV2, gexiv2 >= gexiv2_required_version)
##########################################
......
......@@ -97,6 +97,7 @@ GTKDOC_LIBS = \
$(PANGOFT2_LIBS) \
$(FONTCONFIG_LIBS) \
$(FREETYPE_LIBS) \
$(HARFBUZZ_LIBS) \
$(DBUS_GLIB_LIBS) \
$(GEGL_LIBS) \
$(RT_LIBS) \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment