Commit 780d2b8e authored by Michael Natterer's avatar Michael Natterer 😴

autogen.sh: require automake >= 1.10 and default to 1.11

Remove automake-1.9 from the list of possible versions because it
fails to define $(builddir) which is required in some places.
parent 919598a1
......@@ -9,14 +9,14 @@
# tools and you shouldn't use this script. Just call ./configure
# directly.
ACLOCAL=${ACLOCAL-aclocal-1.9}
ACLOCAL=${ACLOCAL-aclocal-1.11}
AUTOCONF=${AUTOCONF-autoconf}
AUTOHEADER=${AUTOHEADER-autoheader}
AUTOMAKE=${AUTOMAKE-automake-1.9}
AUTOMAKE=${AUTOMAKE-automake-1.11}
LIBTOOLIZE=${LIBTOOLIZE-libtoolize}
AUTOCONF_REQUIRED_VERSION=2.54
AUTOMAKE_REQUIRED_VERSION=1.9.6
AUTOMAKE_REQUIRED_VERSION=1.10.0
INTLTOOL_REQUIRED_VERSION=0.40.1
LIBTOOL_REQUIRED_VERSION=1.5
LIBTOOL_WIN32_REQUIRED_VERSION=2.2
......@@ -163,9 +163,6 @@ elif (automake-1.11 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.10 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.10
ACLOCAL=aclocal-1.10
elif (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
AUTOMAKE=automake-1.9
ACLOCAL=aclocal-1.9
else
echo
echo " You must have automake $AUTOMAKE_REQUIRED_VERSION or newer installed to compile $PROJECT."
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment