Commit 5da252ca authored by Jehan's avatar Jehan

Issue #2543: gimp doesn't open on debian stretch (libmypaint crash).

Known bug in libmypaint dependency. It has been fixed in libmypaint
1.4.0, which we cannot hard require unfortunately (Debian testing still
at 1.3.0).

Still let's make add a warning so that packagers are aware of the issue
and update when possible.
parent 59dcd29f
Pipeline #130507 passed with stages
in 27 minutes and 10 seconds
......@@ -1909,8 +1909,14 @@ fi
# Check for libmypaint
######################
PKG_CHECK_MODULES(LIBMYPAINT, libmypaint >= libmypaint_required_version,,
[add_deps_error([libmypaint >= libmypaint_required_version])])
PKG_CHECK_MODULES(LIBMYPAINT, libmypaint >= 1.4.0,,
[
PKG_CHECK_MODULES(LIBMYPAINT, libmypaint >= libmypaint_required_version,,
[add_deps_error([libmypaint >= libmypaint_required_version])])
warning_libmypaint="
WARNING: libmypaint lower than version 1.4.0 is known to crash when
parsing MyPaint 2 brushes. Please update."
])
PKG_CHECK_MODULES(MYPAINT_BRUSHES, mypaint-brushes-1.0,,
[add_deps_error([mypaint-brushes-1.0])])
......@@ -3175,7 +3181,7 @@ Tests:
Test desktop file $have_desktop_file_validate
Bug report URL: $with_bug_report_url
$override_bug_report_url$warning_vector_icons_windows$warning_glib_networking$warning_gcc$warning_python$warning_javascript$warning_lua$warning_libheif"
$override_bug_report_url$warning_vector_icons_windows$warning_glib_networking$warning_gcc$warning_python$warning_javascript$warning_lua$warning_libheif$warning_libmypaint"
if test "x$required_deps" = "x"; then
AC_OUTPUT
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment