Commit 5c6cf549 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

bumped our version number to 1.3.6. Added check for libgtkhtml-2.0.

2002-05-05  Sven Neumann  <sven@gimp.org>

	* configure.in: bumped our version number to 1.3.6. Added check
	for libgtkhtml-2.0.

	* plug-ins/helpbrowser/Makefile.am
	* plug-ins/helpbrowser/helpbrowser.c: started to port the help browser
	to GtkHtml2. Not all features are working yet.

	* plug-ins/helpbrowser/back.xpm
	* plug-ins/helpbrowser/forward.xpm: removed.
parent 257aaddc
2002-05-05 Sven Neumann <sven@gimp.org>
* configure.in: bumped our version number to 1.3.6. Added check
for libgtkhtml-2.0.
* plug-ins/helpbrowser/Makefile.am
* plug-ins/helpbrowser/helpbrowser.c: started to port the help browser
to GtkHtml2. Not all features are working yet.
* plug-ins/helpbrowser/back.xpm
* plug-ins/helpbrowser/forward.xpm: removed.
2002-05-04 Sven Neumann <sven@gimp.org>
* README: updated Bugs section. Mention gdkxft to avoid more
......
The GIMP: The GNU Image Manipulation Program
============================================
This is version 1.3, the developers version of The GIMP. Only use
it if you are brave and curious and want to participate development
towards the next stable release version 1.4. Please do not yet report
bugs in this version. This is a developers version. We know it has
bugs and it might not even compile. You have been warned!
This is version 1.3, the developers version of The GIMP. Only use it
if you are brave and curious and want to participate development
towards the next stable release version 1.4. This is a developers
version. We know it has bugs and it might not even compile. You have
been warned!
Some features that were present in GIMP 1.2 are disabled or not even
included in this release. This includes the Perl extension and thus
......
dnl Process this file with autoconf to produce a configure script.
AC_INIT(etc/gimprc.in)
AC_INIT(etc/gimprc.in)
GLIB_REQUIRED_VERSION=2.0.0
GTK_REQUIRED_VERSION=$GLIB_REQUIRED_VERSION
PANGOFT2_REQUIRED_VERSION=1.0.0
GTKDOC_REQUIRED_VERSION=0.9
GTKHTML2_REQUIRED_VERSION=1.99.5
#
# Making releases:
......@@ -19,7 +19,7 @@ GTKDOC_REQUIRED_VERSION=0.9
#
GIMP_MAJOR_VERSION=1
GIMP_MINOR_VERSION=3
GIMP_MICRO_VERSION=5
GIMP_MICRO_VERSION=6
GIMP_INTERFACE_AGE=0
GIMP_BINARY_AGE=0
GIMP_VERSION=$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION.$GIMP_MICRO_VERSION
......@@ -607,45 +607,10 @@ dnl Test for libXpm
dnl This is for the help browser
dnl AC_PATH_PROG(GNOME_CONFIG,gnome-config,no)
dnl if test "$GNOME_CONFIG" = "no"; then
dnl dnl Test for standalone GtkXMHTML widget
dnl HELPBROWSER=
dnl if test -n "$LIBPNG" && test -n "$LIBJPEG" && test -n "$LIBXPM"; then
dnl helpbrowser_save_LIBS=$LIBS
dnl LIBS="$LIBS $LIBPNG $LIBJPEG $LIBXPM"
dnl AC_CHECK_LIB(gtkxmhtml, gtk_xmhtml_new,
dnl GTKXMHTML_CFLAGS=$GTK_CFLAGS
dnl GTKXMHTML_LIBS="-lgtkxmhtml $LIBPNG $LIBJPEG $LIBXPM $GTK_LIBS"
dnl HELPBROWSER=helpbrowser,
dnl AC_MSG_WARN(*** Help browser plug-in will not be built (GtkXMHTML library not found) ***))
dnl LIBS=$helpbrowser_save_LIBS
dnl else
dnl AC_MSG_WARN(*** Help browser plug-in will not be built (PNG, JPEG or XPM libraries not found) ***)
dnl fi
dnl else
dnl GTKXMHTML_CFLAGS=`$GNOME_CONFIG --cflags gnomeui`
dnl GTKXMHTML_LIBS=`$GNOME_CONFIG --libs gtkxmhtml`
dnl HELPBROWSER=helpbrowser
dnl fi
dnl Sanity check to make sure the headers are there too and that gnome-config
dnl didn't lie to us
dnl if test -n "$HELPBROWSER"; then
dnl CPPFLAGS="$CPPFLAGS $GTKXMHTML_CFLAGS"
dnl LDFLAGS="$LDFLAGS `echo $GTKXMHTML_LIBS | sed 's/\(.*\)\(-lgtkxmhtml.*\)/\1/'`"
dnl LIBS="$LIBS $GTKXMHTML_LIBS"
dnl AC_MSG_CHECKING([to see if we can build with GtkXMHTML])
dnl AC_TRY_LINK([#include <gtk-xmhtml/gtk-xmhtml.h>], [return 0;],
dnl gtkxmhtml_ok=yes, gtkxmhtml_ok=no)
dnl AC_MSG_RESULT($gtkxmhtml_ok)
dnl
dnl if test "$gtkxmhtml_ok" = no; then
dnl AC_MSG_WARN(*** Help browser plug-in will not be built (GtkXMHTML setup busted) ***)
dnl HELPBROWSER=
dnl fi
dnl fi
PKG_CHECK_MODULES(GTKHTML2, libgtkhtml-2.0 >= GTKHTML2_REQUIRED_VERSION,
HELPBROWSER=helpbrowser,
AC_MSG_WARN([*** Help browser plug-in will not be built (GtkHtml2 not found) ***]))
gimpdatadir=$datadir/$PACKAGE/$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
......@@ -851,6 +816,9 @@ AC_SUBST(PANGOFT2_LIBS)
AC_SUBST(LIBART_CFLAGS)
AC_SUBST(LIBART_LIBS)
AC_SUBST(GTKHTML2_CFLAGS)
AC_SUBST(GTKHTML2_LIBS)
AC_SUBST(PKG_CONFIG)
AC_SUBST(HAVE_GLIBC_REGEX)
......@@ -891,8 +859,6 @@ AC_SUBST(GIMP_PERL)
AC_SUBST(GIMP_PERL_PO)
AC_SUBST(GIMPINSTALL)
AC_SUBST(HELPBROWSER)
AC_SUBST(GTKXMHTML_CFLAGS)
AC_SUBST(GTKXMHTML_LIBS)
AC_SUBST(HTML_DIR)
AC_SUBST(GNOME_DESKTOP_PATH)
......@@ -916,7 +882,6 @@ dnl Output the Makefiles
dnl plug-ins/perl/config.pl
dnl plug-ins/gap/Makefile
dnl plug-ins/gdyntext/Makefile
dnl plug-ins/helpbrowser/Makefile
dnl plug-ins/perl/po/Makefile.in
AC_OUTPUT([
......@@ -984,6 +949,7 @@ plug-ins/gimpressionist/Makefile
plug-ins/gimpressionist/Brushes/Makefile
plug-ins/gimpressionist/Paper/Makefile
plug-ins/gimpressionist/Presets/Makefile
plug-ins/helpbrowser/Makefile
plug-ins/ifscompose/Makefile
plug-ins/imagemap/Makefile
plug-ins/maze/Makefile
......
......@@ -5,8 +5,6 @@ libexecdir = $(gimpplugindir)/plug-ins
libexec_PROGRAMS = helpbrowser
helpbrowser_SOURCES = @STRIP_BEGIN@ \
back.xpm \
forward.xpm \
helpbrowser.c \
queue.c \
queue.h \
......@@ -18,25 +16,16 @@ AM_CPPFLAGS = @STRIP_BEGIN@ \
INCLUDES = @STRIP_BEGIN@ \
-I$(top_srcdir) \
$(GTK_CFLAGS) \
$(GTKXMHTML_CFLAGS) \
$(GTKHTML2_CFLAGS) \
-I$(includedir) \
@STRIP_END@
LDADD = @STRIP_BEGIN@ \
$(top_builddir)/libgimp/libgimpui-$(LT_RELEASE).la \
$(top_builddir)/libgimpwidgets/libgimpwidgets-$(LT_RELEASE).la \
$(top_builddir)/libgimp/libgimp-$(LT_RELEASE).la \
$(top_builddir)/libgimpwidgets/libgimpwidgets-$(LT_RELEASE).la \
$(top_builddir)/libgimpcolor/libgimpcolor-$(LT_RELEASE).la \
$(top_builddir)/libgimpbase/libgimpbase-$(LT_RELEASE).la \
$(GTK_LIBS) \
$(GTKXMHTML_LIBS) \
$(GTKHTML2_LIBS) \
$(INTLLIBS) \
@STRIP_END@
.PHONY: files
files:
@files=`ls $(DISTFILES) 2> /dev/null`; for p in $$files; do \
echo $$p; \
done
/* XPM */
static char * back_xpm[] = {
"14 14 42 1",
" c None",
". c #000000",
"+ c #C6D7C3",
"@ c #E4EBE2",
"# c #FFFFFF",
"$ c #DFE8DD",
"% c #F3F7F3",
"& c #DCE6D9",
"* c #F2F6F1",
"= c #EFF3EE",
"- c #F1F5F0",
"; c #F4F7F4",
"> c #121B12",
", c #DEE7DC",
"' c #EEF3ED",
") c #EBF1EA",
"! c #B1C7AC",
"~ c #E9EFE8",
"{ c #D7E3D5",
"] c #243221",
"^ c #375930",
"/ c #548149",
"( c #729B68",
"_ c #80A776",
": c #7DA473",
"< c #81A877",
"[ c #83AA7A",
"} c #87AC7D",
"| c #67925C",
"1 c #516F4A",
"2 c #4E7C44",
"3 c #739C6A",
"4 c #84A979",
"5 c #81A878",
"6 c #709864",
"7 c #49763F",
"8 c #719A67",
"9 c #608C56",
"0 c #46703C",
"a c #6FA763",
"b c #5B8851",
"c c #36582E",
" ..",
" ..+.",
" ..@#+.",
" ..$#%%+.",
" ..&#*=-;+.",
" .>,#'))===+.",
"..!#~{,@)===+]",
"..^/(_:<[}[}|.",
" ..1234_5}[|.",
" ..^26<_}|.",
" ..728_9.",
" ..0ab.",
" ..c.",
" .."};
/* XPM */
static char * forward_xpm[] = {
"14 14 49 1",
" c None",
". c #000000",
"+ c #E1EADF",
"@ c #FFFFFF",
"# c #F0F4EF",
"$ c #D4E0D1",
"% c #F3F7F3",
"& c #EDF2EB",
"* c #CEDCCB",
"= c #F4F7F4",
"- c #F1F5F0",
"; c #EFF3EE",
"> c #EBF1EA",
", c #C9D8C5",
"' c #E5ECE3",
") c #CBDAC7",
"! c #181818",
"~ c #2B2B2B",
"{ c #E4EBE2",
"] c #DEE7DC",
"^ c #D7E3D5",
"/ c #EEF3ED",
"( c #B1C7AC",
"_ c #9DBB90",
": c #88AC80",
"< c #83AA7C",
"[ c #85A879",
"} c #7EA476",
"| c #84A778",
"1 c #759B6C",
"2 c #59814F",
"3 c #3A5934",
"4 c #9ABB8F",
"5 c #83AA7A",
"6 c #87AC7D",
"7 c #82A87B",
"8 c #86A97C",
"9 c #759C6D",
"0 c #537C49",
"a c #445840",
"b c #80A776",
"c c #749868",
"d c #4B7040",
"e c #90B387",
"f c #749A6B",
"g c #3B5E31",
"h c #5D8554",
"i c #37592F",
"j c #3F6534",
".. ",
".+.. ",
".@#$.. ",
".@%&#*.. ",
".@=-;>-,.. ",
".@;;;>>'#)!. ",
"~@;;;>{]^]/(..",
"._:<:<[}|123..",
".4567|890a.. ",
".46b[c0d.. ",
".ebf0g.. ",
".<hi.. ",
".j.. ",
".. "};
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment