Commit 5523cc81 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

INSTALL configure.in bumped minimum required version of gtk+ to 2.12.1.

2007-12-12  Sven Neumann  <sven@gimp.org>

	* INSTALL
	* configure.in
	* app/gui/gui.c (GTK_REQUIRED_MICRO): bumped minimum required
	version of gtk+ to 2.12.1.

	* app/widgets/gimpdockbook.c (gimp_dockbook_tab_drag_motion):
	removed unused parameter that was needed for gtk+ < 2.12.1.

svn path=/trunk/; revision=24334
parent e698ec93
2007-12-12 Sven Neumann <sven@gimp.org>
* INSTALL
* configure.in
* app/gui/gui.c (GTK_REQUIRED_MICRO): bumped minimum required
version of gtk+ to 2.12.1.
* app/widgets/gimpdockbook.c (gimp_dockbook_tab_drag_motion):
removed unused parameter that was needed for gtk+ < 2.12.1.
2007-12-12 Tor Lillqvist <tml@novell.com>
* libgimpbase/gimpenv.c (gimp_toplevel_directory) [Win32]: Use the
......
......@@ -28,7 +28,7 @@ header files installed.
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need to have installed GTK+ version 2.12.0 or newer. GIMP
2. You need to have installed GTK+ version 2.12.1 or newer. GIMP
also need a recent versions of GLib (>= 2.14.1) and Pango (>= 1.12.2).
Sources for these can be grabbed from ftp://ftp.gtk.org/.
......
......@@ -272,7 +272,7 @@ gui_sanity_check (void)
#define GTK_REQUIRED_MAJOR 2
#define GTK_REQUIRED_MINOR 12
#define GTK_REQUIRED_MICRO 0
#define GTK_REQUIRED_MICRO 1
mismatch = gtk_check_version (GTK_REQUIRED_MAJOR,
GTK_REQUIRED_MINOR,
......
......@@ -675,7 +675,6 @@ gimp_dockbook_tab_drag_motion (GtkWidget *widget,
GimpDockbook *dockbook = dockable->dockbook;
GtkTargetList *target_list;
GdkAtom target_atom;
guint unused;
if (! dockbook->tab_hover_timeout ||
dockbook->tab_hover_dockable != dockable)
......@@ -694,10 +693,7 @@ gimp_dockbook_tab_drag_motion (GtkWidget *widget,
target_list = gtk_drag_dest_get_target_list (widget);
target_atom = gtk_drag_dest_find_target (widget, context, target_list);
#ifdef __GNUC__
#warning Remove "unused" as soon as we depend on GTK+ >= 2.12.1
#endif
if (gtk_target_list_find (target_list, target_atom, &unused))
if (gtk_target_list_find (target_list, target_atom, NULL))
{
gdk_drag_status (context, GDK_ACTION_MOVE, time);
gtk_drag_highlight (widget);
......
......@@ -41,7 +41,7 @@ m4_define([gimp_full_name], [GNU Image Manipulation Program])
# required versions of other packages
m4_define([glib_required_version], [2.14.1])
m4_define([gtk_required_version], [2.12.0])
m4_define([gtk_required_version], [2.12.1])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([pangoft2_required_version], [1.18.0])
m4_define([fontconfig_required_version], [2.2.0])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment