Commit 47b4c723 authored by Marc Lehmann's avatar Marc Lehmann

see plug-ins/perl/Changes

parent 5aa63839
......@@ -6,6 +6,8 @@ Revision history for Gimp-Perl extension.
- new, faster and leaner protocol (bumped protocol version number).
- added SvPV_nolen to ppport.h and made use of it everywhere.
- renamed nolib => Module.
- streamlined warning messages as not to scare the people away.
- fixed a bug in check_for_typoe (correct TRUE and FALSE).
1.089 Tue May 18 19:55:25 CEST 1999
- added colourtoalpha.
......
......@@ -727,8 +727,8 @@ static void check_for_typoe (char *croak_str, char *p)
g_snprintf (b, sizeof b, "SELECTION_%s", p); if (perl_get_cv (b, 0)) goto gotit;
g_snprintf (b, sizeof b, "%s_IMAGE", p); if (perl_get_cv (b, 0)) goto gotit;
strcpy (b, "1"); if (strEQ (b, "TRUE" )) goto gotit;
strcpy (b, "0"); if (strEQ (b, "FALSE")) goto gotit;
strcpy (b, "1"); if (strEQ (p, "TRUE" )) goto gotit;
strcpy (b, "0"); if (strEQ (p, "FALSE")) goto gotit;
return;
......
......@@ -87,51 +87,32 @@ eval "use Parse::RecDescent;"; $PRD = $@ eq "";
$] >= 5.005 or print <<EOF;
NOTICE: you are using a version of perl older than 5.005. While this
extension should run on older versions (and I try to keep source
compatibility), some people get spurious errors that go away
after upgrading to 5.005 (or to gimp-1.1). Also, some features of
Gimp DO NOT WORK WITH 5.004 or gimp-1.0 and are disabled. Since
5.005 is much better and has many many bugs fixed, an upgrade
would come in handy...
NOTICE: You are using a version of perl older than 5.005. This will reduce
the features available to the Gimp-Perl extension.
EOF
$GTK or print <<EOF;
WARNING: unable to use the Perl-Gtk interface. Most features (like
Gimp::Fu) rely on this extension. You can try to build without
it (and many scripts won't work), but it's better to install
it (version 0.5120 or higher is required, you can get it from
ftp://ftp.gimp.org/pub/gtk/perl/ or any CPAN mirror.
NOTICE: unable to use the Perl-Gtk interface. Many features (like
Gimp::Fu) rely on this extension. You can build without it (and
many scripts will be disabled or run with reduced functionality
only), but it's better to install it (version 0.5120 or higher is
required, you can get it from ftp://ftp.gimp.org/pub/gtk/perl/ or
any CPAN mirror.
EOF
$PRD or print <<EOF;
WARNING: Parse::RecDescent is not installed (correctly) on your system. This
means scm2perl (the Scheme->Perl translator) isn't usable. If you
don't need this functionality there is nothing to worry about.
Should the need arise you can install Parse::RecDescent later; it
is available from any CPAN mirror.
WARNING: Parse::RecDescent not found, scm2perl, the Scheme->Perl
translator, will not work. Should the need arise you can install
Parse::RecDescent later; it is available from any CPAN mirror.
EOF
($major,$minor,$patch)=split /[._]/,$Gtk::VERSION;
unless ($major > 0
|| ($major == 0 && $minor > 3)
|| ($major == 0 && $minor == 3 && $patch >= -1)) {
$GTK && print <<EOF;
WARNING: version 0.3 of Gtk is _required_ for this module to
build properly. You can get the newest version from
ftp://ftp.gimp.org/pub/gtk/perl/ or any CPAN mirror. Older
versions may work, but I have warned you!
EOF
}
sub MY::install {
package MY;
my $install = shift->SUPER::install(@_);
......@@ -278,7 +259,7 @@ WriteMakefile(
SUFFIX => '.gz',
},
'PREREQ_PM' => {
Gtk => 0.3,
Gtk => 0.5,
PDL => 1.99,
Data::Dumper => 2.0,
Parse::RecDescent => 1.6,
......
......@@ -55,8 +55,8 @@ static void need_pdl (void)
static void sv2net (SV *s, SV *sv)
{
if (SvLEN(sv)-SvCUR(sv) < 96)
SvGROW (sv, SvLEN(sv) + PV_INC);
if (SvLEN(s)-SvCUR(s) < 96)
SvGROW (s, SvLEN(s) + PV_INC);
if (SvROK(sv))
{
......@@ -86,7 +86,7 @@ static void sv2net (SV *s, SV *sv)
}
else if (SvOK(sv))
{
if (SvTYPE(sv) == SVt_IV)
if (SvIOK(sv))
sv_catpvf (s,"i%ld:", (long)SvIV(sv));
else
{
......@@ -177,6 +177,7 @@ args2net(...)
for (index = 0; index < items; index++)
sv2net (RETVAL, ST(index));
/*printf (">>>>%s\n",SvPV_nolen(RETVAL));*/
OUTPUT:
RETVAL
......@@ -184,6 +185,7 @@ void
net2args(s)
char * s
PPCODE:
/*printf ("<<<<%s\n",s);*/
/* this depends on a trailing zero! */
while (*s)
XPUSHs (sv_2mortal (net2sv (&s)));
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment