Commit 467581b7 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

INSTALL configure.in require gtk+ >= 2.10.6.

2007-04-16  Sven Neumann  <sven@gimp.org>

	* INSTALL
	* configure.in
	* app/gui/gui.c (gui_sanity_check): require gtk+ >= 2.10.6.


svn path=/trunk/; revision=22255
parent 316db87c
2007-04-16 Sven Neumann <sven@gimp.org>
* INSTALL
* configure.in
* app/gui/gui.c (gui_sanity_check): require gtk+ >= 2.10.6.
2007-04-16 Sven Neumann <sven@gimp.org>
* plug-ins/Lighting/lighting_ui.c: applied patch from Aurimas
......@@ -152,9 +158,9 @@
2007-03-31 Michael Schumacher <schumaml@cvs.gnome.org>
* plug-ins/common/svg.c:
* plug-ins/common/tiff.c:
* plug-ins/common/wmf.c:
* plug-ins/common/svg.c:
* plug-ins/common/tiff.c:
* plug-ins/common/wmf.c:
* plug-ins/jpeg/jpeg-load.c: some file load plug-ins did call
gimp_quit() in their load functions. This aborts the plug-in
instead of returning a GIMP_PDB_EXECUTION_ERROR. The run()
......@@ -308,7 +314,7 @@
2007-03-26 Michael Schumacher <schumaml@cvs.gnome.org>
* plug-ins/common/compressor.c (save_image, load_image):
* plug-ins/common/compressor.c (save_image, load_image):
Check if the files to be read or written and the temporary files
have been opened. Otherwise, bail out safely instead of causing a
crash. Fixes bug #422444.
......@@ -28,7 +28,7 @@ header files installed.
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need to have installed GTK+ version 2.8.17 or newer. GIMP
2. You need to have installed GTK+ version 2.10.6 or newer. GIMP
needs an even more recent version of GLib (>= 2.12.3). It also
wants Pango (>= 1.12.2). Sources for these can be grabbed from
ftp://ftp.gtk.org/.
......
......@@ -268,8 +268,8 @@ gui_sanity_check (void)
const gchar *mismatch;
#define GTK_REQUIRED_MAJOR 2
#define GTK_REQUIRED_MINOR 8
#define GTK_REQUIRED_MICRO 17
#define GTK_REQUIRED_MINOR 10
#define GTK_REQUIRED_MICRO 6
mismatch = gtk_check_version (GTK_REQUIRED_MAJOR,
GTK_REQUIRED_MINOR,
......
......@@ -41,7 +41,7 @@ m4_define([gimp_full_name], [GNU Image Manipulation Program])
# required versions of other packages
m4_define([glib_required_version], [2.12.3])
m4_define([gtk_required_version], [2.8.17])
m4_define([gtk_required_version], [2.10.6])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([pangoft2_required_version], [1.12.2])
m4_define([fontconfig_required_version], [2.2.0])
......@@ -1212,19 +1212,14 @@ AC_SUBST(LIBSVG)
####################################
# Check for gtk+ 2.10 (for GtkPrint)
# Allow to disable the print plug-in
####################################
enable_print=no
enable_print="no (disabled)"
AC_ARG_WITH(print,[ --without-print build without print support])
if test "x$with_print" != xno; then
PKG_CHECK_MODULES(PRINT, gtk+-2.0 >= 2.9.3,
enable_print="yes",
AC_MSG_RESULT([no])
enable_print="no (gtk+ >= 2.9.3 not available)")
else
enable_print="no (print support disabled)"
enable_print="yes"
fi
AM_CONDITIONAL(BUILD_PRINT, test "x$enable_print" == xyes)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment