Commit 41d932cf authored by Ed J's avatar Ed J Committed by Kevin Cozens

Make INSTALL be generated by autoconf/configure - automatically updates version numbers.

parent 8b89fdb3
--------------------------------------
Installation instructions for GIMP 2.8
Installation instructions for GIMP @GIMP_APP_VERSION@
--------------------------------------
There are some basic steps to building and installing GIMP.
GIMP 2.8 replaces earlier GIMP 2.x versions. It is advised that you
uninstall them before installing GIMP 2.8. If you want to keep your
older GIMP 2.x installation in parallel to GIMP 2.8, you have to
GIMP @GIMP_APP_VERSION@ replaces earlier GIMP 2.x versions. It is advised that you
uninstall them before installing GIMP @GIMP_APP_VERSION@ If you want to keep your
older GIMP 2.x installation in parallel to GIMP @GIMP_APP_VERSION@, you have to
choose a separate prefix which is not in your default library search
path.
GIMP 2.8 is fully backward compatible to all earlier GIMP 2.x version.
GIMP @GIMP_APP_VERSION@ is fully backward compatible to all earlier GIMP 2.x version.
Plug-ins and scripts written for GIMP 2.6 or earlier GIMP 2.x versions
will continue to work and don't need to be changed nor recompiled to
be used with GIMP 2.8.
be used with GIMP @GIMP_APP_VERSION@.
The most important part is to make sure the requirements for a build
are fulfilled. We depend on a number of tools and libraries which are
......@@ -32,29 +32,29 @@ header files installed.
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need intltool (at least 0.40.1, but preferably a newer version).
2. You need intltool (at least @INTLTOOL_REQUIRED_VERSION@, but preferably a newer version).
Intltool can be downloaded from
http://ftp.gnome.org/pub/gnome/sources/intltool/
3. You need to have GEGL version 0.3.0 or newer and babl version
0.1.11 or newer. You can get them from http://gegl.org/ or clone
3. You need to have GEGL version @GEGL_REQUIRED_VERSION@ or newer and babl version
@BABL_REQUIRED_VERSION@ or newer. You can get them from http://gegl.org/ or clone
them from the GNOME git repository:
git://git.gnome.org/babl
git://git.gnome.org/gegl
4. You need to have installed GTK+ version 2.24.10 or newer.
GIMP also need a recent versions of GLib (>= 2.36.0), GDK-Pixbuf
(>= 2.24.1), and Pango (>= 1.29.4). Sources for these can be grabbed
4. You need to have installed GTK+ version @GTK_REQUIRED_VERSION@ or newer.
GIMP also need a recent versions of GLib (>= @GLIB_REQUIRED_VERSION@), GDK-Pixbuf
(>= @GDK_PIXBUF_REQUIRED_VERSION@), and Pango (>= @PANGOCAIRO_REQUIRED_VERSION@). Sources for these can be grabbed
from ftp://ftp.gtk.org/.
5. We use cairo >= 1.10.2, which is hosted at
5. We use cairo >= @CAIRO_REQUIRED_VERSION@, which is hosted at
http://www.cairographics.org/.
6. We require PangoCairo, a Pango backend using Cairo. Make sure you
have Cairo, FreeType2 and fontconfig installed before you compile
Pango. GIMP depends on freetype2 being newer than version 2.1.7
and fontconfig 2.2.0 or newer. Older versions are known to have
Pango. GIMP depends on freetype2 being newer than version @FREETYPE2_REQUIRED_VERSION@
and fontconfig @FONTCONFIG_REQUIRED_VERSION@ or newer. Older versions are known to have
bugs that seriously affect the stability of GIMP.
7. Access of remote files is implemented in the URI plug-in. There
......@@ -93,9 +93,21 @@ header files installed.
of make, we'd appreciate if you'd send us a patch with the changes.
15. Install GIMP by running `make install'. In order to avoid clashes
with other versions of GIMP, we install a binary called gimp-2.8.
with other versions of GIMP, we install a binary called gimp-@GIMP_APP_VERSION@.
By default there's also a link created so that you can type 'gimp'
to start gimp-2.8.
to start gimp-@GIMP_APP_VERSION@.
16. Summary of required packages and what version you need:
cairo: @CAIRO_REQUIRED_VERSION@
glib: @GLIB_REQUIRED_VERSION@
pangocairo: @PANGOCAIRO_REQUIRED_VERSION@
atk: @ATK_REQUIRED_VERSION@
fontconfig: @FONTCONFIG_REQUIRED_VERSION@
babl: @BABL_REQUIRED_VERSION@
gdk_pixbuf: @GDK_PIXBUF_REQUIRED_VERSION@
gegl: @GEGL_REQUIRED_VERSION@
freetype2: @FREETYPE2_REQUIRED_VERSION@
Please make sure you don't have any old GTK+-2.x, jpeg, etc. libraries
lying around on your system, otherwise configure may fail to find the
......@@ -107,8 +119,8 @@ packages are included below. Here is an illustration of commands that
might be used to build and install GIMP. The actual configuration,
compilation and installation output is not shown.
% tar xvfz gimp-2.8.x.tar.gz # unpack the sources
% cd gimp-2.8.x # change to the toplevel directory
% tar xvfz gimp-@GIMP_VERSION@.tar.gz # unpack the sources
% cd gimp-@GIMP_VERSION@ # change to the toplevel directory
% ./configure # run the `configure' script
% make # build GIMP
% make install # install GIMP
......@@ -143,8 +155,8 @@ These are:
is intended primarily as a convenience for developers.
--with-gimpdir=DIR. This option changes the default directory
GIMP uses to search for its configuration files from ~/.gimp-2.8
(the directory .gimp-2.8 in the users home directory) to DIR.
GIMP uses to search for its configuration files from ~/.gimp-@GIMP_APP_VERSION@
(the directory .gimp-@GIMP_APP_VERSION@ in the users home directory) to DIR.
--enable-binreloc. When compiled for Linux with this option enabled,
GIMP will be binary relocatable. Plug-ins and data files will
......@@ -240,8 +252,8 @@ These are:
if you call configure with --without-desktop-dir.
--disable-default-binary. Use this option if you don't want to make
gimp-2.8 the default GIMP installation. Otherwise a link called
gimp pointing to the gimp-2.8 executable will be installed.
gimp-@GIMP_APP_VERSION@ the default GIMP installation. Otherwise a link called
gimp pointing to the gimp-@GIMP_APP_VERSION@ executable will be installed.
--disable-gimp-console. Use this option if you don't want the
gimp-console binary to be built in addition to the standard binary.
......@@ -263,7 +275,7 @@ The `make' command builds several things:
- A bunch of public libraries in the directories starting with 'libgimp'.
- The plug-in programs in the 'plug-ins' directory.
- Some modules in the 'modules' subdirectory.
- The main GIMP program 'gimp-2.8' in `app'.
- The main GIMP program 'gimp-@GIMP_APP_VERSION@' in `app'.
The `make install' commands installs the GIMP header files associated
with the libgimp libraries, the plug-ins, some data files and the GIMP
......
......@@ -50,6 +50,7 @@ m4_define([cairo_required_version], [1.12.2])
m4_define([cairo_pdf_required_version], [1.12.2])
m4_define([pangocairo_required_version], [1.29.4])
m4_define([fontconfig_required_version], [2.2.0])
m4_define([freetype2_required_version], [2.1.7])
m4_define([gtkdoc_required_version], [1.0])
m4_define([webkit_required_version], [1.6.1])
m4_define([alsa_required_version], [1.0.0])
......@@ -65,7 +66,7 @@ m4_define([libpng_required_version], [1.2.37])
m4_define([liblzma_required_version], [5.0.0])
m4_define([openexr_required_version], [1.6.1])
m4_define([gtk_mac_integration_required_version], [1.0.1])
m4_define([intltool_required_version], [0.40.1])
AC_INIT([GIMP], [gimp_version],
[http://bugzilla.gnome.org/enter_bug.cgi?product=GIMP],
......@@ -125,12 +126,24 @@ GTK_REQUIRED_VERSION=gtk_required_version
CAIRO_REQUIRED_VERSION=cairo_required_version
GEGL_REQUIRED_VERSION=gegl_required_version
GEXIV2_REQUIRED_VERSION=gexiv2_required_version
PANGOCAIRO_REQUIRED_VERSION=pangocairo_required_version
BABL_REQUIRED_VERSION=babl_required_version
FONTCONFIG_REQUIRED_VERSION=fontconfig_required_version
FREETYPE2_REQUIRED_VERSION=freetype2_required_version
ATK_REQUIRED_VERSION=atk_required_version
INTLTOOL_REQUIRED_VERSION=intltool_required_version
AC_SUBST(GLIB_REQUIRED_VERSION)
AC_SUBST(GDK_PIXBUF_REQUIRED_VERSION)
AC_SUBST(GTK_REQUIRED_VERSION)
AC_SUBST(CAIRO_REQUIRED_VERSION)
AC_SUBST(GEGL_REQUIRED_VERSION)
AC_SUBST(GEXIV2_REQUIRED_VERSION)
AC_SUBST(PANGOCAIRO_REQUIRED_VERSION)
AC_SUBST(BABL_REQUIRED_VERSION)
AC_SUBST(FONTCONFIG_REQUIRED_VERSION)
AC_SUBST(FREETYPE2_REQUIRED_VERSION)
AC_SUBST(ATK_REQUIRED_VERSION)
AC_SUBST(INTLTOOL_REQUIRED_VERSION)
# The symbol GIMP_UNSTABLE is defined above for substitution in
# Makefiles and conditionally defined here as a preprocessor symbol
......@@ -457,7 +470,7 @@ fi
# Internationalisation
######################
IT_PROG_INTLTOOL(0.40.1)
IT_PROG_INTLTOOL(intltool_required_version)
AM_GLIB_GNU_GETTEXT
......@@ -2130,6 +2143,7 @@ _______EOF
])
AC_CONFIG_FILES([
INSTALL
tools/Makefile
tools/pdbgen/Makefile
libgimp/Makefile
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment