Commit 3f18f32c authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

put GIO check back in as we need it to initialize GIO_CFLAGS and GIO_LIBS.

2008-03-28  Sven Neumann  <sven@gimp.org>

	* configure.in: put GIO check back in as we need it to initialize
	GIO_CFLAGS and GIO_LIBS. Renamed --without-gio to --without-gvfs.

	* INSTALL: changed accordingly.

	* plug-ins/uri/Makefile.am
	* plug-ins/uri/uri-backend-gio.c
	* plug-ins/uri/uri-backend-gvfs.c: renamed the gio backend to gvfs.

svn path=/trunk/; revision=25284
parent 18605017
2008-03-28 Sven Neumann <sven@gimp.org>
* configure.in: put GIO check back in as we need it to initialize
GIO_CFLAGS and GIO_LIBS. Renamed --without-gio to --without-gvfs.
* INSTALL: changed accordingly.
* plug-ins/uri/Makefile.am
* plug-ins/uri/uri-backend-gio.c
* plug-ins/uri/uri-backend-gvfs.c: renamed the gio backend to gvfs.
2008-03-28 Michael Natterer <mitch@gimp.org>
* plug-ins/script-fu/scripts/line-nova.scm (script-fu-line-nova):
......@@ -15,7 +26,7 @@
2008-03-28 Sven Neumann <sven@gimp.org>
* libgimpwidgets/gimphelpui.c: show a custom tooltip for menu
items and inform the user the she can get more help by pressing F1.
items and inform the user that she can get more help by pressing F1.
2008-03-28 Sven Neumann <sven@gimp.org>
......
......@@ -33,7 +33,7 @@ header files installed.
http://svn.gnome.org/svn/gegl/trunk
3. You need to have installed GTK+ version 2.12.1 or newer. GIMP
also need a recent versions of GLib (>= 2.14.1) and Pango (>= 1.12.2).
also need a recent versions of GLib (>= 2.16.1) and Pango (>= 1.18.0).
Sources for these can be grabbed from ftp://ftp.gtk.org/.
4. We require PangoFT2, a Pango backend that uses FreeType2. Make
......@@ -42,7 +42,7 @@ header files installed.
http://www.freetype.org/. Fontconfig from
http://freedesktop.org/fontconfig/. GIMP depends on freetype2
being newer than version 2.1.7 and fontconfig 2.2.0 or newer.
Older versions are known to have bugs that seriously affect
Older versions are known to have bugs that seriously affect the
stability of GIMP.
5. We use libart2. Grab the module libart_lgpl out of GNOME SVN or
......@@ -165,8 +165,8 @@ These are:
--without-print. If for some reason you don't want to build the Print
plug-in based on the GtkPrint API, you can build with --without-print.
--without-gio. If you don't want to use GIO to access remote
files, you can pass --without-gio to the configure script.
--without-gvfs. If you don't want to use GIO/GVfs to access remote
files, you can pass --without-gvfs to the configure script.
--without-gnomevfs. If you don't want to use gnomevfs to access remote
files, you can pass --without-gnomevfs to the configure script.
......
......@@ -436,6 +436,8 @@ AM_PATH_GLIB_2_0(glib_required_version, :,
PKG_CHECK_MODULES(GMODULE_NO_EXPORT, gmodule-no-export-2.0)
PKG_CHECK_MODULES(GIO, gio-2.0)
AC_MSG_CHECKING([if GLib is version 2.19.0 or newer])
if $PKG_CONFIG --atleast-version=2.19.0 glib-2.0; then
have_glib_2_19=yes
......@@ -1275,16 +1277,16 @@ AC_SUBST(LIBPOPPLER)
###############################################
# Check for gio, gnome-vfs and libcurl
# Check for gio/gvfs, gnome-vfs and libcurl
# (and optionally libgnomeui and gnome-keyring)
###############################################
uri_plugin=no
AC_ARG_WITH(gio, [ --without-gio build without GIO support])
AC_ARG_WITH(gvfs, [ --without-gvfs build without GIO/GVfs support])
AM_CONDITIONAL(HAVE_GIO, test "x$with_gio" != xno)
AM_CONDITIONAL(HAVE_GVFS, test "x$with_gvfs" != xno)
gnome_vfs_modules="gnome-vfs-2.0 >= gnome_vfs_required_version"
......@@ -1339,8 +1341,8 @@ fi
AM_CONDITIONAL(HAVE_LIBCURL, test "x$have_libcurl" = xyes)
if test "x$with_gio" != xno; then
uri_plugin="yes (using GIO)"
if test "x$with_gvfs" != xno; then
uri_plugin="yes (using GIO/GVfs)"
elif test "x$have_gnomevfs" = xyes; then
uri_plugin="yes (using gnome-vfs)"
elif test "x$have_libcurl" = xyes; then
......
......@@ -18,8 +18,8 @@ libexecdir = $(gimpplugindir)/plug-ins
libexec_PROGRAMS = uri
if HAVE_GIO
backend_sources = gimpmountoperation.c gimpmountoperation.h uri-backend-gio.c
if HAVE_GVFS
backend_sources = gimpmountoperation.c gimpmountoperation.h uri-backend-gvfs.c
backend_cflags = $(GIO_CFLAGS)
backend_libs = $(GIO_LIBS)
else
......
/* GIMP - The GNU Image Manipulation Program
* Copyright (C) 1995 Spencer Kimball and Peter Mattis
*
* URI plug-in, GIO backend
* URI plug-in, GIO/GVfs backend
* Copyright (C) 2008 Sven Neumann <sven@gimp.org>
*
* This program is free software; you can redistribute it and/or modify
......
......@@ -271,8 +271,8 @@ plug-ins/selection-to-path/selection-to-path.c
plug-ins/sgi/sgi.c
plug-ins/twain/twain.c
plug-ins/uri/gimpmountoperation.c
plug-ins/uri/uri-backend-gio.c
plug-ins/uri/uri-backend-gnomevfs.c
plug-ins/uri/uri-backend-gvfs.c
plug-ins/uri/uri-backend-libcurl.c
plug-ins/uri/uri-backend-wget.c
plug-ins/uri/uri.c
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment