Commit 3c15e5ed authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

removed checks for PangoFT2.

2008-10-31  Sven Neumann  <sven@gimp.org>

	* INSTALL: 
	* configure.in: removed checks for PangoFT2.

	* app/config/Makefile.am
	* app/text/Makefile.am
	* app/Makefile.am: removed use of PANGOFT2_CFLAGS and 
PANGOFT2_LIBS.


svn path=/trunk/; revision=27490
parent 437c046d
2008-10-31 Sven Neumann <sven@gimp.org>
* INSTALL:
* configure.in: removed checks for PangoFT2.
* app/config/Makefile.am
* app/text/Makefile.am
* app/Makefile.am: removed use of PANGOFT2_CFLAGS and PANGOFT2_LIBS.
2008-10-31 Sven Neumann <sven@gimp.org>
* app/text/gimpfont.c
......
......@@ -45,16 +45,13 @@ header files installed.
also need a recent versions of GLib (>= 2.16.1) and Pango (>= 1.18.0).
Sources for these can be grabbed from ftp://ftp.gtk.org/.
5. We require PangoFT2, a Pango backend that uses FreeType2. Make
sure you have FreeType2 and fontconfig installed before you
compile Pango. FreeType2 can be downloaded from
http://www.freetype.org/. Fontconfig from
http://freedesktop.org/fontconfig/. GIMP depends on freetype2
being newer than version 2.1.7 and fontconfig 2.2.0 or newer.
Older versions are known to have bugs that seriously affect the
stability of GIMP.
6. We use cairo, which is hosted at http://www.cairographics.org/.
5. We use cairo, which is hosted at http://www.cairographics.org/.
6. We require PangoCairo, a Pango backend using Cairo. Make sure you
have Cairo, FreeType2 and fontconfig installed before you compile
Pango. GIMP depends on freetype2 being newer than version 2.1.7
and fontconfig 2.2.0 or newer. Older versions are known to have
bugs that seriously affect the stability of GIMP.
7. We use dbus-glib if available. Grab it from
http://dbus.freedesktop.org/releases/dbus-glib/
......
......@@ -89,7 +89,6 @@ AM_CPPFLAGS = \
INCLUDES = \
-I$(top_srcdir) \
$(GTK_CFLAGS) \
$(PANGOFT2_CFLAGS) \
$(PANGOCAIRO_CFLAGS) \
$(DBUS_GLIB_CFLAGS) \
$(GEGL_CFLAGS) \
......@@ -137,7 +136,6 @@ gimp_2_7_LDADD = \
$(libgimpconfig) \
$(libgimpbase) \
$(GTK_LIBS) \
$(PANGOFT2_LIBS) \
$(PANGOCAIRO_LIBS) \
$(FONTCONFIG_LIBS) \
$(FREETYPE_LIBS) \
......@@ -182,7 +180,6 @@ gimp_console_2_7_LDADD = \
$(libgimpbase) \
$(GDK_PIXBUF_LIBS) \
$(CAIRO_LIBS) \
$(PANGOFT2_LIBS) \
$(PANGOCAIRO_LIBS) \
$(FONTCONFIG_LIBS) \
$(FREETYPE_LIBS) \
......
......@@ -66,7 +66,7 @@ test_config_DEPENDENCIES = $(gimpconfig_libs)
test_config_LDFLAGS = \
-u $(SYMPREFIX)xcf_init \
-u $(SYMPREFIX)internal_procs_init \
-u $(SYMPREFIX)gimp_coords_mix \
-u $(SYMPREFIX)gimp_coords_interpolate_bezier \
-u $(SYMPREFIX)gimp_plug_in_manager_restore \
-u $(SYMPREFIX)gimp_image_map_config_get_type
......@@ -95,10 +95,8 @@ test_config_LDADD = \
$(libgimpmath) \
$(libgimpconfig) \
$(libgimpbase) \
$(CAIRO_LIBS) \
$(PANGOFT2_LIBS) \
$(PANGOCAIRO_LIBS) \
$(GDK_PIXBUF_LIBS) \
$(LIBART_LIBS) \
$(GEGL_LIBS) \
$(GLIB_LIBS)
......
......@@ -9,7 +9,6 @@ INCLUDES = \
-I$(top_builddir)/app \
-I$(top_srcdir)/app \
$(GEGL_CFLAGS) \
$(PANGOFT2_CFLAGS) \
$(PANGOCAIRO_CFLAGS) \
$(GDK_PIXBUF_CFLAGS) \
-I$(includedir)
......
......@@ -46,7 +46,6 @@ m4_define([glib_required_version], [2.16.1])
m4_define([gtk_required_version], [2.12.5])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([pangocairo_required_version], [1.20.1])
m4_define([pangoft2_required_version], [1.18.0])
m4_define([fontconfig_required_version], [2.2.0])
m4_define([cairo_required_version], [1.6.4])
m4_define([gtkdoc_required_version], [1.0])
......@@ -507,11 +506,6 @@ CFLAGS="$PANGOCAIRO_CFLAGS $CFLAGS"
PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= fontconfig_required_version)
PKG_CHECK_MODULES(PANGOFT2, pangoft2 >= pangoft2_required_version, :,
AC_MSG_ERROR([Test for PangoFT2 failed.
*** We require Pango with the optional support for FreeType2 compiled in.
*** See the file 'INSTALL' for more help.]))
AC_MSG_CHECKING([if Pango is version 1.21.0 or newer])
if $PKG_CONFIG --atleast-version=1.21.0 pango; then
have_pango_1_21=yes
......@@ -520,7 +514,7 @@ else
fi
AC_MSG_RESULT($have_pango_1_21)
CFLAGS="$PANGOFT2_CFLAGS $CFLAGS"
CFLAGS="$PANGOCAIRO_CFLAGS $CFLAGS"
AC_MSG_CHECKING([if Pango is built with a recent fontconfig])
AC_TRY_COMPILE([#include <fontconfig/fontconfig.h>],
......@@ -533,9 +527,9 @@ CFLAGS=$gimp_save_CFLAGS
if test "x$fontconfig_ok" = xno; then
AC_MSG_ERROR([
*** You have a fontconfig >= fontconfig_required_version installed on your system, but your
*** PangoFT2 is using an older version. This old version is probably in
*** Pango library is using an older version. This old version is probably in
*** /usr/X11R6. Look at the above output, and note that the result for
*** FONTCONFIG_CFLAGS is not in the result for PANGOFT2_CFLAGS, and that
*** FONTCONFIG_CFLAGS is not in the result for PANGOCAIRO_CFLAGS, and that
*** there is likely an extra -I line, other than the ones for GLIB,
*** Freetype, and Pango itself. That's where your old fontconfig files are.
*** Rebuild pango, and make sure that it uses the newer fontconfig. The
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment