Commit 3b352087 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

depend on GTK+ >= 2.14.4.

2009-03-05  Sven Neumann  <sven@gimp.org>

	* configure.in: depend on GTK+ >= 2.14.4.

	* INSTALL: changed accordingly.


svn path=/trunk/; revision=28109
parent 70c88aed
2009-03-05 Sven Neumann <sven@gimp.org>
* configure.in: depend on GTK+ >= 2.14.4.
* INSTALL: changed accordingly.
2009-03-05 Sven Neumann <sven@gimp.org>
Bug 573695 1-bit white background saved as PBM becomes all black
......
......@@ -41,7 +41,7 @@ header files installed.
http://svn.gnome.org/svn/babl/trunk
http://svn.gnome.org/svn/gegl/trunk
4. You need to have installed GTK+ version 2.12.5 or newer. GIMP
4. You need to have installed GTK+ version 2.14.4 or newer. GIMP
also need a recent versions of GLib (>= 2.18.0) and Pango (>= 1.20.1).
Sources for these can be grabbed from ftp://ftp.gtk.org/.
......
......@@ -43,7 +43,7 @@ m4_define([gimp_full_name], [GNU Image Manipulation Program])
m4_define([babl_required_version], [0.0.23])
m4_define([gegl_required_version], [0.0.22])
m4_define([glib_required_version], [2.18.0])
m4_define([gtk_required_version], [2.12.5])
m4_define([gtk_required_version], [2.14.4])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([cairo_required_version], [1.6.0])
m4_define([pangocairo_required_version], [1.20.1])
......@@ -485,8 +485,8 @@ AM_PATH_GTK_2_0(gtk_required_version, :,
AC_MSG_ERROR(Test for GTK+ failed. See the file 'INSTALL' for help.),
gthread)
AC_MSG_CHECKING([if GTK+ is version 2.17.0 or newer])
if $PKG_CONFIG --atleast-version=2.17.0 gtk+-2.0; then
AC_MSG_CHECKING([if GTK+ is version 2.15.0 or newer])
if $PKG_CONFIG --atleast-version=2.15.0 gtk+-2.0; then
have_gtk_2_15=yes
else
have_gtk_2_15=no
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment