Commit 36853815 authored by Mukund Sivaraman's avatar Mukund Sivaraman

build: Require dependencies of file-compressor

Without the dependencies of file-compressor (currently zlib, libbzip2
and liblzma), configure fails now. file-compressor is referenced in too
many places for its functionality to be optional.
parent 89081075
......@@ -68,24 +68,27 @@ header files installed.
configure. The configure script will then try to detect another
method for accessing remote files.
9. You may want to install other third party libraries or programs
that are needed for some of the available plug-ins. We recommend
to check that the following libraries are installed: lcms,
libpng, libjpeg, libpoppler, libtiff, webkit, libmng, librsvg,
libwmf, libz, libbzip2, libgs (Ghostscript), libaa and libjasper.
9. The file-compressor plug-in requires zlib, libbzip2, and liblzma to
be installed. All these libraries are required dependencies.
10. The Python extension requires Python development headers to be
10. You may want to install other third party libraries or programs
that are needed for some of the available plug-ins. We recommend to
check that the following libraries are installed: lcms, libpng,
libjpeg, libpoppler, libtiff, webkit, libmng, librsvg, libwmf,
libgs (Ghostscript), libaa and libjasper.
11. The Python extension requires Python development headers to be
present. You will also need PyGTK and the respective development
headers.
11. Configure GIMP by running the `configure' script. You may want
12. Configure GIMP by running the `configure' script. You may want
to pass some options to it, see below.
12. Build GIMP by running `make'. The use of GNU make is recommended.
13. Build GIMP by running `make'. The use of GNU make is recommended.
If you need to tweak the build to make it work with other flavours
of make, we'd appreciate if you'd send us a patch with the changes.
13. Install GIMP by running `make install'. In order to avoid clashes
14. Install GIMP by running `make install'. In order to avoid clashes
with other versions of GIMP, we install a binary called gimp-2.8.
By default there's also a link created so that you can type 'gimp'
to start gimp-2.8.
......
......@@ -1192,6 +1192,11 @@ AM_CONDITIONAL(HAVE_LIBLZMA, test "x$have_liblzma" = xyes)
have_compressor=no
if test "x$have_zlib" = xyes && test "x$have_libbzip2" = xyes && test "x$have_liblzma" = xyes; then
have_compressor=yes
else
AC_MSG_ERROR([
*** One or more compression libraries are unavailable. zlib, libbzip2
*** and liblzma are required build dependencies. See the file 'INSTALL'
*** for help.])
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment