Commit 36735492 authored by Michael Natterer's avatar Michael Natterer 😴

Depend on lots of newer library versions

Gegl >= 0.1.8, Babl >= 0.1.6, Gdk-Pixbuf >= 1.24.0, Pango >= 1.29.4,
GLib >= 2.28.8, GTK+ 2.24.7

Which means depending on a gazillion of bug fixes, which means less
pain for GIMP 2.8 users, and less useless bugzilla traffic eating
developer resources.
parent 82480557
......@@ -36,19 +36,20 @@ header files installed.
Intltool can be downloaded from
http://ftp.gnome.org/pub/gnome/sources/intltool/
3. You need to have GEGL version 0.1.6 or newer and babl version
0.1.4 or newer. You can get them from http://gegl.org/ or clone
3. You need to have GEGL version 0.1.8 or newer and babl version
0.1.6 or newer. You can get them from http://gegl.org/ or clone
them from the GNOME git repository:
git://git.gnome.org/babl
git://git.gnome.org/gegl
4. You need to have installed GTK+ version 2.24.3 or newer.
GIMP also need a recent versions of GLib (>= 2.28.1), GDK-PixBuf
(>= 2.22.1), and Pango (>= 1.22.0). Sources for these can be grabbed
4. You need to have installed GTK+ version 2.24.7 or newer.
GIMP also need a recent versions of GLib (>= 2.28.8), GDK-PixBuf
(>= 2.24.0), and Pango (>= 1.29.4). Sources for these can be grabbed
from ftp://ftp.gtk.org/.
5. We use cairo, which is hosted at http://www.cairographics.org/.
5. We use cairo >= 1.20.2, which is hosted at
http://www.cairographics.org/.
6. We require PangoCairo, a Pango backend using Cairo. Make sure you
have Cairo, FreeType2 and fontconfig installed before you compile
......
......@@ -252,7 +252,7 @@ gui_sanity_check (void)
{
#define GTK_REQUIRED_MAJOR 2
#define GTK_REQUIRED_MINOR 24
#define GTK_REQUIRED_MICRO 3
#define GTK_REQUIRED_MICRO 7
const gchar *mismatch = gtk_check_version (GTK_REQUIRED_MAJOR,
GTK_REQUIRED_MINOR,
......
......@@ -131,7 +131,7 @@ sanity_check_glib (void)
{
#define GLIB_REQUIRED_MAJOR 2
#define GLIB_REQUIRED_MINOR 28
#define GLIB_REQUIRED_MICRO 1
#define GLIB_REQUIRED_MICRO 8
const gchar *mismatch = glib_check_version (GLIB_REQUIRED_MAJOR,
GLIB_REQUIRED_MINOR,
......@@ -193,8 +193,8 @@ static gchar *
sanity_check_pango (void)
{
#define PANGO_REQUIRED_MAJOR 1
#define PANGO_REQUIRED_MINOR 22
#define PANGO_REQUIRED_MICRO 0
#define PANGO_REQUIRED_MINOR 29
#define PANGO_REQUIRED_MICRO 4
const gchar *mismatch = pango_version_check (PANGO_REQUIRED_MAJOR,
PANGO_REQUIRED_MINOR,
......@@ -316,8 +316,8 @@ static gchar *
sanity_check_gdk_pixbuf (void)
{
#define GDK_PIXBUF_REQUIRED_MAJOR 2
#define GDK_PIXBUF_REQUIRED_MINOR 22
#define GDK_PIXBUF_REQUIRED_MICRO 1
#define GDK_PIXBUF_REQUIRED_MINOR 24
#define GDK_PIXBUF_REQUIRED_MICRO 0
if (! sanity_check_version (gdk_pixbuf_major_version, GDK_PIXBUF_REQUIRED_MAJOR,
gdk_pixbuf_minor_version, GDK_PIXBUF_REQUIRED_MINOR,
......@@ -351,7 +351,7 @@ sanity_check_babl (void)
#define BABL_REQUIRED_MAJOR 0
#define BABL_REQUIRED_MINOR 1
#define BABL_REQUIRED_MICRO 4
#define BABL_REQUIRED_MICRO 6
babl_get_version (&babl_major_version,
&babl_minor_version,
......@@ -389,7 +389,7 @@ sanity_check_gegl (void)
#define GEGL_REQUIRED_MAJOR 0
#define GEGL_REQUIRED_MINOR 1
#define GEGL_REQUIRED_MICRO 6
#define GEGL_REQUIRED_MICRO 8
gegl_get_version (&gegl_major_version,
&gegl_minor_version,
......
......@@ -40,14 +40,14 @@ m4_define([gimp_stable],
m4_define([gimp_full_name], [GNU Image Manipulation Program])
# required versions of other packages
m4_define([babl_required_version], [0.1.4])
m4_define([gegl_required_version], [0.1.6])
m4_define([glib_required_version], [2.28.1])
m4_define([gtk_required_version], [2.24.3])
m4_define([gdk_pixbuf_required_version], [2.22.1])
m4_define([babl_required_version], [0.1.6])
m4_define([gegl_required_version], [0.1.8])
m4_define([glib_required_version], [2.28.8])
m4_define([gtk_required_version], [2.24.7])
m4_define([gdk_pixbuf_required_version], [2.24.0])
m4_define([cairo_required_version], [1.10.2])
m4_define([cairo_pdf_required_version], [1.10.2])
m4_define([pangocairo_required_version], [1.22.0])
m4_define([pangocairo_required_version], [1.29.4])
m4_define([fontconfig_required_version], [2.2.0])
m4_define([gtkdoc_required_version], [1.0])
m4_define([webkit_required_version], [1.1.0])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment