Commit 35318286 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

INSTALL NEWS updated for the 2.0 release.

2004-03-23  Sven Neumann  <sven@gimp.org>

	* INSTALL
	* NEWS
	* README: updated for the 2.0 release.
parent fa4fb1e6
2004-03-23 Sven Neumann <sven@gimp.org>
* INSTALL
* NEWS
* README: updated for the 2.0 release.
2004-03-23 Simon Budig <simon@gimp.org>
* plug-ins/script-fu/scripts/alien-glow-arrow.scm: fixed
THIS IS A DEVELOPMENT VERSION OF THE GIMP!
If you are looking for the stable version, use GIMP 1.2. We do
however encourage you to try this GIMP-2.0 prerelease. Read on
further to learn more about the installation process...
Installation instructions for GIMP 2.0
--------------------------------------
There are some basic steps to building and installing the GIMP.
......@@ -12,8 +8,8 @@ are fulfilled. We depend on a number of tools and libraries which are
listed below. For libraries this means you need to also have the
header files installed.
Please note that GIMP-1.2 and GIMP-1.3/2.0 peacefully coexist. You don't
need to deinstall the 1.2 version.
Please note that GIMP 1.2 and GIMP 2.0 peacefully coexist. You don't
need to uninstall the 1.2 version.
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
......@@ -46,8 +42,10 @@ need to deinstall the 1.2 version.
of make, we'd appreciate if you'd send us a patch with the changes.
8. Install the GIMP by running `make install'. In order to avoid clashes
with an installed stable version of The GIMP, we install a binary
called gimp-1.3.
with other versions of The GIMP, we install a binary called gimp-2.0.
By default there's also a link created so that you can type 'gimp'
to start gimp-2.0. If you have the 1.2 version installed, you should
still be able to run it using 'gimp-1.2'.
Unless you are experienced with building software from source, you
should not attempt to build all these libraries yourself. We suggest
......@@ -62,8 +60,8 @@ packages are included below. Here is an illustration of commands that
might be used to build and install the GIMP. The actual configuration,
compilation and installation output is not shown.
% tar xvfz gimp-1.3.x.tar.gz # unpack the sources
% cd gimp-1.3.x # change to the toplevel directory
% tar xvfz gimp-2.0.x.tar.gz # unpack the sources
% cd gimp-2.0.x # change to the toplevel directory
% ./configure # run the `configure' script
% make # build the GIMP
% make install # install the GIMP
......@@ -92,8 +90,8 @@ recognizes. These are:
is intended primarily as a convenience for developers.
--enable-gimpdir=DIR. This option changes the default directory
the gimp uses to search for its configuration files from ~/.gimp-1.3
(the directory .gimp-1.3 in the users home directory) to DIR.
the gimp uses to search for its configuration files from ~/.gimp-2.0
(the directory .gimp-2.0 in the users home directory) to DIR.
--without-libtiff, --without-libjpeg, --without-libpng. configure
will bail out if libtiff, libjpeg or libpng can not be found. You
......@@ -155,15 +153,15 @@ recognizes. These are:
created if the desktop directories don't exist or you used
--without-desktop-dir.
--enable-default-binary. Use this option if you want to make gimp-1.3
the default gimp installation. A link called gimp pointing to the
gimp-1.3 executable will be installed then.
--disable-default-binary. Use this option if you don't want to make
gimp-2.0 the default gimp installation. Otherwise a link called
gimp pointing to the gimp-2.0 executable will be installed.
The `make' command builds several things:
- A bunch of public libraries in the directories starting with 'libgimp'.
- The plug-in programs in the 'plug-ins' directory.
- Some modules in the 'modules' subdirectory.
- The main GIMP program 'gimp-1.3' in `app'.
- The main GIMP program 'gimp-2.0' in `app'.
The `make install' commands installs the gimp header files associated
with the libgimp libraries, the plug-ins, some data files and the GIMP
......
......@@ -3,9 +3,21 @@
A Colorspace Odyssey
GIMP 1.3 is the development branch of The GIMP. Here's where the
development takes place on the road to the next stable release
GIMP version 2.0.
GIMP 1.3 used to be the development branch of The GIMP. Here's where
the development took place on the road to GIMP version 2.0. This file
lists the changes for each release in this development cycle.
Bugs fixed in GIMP 2.0.0
========================
- 137766: compress text undo steps (Sven)
- 137876: set a default height for dock windows (Sven, Simon)
- 137502: check for buggy intltool versions (Raphael)
- 137930: portability fix for Solaris (Sven)
- 137968: workaround GIOChannel misfeature on win32 (Tor)
- 137957: bugfix in floating selection code (Sven, Mitch)
- 136868: fixed alien glow arrow script (Simon)
Bugs fixed in GIMP 2.0rc1
=========================
......
The GIMP: The GNU Image Manipulation Program
============================================
This is a release candidate of GIMP version 2.0. Unless there are
major problems, this will be released as GIMP 2.0 very soon. Your
feedback can help to make the 2.0 release a success. If you
encounter any problems, please report them to our bug-tracker a
bugzilla.gnome.org. There are still a number of known problems, so
please check first if your problem has already been reported.
GIMP 2.0 installs side-by-side with GIMP 1.2 so there's no need to
uninstall GIMP 1.2 (but sooner or later you will not be using it any
longer...).
This is GIMP version 2.0, a stable release of the GNU Image
Manipulation Program. GIMP 2.0 installs side-by-side with GIMP 1.2 so
there's no need to uninstall GIMP 1.2 (but sooner or later you will
not be using it any longer...).
Some features that were present in GIMP 1.2 are not included in this
release. The perl bindings as well as all the perl scripts are not any
longer included in this source tree. They have been moved into its own
module called gimp-perl. Sooner or later there will be a gimp-perl
release for GIMP 2.0. GAP, a set of plug-ins that used to live in the
Video submenu has also become a separate package. Expect a preview
release of this software for GIMP 2.0 soon.
Video submenu has also become a separate package and can be downloaded
from ftp://ftp.gimp.org/pub/gimp/plug-ins/v2.0/gap/.
For detailed installation instructions, see the file INSTALL.
......@@ -42,7 +36,7 @@ forms-based interface.
The latest version of The GIMP can be found at:
http://www.gimp.org/download/
http://www.gimp.org/downloads/
2. Mailing Lists
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment