Commit 222d3349 authored by Michael Natterer's avatar Michael Natterer 😴 Committed by Michael Natterer

depend on pango 1.18

2007-11-11  Michael Natterer  <mitch@gimp.org>

	* configure.in: depend on pango 1.18

	* app/text/gimpfontlist.c (gimp_font_list_add_font): remove
	workaround for old pango appending "Non-Rotated" to font names.


svn path=/trunk/; revision=24118
parent 6087b866
2007-11-11 Michael Natterer <mitch@gimp.org>
* configure.in: depend on pango 1.18
* app/text/gimpfontlist.c (gimp_font_list_add_font): remove
workaround for old pango appending "Non-Rotated" to font names.
2007-11-11 Martin Nordholts <martinn@svn.gnome.org>
* app/tools/gimprectangleselecttool.[ch]: Don't expose private
......
......@@ -147,38 +147,27 @@ gimp_font_list_add_font (GimpFontList *list,
PangoContext *context,
PangoFontDescription *desc)
{
GimpFont *font;
gchar *name;
gsize len;
gchar *name;
if (! desc)
return;
name = font_desc_to_string (desc);
len = strlen (name);
if (! g_utf8_validate (name, len, NULL))
if (g_utf8_validate (name, -1, NULL))
{
g_free (name);
return;
}
GimpFont *font;
#ifdef __GNUC__
#warning remove this as soon as we depend on Pango 1.16.5
#endif
if (g_str_has_suffix (name, " Not-Rotated"))
name[len - strlen (" Not-Rotated")] = '\0';
font = g_object_new (GIMP_TYPE_FONT,
"name", name,
"pango-context", context,
NULL);
font = g_object_new (GIMP_TYPE_FONT,
"name", name,
"pango-context", context,
NULL);
gimp_container_add (GIMP_CONTAINER (list), GIMP_OBJECT (font));
g_object_unref (font);
}
g_free (name);
gimp_container_add (GIMP_CONTAINER (list), GIMP_OBJECT (font));
g_object_unref (font);
}
#ifdef USE_FONTCONFIG_DIRECTLY
......
......@@ -43,7 +43,7 @@ m4_define([gimp_full_name], [GNU Image Manipulation Program])
m4_define([glib_required_version], [2.14.1])
m4_define([gtk_required_version], [2.12.0])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([pangoft2_required_version], [1.12.2])
m4_define([pangoft2_required_version], [1.18.0])
m4_define([fontconfig_required_version], [2.2.0])
m4_define([gtkdoc_required_version], [1.0])
m4_define([gtkhtml2_required_version], [2.0.0])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment