Commit 1a246b69 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

added "ms" (Malay) now that all po files are there.

2003-10-25  Sven Neumann  <sven@gimp.org>

	* configure.in (ALL_LINUGUAS): added "ms" (Malay) now that all po
	files are there.

	(PANGOFT2_REQUIRED_VERSION) depend on PangoFT2 >= 1.2.2. There are
	a couple of bug-fixes that are needed to make the text tool work.
	Actually you should use at least version 1.2.4.

	(GTK_REQUIRED_VERSION): depend on GTK+ >= 2.2.2. Earlier versions
	had bugs that we don't want to work around any longer.

	* INSTALL: document this change.

	* app/gui/gui.c (gui_post_init): removed the GTK+ version check.

	* app/text/gimptext.[ch]: added properties for letter spacing and
	kerning for compatibility with future GIMP versions implementing
	these features.
parent 78215a79
2003-10-25 Sven Neumann <sven@gimp.org>
* configure.in (ALL_LINUGUAS): added "ms" (Malay) now that all po
files are there.
(PANGOFT2_REQUIRED_VERSION) depend on PangoFT2 >= 1.2.2. There are
a couple of bug-fixes that are needed to make the text tool work.
Actually you should use at least version 1.2.4.
(GTK_REQUIRED_VERSION): depend on GTK+ >= 2.2.2. Earlier versions
had bugs that we don't want to work around any longer.
* INSTALL: document this change.
* app/gui/gui.c (gui_post_init): removed the GTK+ version check.
* app/text/gimptext.[ch]: added properties for letter spacing and
kerning for compatibility with future GIMP versions implementing
these features.
2003-10-25 Sven Neumann <sven@gimp.org>
* plug-ins/gimpressionist/Makefile.am: fixed(?) dependencies.
......@@ -18,7 +38,7 @@
* plug-ins/gimpressionist/gimpressionist.c: changed accordingly.
t2003-10-24 Maurits Rijk <lpeek.mrijk@consunet.nl>
2003-10-24 Maurits Rijk <lpeek.mrijk@consunet.nl>
* plug-ins/gimpressionist/about.c: removed...
* plug-ins/gimpressionist/logo.xpm: and replaced by new .xpm file so
......@@ -6726,7 +6746,7 @@ t2003-10-24 Maurits Rijk <lpeek.mrijk@consunet.nl>
2003-08-22 Hasbullah Bin Pit <sebol@ikhlas.com>
* configure.in(ALL_LINGUAS): Added "ms" (Malay).
* configure.in(ALL_LINGUAS): Added "ms" (Malay).
2003-08-22 Simon Budig <simon@gimp.org>
......@@ -12,14 +12,17 @@ are fulfilled. We depend on a number of tools and libraries which are
listed below. For libraries this means you need to also have the
header files installed.
Please note that GIMP-1.2 and GIMP-1.3 peacefully coexist. You don't
need to deinstall the 1.2 version.
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need to have installed GTK+ version 2.2.0 or better. Do not try to
use an older GTK+ version (1.2.x), it will not work. GTK+-2.2 itself
needs recent versions of GLib, Pango and ATK. Grab them from
ftp://ftp.gtk.org/. GTK+-2.x and friends can be installed side by side
with GTK+-1.2.
2. You need to have installed GTK+ version 2.2.2 or better. Do not
try to use an older GTK+ version (1.2.x), it will not work.
GTK+-2.2 itself needs recent versions of GLib, Pango and ATK.
Sources for these can be grabbed from ftp://ftp.gtk.org/.
GTK+-2.x and friends can be installed side by side with GTK+-1.2.
3. We require PangoFT2, a Pango backend that uses FreeType2. Make sure
you have FreeType2 and fontconfig installed before you compile Pango.
......@@ -175,7 +178,7 @@ When ./configure fails
scripts. The most recent version is available from
http://www.freedesktop.org/software/pkgconfig/
'configure' tries to compile and run a short GTK program. There are
'configure' tries to compile and run a short GTK+ program. There are
several reasons why this might fail:
* pkg-config could not find the file 'gtk+-2.0.pc' that gets installed
......
......@@ -203,18 +203,6 @@ gui_post_init (Gimp *gimp)
if (GIMP_GUI_CONFIG (gimp->config)->show_tips)
gimp_dialog_factory_dialog_new (global_dialog_factory,
"gimp-tips-dialog", -1);
#ifdef __GNUC__
#warning FIXME: remove this as soon as we depend on GTK+ >= 2.2.2
#endif
if (gtk_check_version (2, 2, 2) != NULL)
gimp_message_box (GIMP_STOCK_WILBER_EEK, NULL,
"Please upgrade your GTK+ installation!\n\n"
"The GTK+ version you are using is too old.\n"
"Please upgrade to GTK+ version 2.2.2 or better\n"
"or your extended input devices (tablets) will\n"
"not work at all!",
NULL, NULL);
}
......
......@@ -52,12 +52,14 @@ enum
PROP_HINTING,
PROP_AUTOHINT,
PROP_ANTIALIAS,
PROP_KERNING,
PROP_LANGUAGE,
PROP_BASE_DIR,
PROP_COLOR,
PROP_JUSTIFICATION,
PROP_INDENTATION,
PROP_LINE_SPACING,
PROP_LETTER_SPACING,
PROP_BOX_MODE,
PROP_BOX_WIDTH,
PROP_BOX_HEIGHT,
......@@ -180,6 +182,10 @@ gimp_text_class_init (GimpTextClass *klass)
"antialias", NULL,
TRUE,
0);
GIMP_CONFIG_INSTALL_PROP_BOOLEAN (object_class, PROP_KERNING,
"kerning", NULL,
FALSE,
0);
GIMP_CONFIG_INSTALL_PROP_STRING (object_class, PROP_LANGUAGE,
"language", NULL,
language,
......@@ -211,6 +217,11 @@ gimp_text_class_init (GimpTextClass *klass)
N_("Additional line spacing (in pixels)"),
-8192.0, 8192.0, 0.0,
0);
GIMP_CONFIG_INSTALL_PROP_DOUBLE (object_class, PROP_LETTER_SPACING,
"letter-spacing",
N_("Additional letter spacing (in pixels)"),
-8192.0, 8192.0, 0.0,
0);
GIMP_CONFIG_INSTALL_PROP_ENUM (object_class, PROP_BOX_MODE,
"box-mode",
NULL,
......@@ -298,6 +309,9 @@ gimp_text_get_property (GObject *object,
case PROP_ANTIALIAS:
g_value_set_boolean (value, text->antialias);
break;
case PROP_KERNING:
g_value_set_boolean (value, text->kerning);
break;
case PROP_BASE_DIR:
g_value_set_enum (value, text->base_dir);
break;
......@@ -316,6 +330,9 @@ gimp_text_get_property (GObject *object,
case PROP_LINE_SPACING:
g_value_set_double (value, text->line_spacing);
break;
case PROP_LETTER_SPACING:
g_value_set_double (value, text->letter_spacing);
break;
case PROP_BOX_MODE:
g_value_set_enum (value, text->box_mode);
break;
......@@ -372,6 +389,9 @@ gimp_text_set_property (GObject *object,
case PROP_ANTIALIAS:
text->antialias = g_value_get_boolean (value);
break;
case PROP_KERNING:
text->kerning = g_value_get_boolean (value);
break;
case PROP_LANGUAGE:
g_free (text->language);
text->language = g_value_dup_string (value);
......@@ -392,6 +412,9 @@ gimp_text_set_property (GObject *object,
case PROP_LINE_SPACING:
text->line_spacing = g_value_get_double (value);
break;
case PROP_LETTER_SPACING:
text->letter_spacing = g_value_get_double (value);
break;
case PROP_BOX_MODE:
text->box_mode = g_value_get_enum (value);
break;
......
......@@ -47,12 +47,14 @@ struct _GimpText
gboolean hinting;
gboolean autohint;
gboolean antialias;
gboolean kerning;
gchar *language;
GimpTextDirection base_dir;
GimpRGB color;
GimpTextJustification justify;
gdouble indent;
gdouble line_spacing;
gdouble letter_spacing;
GimpTextBoxMode box_mode;
gdouble box_width;
gdouble box_height;
......
......@@ -15,9 +15,9 @@ AC_INIT(app/core/gimp.c)
############
GLIB_REQUIRED_VERSION=2.2.0
GTK_REQUIRED_VERSION=$GLIB_REQUIRED_VERSION
GTK_REQUIRED_VERSION=2.2.2
GDKPIXBUF_REQUIRED_VERSION=$GTK_REQUIRED_VERSION
PANGOFT2_REQUIRED_VERSION=1.2.0
PANGOFT2_REQUIRED_VERSION=1.2.2
FONTCONFIG_REQUIRED_VERSION=2.2.0
GTKDOC_REQUIRED_VERSION=1.0
GTKHTML2_REQUIRED_VERSION=2.0.0
......@@ -25,12 +25,13 @@ GIMPPRINT_REQUIRED_VERSION=4.2.0
GIMPPRINT_TOONEW_VERSION=4.3.0
RSVG_REQUIRED_VERSION=2.2.0
AC_SUBST(FONTCONFIG_REQUIRED_VERSION)
AC_SUBST(PANGOFT2_REQUIRED_VERSION)
AC_SUBST(GLIB_REQUIRED_VERSION)
AC_SUBST(GTK_REQUIRED_VERSION)
AC_SUBST(PANGOFT2_REQUIRED_VERSION)
AC_SUBST(FONTCONFIG_REQUIRED_VERSION)
AC_SUBST(GTKHTML2_REQUIRED_VERSION)
AC_SUBST(GIMPPRINT_REQUIRED_VERSION)
AC_SUBST(GIMPPRINT_TOONEW_VERSION)
AC_SUBST(GTKHTML2_REQUIRED_VERSION)
AC_SUBST(RSVG_REQUIRED_VERSION)
#
......@@ -294,7 +295,7 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE",
dnl Note to translators: you MUST have .po files in all 4 directories: po,
dnl po-libgimp, po-plug-ins, and po-script-fu before adding you language
dnl code to ALL_LINGUAS
ALL_LINGUAS="ca cs da de el en_GB es fi fr ga gl he hu hr id it ja ko nl no pl pt pt_BR ro ru sk sr sr@Latn sv tr uk vi yi zh_CN zh_TW"
ALL_LINGUAS="ca cs da de el en_GB es fi fr ga gl he hu hr id it ja ko ms nl no pl pt pt_BR ro ru sk sr sr@Latn sv tr uk vi yi zh_CN zh_TW"
AC_PROG_INTLTOOL
AM_GLIB_GNU_GETTEXT
......@@ -321,21 +322,8 @@ LIBS=$gimp_save_LIBS
AC_PATH_XTRA
dnl Additional test for GTK+ 2.2.2. We want to avoid bug reports
dnl related to XInput support (known to be broken in 2.2.1) but we do
dnl not want to make the upgrade mandatory yet. The extra test can
dnl be removed once GTK+ 2.2.2 or later becomes mandatory (this is
dnl planned for the next stable release).
AM_PATH_GTK_2_0(2.2.2,gimp_broken_gtk=no,gimp_broken_gtk=yes)
if test x$gimp_broken_gtk = xyes; then
AM_PATH_GTK_2_0($GTK_REQUIRED_VERSION,
AC_MSG_WARN([Please upgrade your GTK+ installation!
*** The GTK+ version you are using is too old.
*** Please upgrade to GTK+ version 2.2.2 or better
*** or your extended input devices (tablets) will not
*** work at all!]),
AC_MSG_ERROR(Test for GTK failed. See the file 'INSTALL' for help.))
fi
AM_PATH_GTK_2_0($GTK_REQUIRED_VERSION,,
AC_MSG_ERROR(Test for GTK+ failed. See the file 'INSTALL' for help.))
PKG_CHECK_MODULES(GDK_PIXBUF, gdk-pixbuf-2.0 >= $GDKPIXBUF_REQUIRED_VERSION)
AC_SUBST(GDK_PIXBUF_CFLAGS)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment