Commit 1504cfa9 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

INSTALL bumped required version of GTK+ to 2.12.0.

2007-11-04  Sven Neumann  <sven@gimp.org>

	* INSTALL
	* configure.in: bumped required version of GTK+ to 2.12.0.

	* app/sanity.c (sanity_check_glib)
	* app/gui/gui.c (gui_sanity_check): updated sanity checks. 


svn path=/trunk/; revision=24049
parent 790cffc1
2007-11-04 Sven Neumann <sven@gimp.org>
* INSTALL
* configure.in: bumped required version of GTK+ to 2.12.0.
* app/sanity.c (sanity_check_glib)
* app/gui/gui.c (gui_sanity_check): updated sanity checks.
2007-11-02 Michael Natterer <mitch@gimp.org>
* app/widgets/gimphistogramview.[ch]: added API to set the
......
......@@ -28,10 +28,9 @@ header files installed.
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need to have installed GTK+ version 2.10.13 or newer. GIMP
needs an even more recent version of GLib (>= 2.14.1). It also
wants Pango (>= 1.12.2). Sources for these can be grabbed from
ftp://ftp.gtk.org/.
2. You need to have installed GTK+ version 2.12.0 or newer. GIMP
also need a recent versions of GLib (>= 2.14.1) and Pango (>= 1.12.2).
Sources for these can be grabbed from ftp://ftp.gtk.org/.
3. We require PangoFT2, a Pango backend that uses FreeType2. Make
sure you have FreeType2 and fontconfig installed before you
......
......@@ -271,8 +271,8 @@ gui_sanity_check (void)
const gchar *mismatch;
#define GTK_REQUIRED_MAJOR 2
#define GTK_REQUIRED_MINOR 10
#define GTK_REQUIRED_MICRO 13
#define GTK_REQUIRED_MINOR 12
#define GTK_REQUIRED_MICRO 0
mismatch = gtk_check_version (GTK_REQUIRED_MAJOR,
GTK_REQUIRED_MINOR,
......
......@@ -87,8 +87,8 @@ sanity_check_glib (void)
const gchar *mismatch;
#define GLIB_REQUIRED_MAJOR 2
#define GLIB_REQUIRED_MINOR 12
#define GLIB_REQUIRED_MICRO 3
#define GLIB_REQUIRED_MINOR 14
#define GLIB_REQUIRED_MICRO 1
mismatch = glib_check_version (GLIB_REQUIRED_MAJOR,
GLIB_REQUIRED_MINOR,
......
......@@ -41,7 +41,7 @@ m4_define([gimp_full_name], [GNU Image Manipulation Program])
# required versions of other packages
m4_define([glib_required_version], [2.14.1])
m4_define([gtk_required_version], [2.10.13])
m4_define([gtk_required_version], [2.12.0])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([pangoft2_required_version], [1.12.2])
m4_define([fontconfig_required_version], [2.2.0])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment