Commit 14079834 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

configure.in made the build of gimp-remote optional and disable it by

2008-07-11  Sven Neumann  <sven@gimp.org>

	* configure.in
	* docs/Makefile.am: made the build of gimp-remote optional and
	disable it by default.

	* INSTALL: document the --enable-gimp-remote configure option.


svn path=/trunk/; revision=26126
parent 0edb0e7e
2008-07-11 Sven Neumann <sven@gimp.org>
* configure.in
* docs/Makefile.am: made the build of gimp-remote optional and
disable it by default.
* INSTALL: document the --enable-gimp-remote configure option.
2008-07-11 Tor Lillqvist <tml@novell.com>
* app/unique.c (gimp_unique_filename_to_uri): Check GError being
......
......@@ -230,6 +230,10 @@ These are:
gimp-console binary to be built in addition to the standard binary.
gimp-console is useful for command-line batch mode or as a server.
--enable-gimp-remote. Use this option if you want the gimp-remote
binary to be built. This only works with X11 and it is obsolete if#
your platform has DBus support.
--disable-python. If for some reason you don't want to build the
Python based pygimp plug-in, you can use --disable-python.
......
......@@ -888,16 +888,25 @@ if test "x$enable_mp" != "xno"; then
[Define to 1 to enable support for multiple processors.])
fi
###################################################
# gimp-remote is obsolete, but can still be enabled
###################################################
AC_ARG_ENABLE(gimp-remote,
[ --enable-gimp-remote build gimp-remote utility (default=no)],
enable_gimp_remote=yes,
enable_gimp_remote="no (not enabled)")
################################
# Some plug-ins are X11 specific
################################
GIMP_COMMAND='gimp-gimp_app_version'
# Check if building for GTK+-X11
gdk_target=`$PKG_CONFIG --variable=target gtk+-2.0`
have_libxmu="no (building for $gdk_target)"
if test "$gdk_target" = x11; then
# doc-shooter is X11 specific
......@@ -912,16 +921,13 @@ if test "$gdk_target" = x11; then
LDFLAGS="$LDFLAGS $X_LIBS"
# Test for Xmu
enable_gimp_remote=yes
if test -z "$LIBXMU"; then
AC_CHECK_LIB(Xmu, XmuClientWindow,
[AC_CHECK_HEADERS(X11/Xmu/WinUtil.h,
GIMP_REMOTE='gimp-remote-gimp_app_version$(EXEEXT)';
GIMP_COMMAND='gimp-remote-gimp_app_version'
have_libxmu=yes
LIBXMU="$X_LIBS $X_PRE_LIBS -lX11 -lXmu -lXt",
[enable_gimp_remote="no (XMU header file not found)"],[#include <gdk/gdkx.h>])],
[enable_gimp_remote="no (XMU library not found)"], -lXt -lX11)
[have_libxmu="no (XMU header file not found)"],[#include <gdk/gdkx.h>])],
[have_libxmu="no (XMU library not found)"], -lXt -lX11)
LIBSCREENSHOT="$LIBXMU"
fi
......@@ -940,9 +946,6 @@ if test "$gdk_target" = x11; then
[Define to 1 to if the XFIXES X extension is available])
LIBSCREENSHOT="$LIBSCREENSHOT $XFIXES_LIBS",
true)
else
enable_gimp_remote="no (building for $gdk_target)"
fi
AC_SUBST(LIBXMU)
......@@ -950,7 +953,21 @@ AC_SUBST(LIBSCREENSHOT)
AC_SUBST(DOC_SHOOTER)
if test x"$enable_gimp_remote" = xyes; then
enable_gimp_remote="$have_libxmu"
fi
if test x"$enable_gimp_remote" = xyes; then
GIMP_REMOTE='gimp-remote-gimp_app_version$(EXEEXT)'
GIMP_REMOTE_MANPAGE='gimp-remote-gimp_app_version.1'
GIMP_COMMAND='gimp-remote-gimp_app_version'
else
GIMP_COMMAND='gimp-gimp_app_version'
fi
AC_SUBST(GIMP_REMOTE)
AC_SUBST(GIMP_REMOTE_MANPAGE)
AC_SUBST(GIMP_COMMAND)
......
## Process this file with automake to produce Makefile.in
EXTRA_DIST = \
gimp-remote.1.in \
Wilber.xcf.gz \
Wilber.xcf.gz.README \
Wilber_Construction_Kit.xcf.gz
......@@ -8,7 +9,7 @@ EXTRA_DIST = \
mans = \
gimp-$(GIMP_APP_VERSION).1 \
gimprc-$(GIMP_APP_VERSION).5 \
gimp-remote-$(GIMP_APP_VERSION).1
$(GIMP_REMOTE_MANPAGE)
man_MANS = \
$(mans) \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment