Commit 113252af authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

added FreeType2 URL and suggest to use GNU make.

2002-06-06  Sven Neumann  <sven@gimp.org>

	* INSTALL: added FreeType2 URL and suggest to use GNU make.

	* configure.in: improved output in case of missing PangoFT2.
parent 1cbdc95f
2002-06-06 Sven Neumann <sven@gimp.org>
* INSTALL: added FreeType2 URL and suggest to use GNU make.
* configure.in: improved output in case of missing PangoFT2.
2002-06-05 Michael Natterer <mitch@gimp.org>
* app/tools/gimprectselecttool.c: fixed #84157: allow the tool to
......
......@@ -14,10 +14,11 @@ There are some basic steps to building and installing the GIMP:
by side with GTK+-1.2.
3. We require PangoFT2, a Pango backend that uses FreeType2. Make sure
you have FreeType2 installed before you compile Pango.
you have FreeType2 installed before you compile Pango. It can be
downloaded from http://www.freetype.org/.
4. We use libart2. Grab the module libart_lgpl out of GNOME CVS or
fetch the tarball from
fetch the tarball from
ftp://ftp.gnome.org/pub/gnome/pre-gnome2/sources/libart_lgpl/
5. You may want to install other third party libraries or programs that
......@@ -27,7 +28,9 @@ There are some basic steps to building and installing the GIMP:
6. Configure the GIMP by running the `configure' script. You may want
to pass some options to it, see below.
7. Build the GIMP by running `make'.
7. Build the GIMP by running `make'. The use of GNU make is recommened.
If you need to tweak the build to make it work with other flavours
of make, we'd appreciate if you'd send us a patch with the changes.
8. Install the GIMP by running `make install'. In order to avoid clashes
with an installed stable version of The GIMP, we install a binary
......
......@@ -264,7 +264,10 @@ AC_PATH_XTRA
AM_PATH_GTK_2_0($GTK_REQUIRED_VERSION,,
AC_MSG_ERROR(Test for GTK failed. See the file 'INSTALL' for help.))
PKG_CHECK_MODULES(PANGOFT2, pangoft2 >= $PANGOFT2_REQUIRED_VERSION)
PKG_CHECK_MODULES(PANGOFT2, pangoft2 >= $PANGOFT2_REQUIRED_VERSION,,
AC_MSG_ERROR([Test for PangoFT2 failed.
*** We require Pango with the optional support for FreeType2 compiled in.
*** See the file 'INSTALL' for more help.]))
AC_SUBST(PANGOFT2_CFLAGS)
AC_SUBST(PANGOFT2_LIBS)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment