Commit 0fa2ef91 authored by Jehan's avatar Jehan

app: add a reason string for internal zlib compression in GIMP 2.10.

Even though chosen as a parameter to gimp_image_get_xcf_version() and
not a feature within the image itself, we also want to list this reason
in the compatibility list.
parent 7448c7f8
......@@ -2527,7 +2527,11 @@ gimp_image_get_xcf_version (GimpImage *image,
/* need version 8 for zlib compression */
if (zlib_compression)
version = MAX (8, version);
{
ADD_REASON (g_strdup_printf (_("Internal zlib compression was "
"added in %s"), "GIMP 2.10"));
version = MAX (8, version);
}
/* if version is 10 (lots of new layer modes), go to version 11 with
* 64 bit offsets right away
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment