Commit 0904b1e9 authored by Michael Natterer's avatar Michael Natterer 😴

configure.ac, INSTALL.in: remove traces of libcurl and the URI plug-in

and fix formatting of "Summary of optional packages" in INSTALL.in
parent 980ba7f8
......@@ -70,47 +70,39 @@ header files installed.
will likely have it installed, but you may have to install a
development package for the headers.
7. Access of remote files is implemented in the URI plug-in. There
are several possible implementations for this. The implementation
used is determined when you configure GIMP. By default the
GIO/GVfs backend is used. If you don't have GVfs support on your
target platform, you should pass the '--without-gvfs' option to
configure. The configure script will then try to detect another
method for accessing remote files.
8. The file-compressor plug-in requires zlib, libbzip2, and liblzma to
9. The file-compressor plug-in requires zlib, libbzip2, and liblzma to
be installed. All these libraries are required dependencies.
9. For metadata access GIMP requires the gexiv2 library. It is hosted
10. For metadata access GIMP requires the gexiv2 library. It is hosted
at http://redmine.yorba.org/projects/gexiv2/wiki .
10. Some other third party libraries or programs are needed for some
11. Some other third party libraries or programs are needed for some
of the available plug-ins. libpng, libjpeg and lcms are hard
dependencies that can not be disabled.
11. You may want to install other third party libraries or programs
12. You may want to install other third party libraries or programs
that are needed for some of the available plug-ins. We recommend
to check that the following libraries are installed: libpoppler,
libtiff, webkit, libmng, librsvg, libwmf, libgs (Ghostscript),
libaa and libjasper.
12. The Python extension requires Python 2 development headers (@PYTHON2_REQUIRED_VERSION@
13. The Python extension requires Python 2 development headers (@PYTHON2_REQUIRED_VERSION@
or newer) to be present. You will also need PyGTK and the
respective development headers.
13. Configure GIMP by running the `configure' script. You may want
14. Configure GIMP by running the `configure' script. You may want
to pass some options to it, see below.
14. Build GIMP by running `make'. The use of GNU make is recommended.
15. Build GIMP by running `make'. The use of GNU make is recommended.
If you need to tweak the build to make it work with other flavours
of make, we'd appreciate if you'd send us a patch with the changes.
15. Install GIMP by running `make install'. In order to avoid clashes
16. Install GIMP by running `make install'. In order to avoid clashes
with other versions of GIMP, we install a binary called gimp-@GIMP_APP_VERSION@.
By default there's also a link created so that you can type 'gimp'
to start gimp-@GIMP_APP_VERSION@.
16. Summary of required packages and what version you need:
17. Summary of required packages and what version you need:
ATK: @ATK_REQUIRED_VERSION@
babl: @BABL_REQUIRED_VERSION@
......@@ -130,25 +122,25 @@ header files installed.
pangocairo: @PANGOCAIRO_REQUIRED_VERSION@
zlib
17. Summary of optional packages:
18. Summary of optional packages:
Package Name | Version | Feature
Package Name Version Feature
libaa - ASCII art
gs - ghostscript
webkit @WEBKIT_REQUIRED_VERSION@ Help browser & webpage
libjasper - JPEG 2000
libmng - MNG
openexr @OPENEXR_REQUIRED_VERSION@ OpenEXR
libpoppler @POPPLER_REQUIRED_VERSION@ PDF import
poppler-data - PDF import (optional: rendering of CJK and Cyrillic)
cairo-pdf @CAIRO_PDF_REQUIRED_VERSION@ PDF export
python 2 @PYTHON2_REQUIRED_VERSION@ Python plug-ins
librsvg @RSVG_REQUIRED_VERSION@ SVG
libtiff - TIFF
libwmf @WMF_REQUIRED_VERSION@ WMF
libXcursor - X11 Mouse Cursor
libxpm - XPM
libaa - ASCII art
gs - ghostscript
webkit @WEBKIT_REQUIRED_VERSION@ Help browser & webpage
libjasper - JPEG 2000
libmng - MNG
openexr @OPENEXR_REQUIRED_VERSION@ OpenEXR
libpoppler @POPPLER_REQUIRED_VERSION@ PDF import
poppler-data - PDF import (optional: rendering of CJK and Cyrillic)
cairo-pdf @CAIRO_PDF_REQUIRED_VERSION@ PDF export
python 2 @PYTHON2_REQUIRED_VERSION@ Python plug-ins
librsvg @RSVG_REQUIRED_VERSION@ SVG
libtiff - TIFF
libwmf @WMF_REQUIRED_VERSION@ WMF
libXcursor - X11 Mouse Cursor
libxpm - XPM
Please make sure you don't have any old GTK+-2.x, jpeg, etc. libraries
......@@ -246,12 +238,6 @@ These are:
--without-print. If for some reason you don't want to build the Print
plug-in based on the GtkPrint API, you can build with --without-print.
--without-gvfs. If you don't want to use GIO/GVfs to access remote
files, you can pass --without-gvfs to the configure script.
--without-libcurl. If you don't want to use libcurl to access remote
files, you can pass --without-libcurl to the configure script.
--without-alsa. If you don't want to compile ALSA support into the
MIDI input controller module, you can use the --without-alsa option.
......
......@@ -60,7 +60,6 @@ m4_define([rsvg_required_version], [2.36.0])
m4_define([wmf_required_version], [0.2.8])
m4_define([pygtk_required_version], [2.10.4])
m4_define([poppler_required_version], [0.12.4])
m4_define([libcurl_required_version], [7.15.1])
m4_define([libgudev_required_version], [167])
m4_define([gexiv2_required_version], [0.6.1])
m4_define([lcms_required_version], [2.2])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment