Commit f9a2979b authored by Marc Lehmann's avatar Marc Lehmann
Browse files

see plug-ins/perl/Changes

parent 90fb8d33
......@@ -2,8 +2,11 @@ Revision history for Gimp-Perl extension.
- moved the xlfd_size function from Gimp::Fu into Gimp
(and maybe later into Gimp::Util?)
- Functions in Gimp::Util are now treated in the same way
- functions in Gimp::Util are now treated in the same way
as PDB functions (when the module is loaded)
- improved handling of "make clean" to make it less perl-ish
and more gnu-ish
- enabled full testsuite (keep your fingers crossed)
1.051 Tue Jan 19 21:10:20 CET 1999
- corrected a minor typoe found by Stefan Traby <stefan@sime.com>
......
......@@ -15,6 +15,13 @@ sub MY::const_loadlibs {
$self->SUPER::const_loadlibs(@_);
}
sub MY::postamble {
<<"EOF";
clean ::
test -f Makefile || mv -f Makefile.old Makefile
EOF
}
WriteMakefile(
'NAME' => 'Gimp::Lib',
'VERSION_FROM' => '../Gimp.pm',
......
......@@ -22,6 +22,7 @@ etc/configure.in
etc/aclocal.m4
etc/config.h.in
etc/config.pl.in
etc/configure.frag
Gimp/Makefile.PL
Gimp/Lib.xs
Gimp/Lib.pm
......
......@@ -25,9 +25,9 @@ gimp-1.1 ;)
If you decide to run these tests (please!), I'd be glad to hear
success stories (and of course any bug-reports ;)
Do you want me to make these tests [n]? ";
Do you want me to make these tests [y]? ";
$EXTENSIVE_TESTS = (<STDIN> =~ /^[yYjJ]/) ? 1 : 0;
$EXTENSIVE_TESTS = (<STDIN> !~ /^[nN]/) ? 1 : 0;
}
print "\n";
......@@ -41,7 +41,6 @@ Do you want me to make these tests [n]? ";
$ENV{IN_GIMP}=0;
exit system("./etc/configure",@ARGV)>>8;
} else {
shift @ARGV;
do './config.pl';
}
......@@ -53,19 +52,19 @@ $] >= 5.005 or print <<EOF;
WARNING: you are using a version of perl older than 5.005. While this
extension should run on older versions (and I try to keep source
compatibility), some people get spurious errors that go away after
upgrading to 5.005. Since 5.005 is much better and has many many
bugs fixed, an upgrade wpuld come in handy...
compatibility), some people get spurious errors that go away
after upgrading to 5.005. Since 5.005 is much better and has many
many bugs fixed, an upgrade wpuld come in handy...
EOF
$GTK or print <<EOF;
WARNING: unable to use the Perl-Gtk interface. Some features (like
Gimp::Fu) rely on this extension. You can try to build without it,
but it's better to install it (version 0.3 or higher is required,
you can get it from ftp://ftp.gimp.org/pub/gtk/perl/ or any
CPAN mirror.
Gimp::Fu) rely on this extension. You can try to build without
it, but it's better to install it (version 0.3 or higher is
required, you can get it from ftp://ftp.gimp.org/pub/gtk/perl/ or
any CPAN mirror.
EOF
......@@ -74,8 +73,9 @@ $PDL or print <<EOF;
WARNING: unable to use PDL (the perl data language). This means that
Gimp::PDL is non-functional. Unless you plan to use Tile/PixelRgn
functions together with PDL, this is harmless. Gimp::PDL will be
installed, just in case you later install PDL. You can get PDL
from any CPAN mirror.
installed, just in case you later install PDL. The plug-ins using
PDL, however, will NOT BE INSTALLED. You can get PDL from any CPAN
mirror.
EOF
......@@ -104,8 +104,8 @@ unless ($major > 0
|| ($major == 0 && $minor == 3 && $patch >= -1)) {
print <<EOF;
WARNING: version 0.3 of Gtk is _required_ for this module to build
properly. You can get the newest version from
WARNING: version 0.3 of Gtk is _required_ for this module to
build properly. You can get the newest version from
ftp://ftp.gimp.org/pub/gtk/perl/ or any CPAN mirror. Older
versions may work, but I have warned you!
......@@ -116,11 +116,14 @@ sub MY::postamble {
(my $GIMPTOOL2 = $GIMPTOOL) =~ s/^\.\./..\/../;
<<"EOF";
objclean :: clean
maintainer-clean :: realclean
objclean :: realclean
distclean :: realclean
check :: test
clean ::
test -f Makefile || mv -f Makefile.old Makefile
install :: install-plugins
install-plugins:
......@@ -131,14 +134,12 @@ install-plugins:
-cd examples && $GIMPTOOL2 --install-admin-bin PDB
-cd examples && $GIMPTOOL2 --install-admin-bin alpha2color.pl
-cd examples && $GIMPTOOL2 --install-admin-bin tex-to-float
-cd examples && $GIMPTOOL2 --install-admin-bin ditherize
-cd examples && $GIMPTOOL2 --install-admin-bin ditherize.pl
-cd examples && $GIMPTOOL2 --install-admin-bin border.pl
-cd examples && $GIMPTOOL2 --install-admin-bin view3d.pl
EOF
}
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
WriteMakefile(
'dist' => {
'PREOP' => 'chmod -R u=rwX,go=rX . ;',
......@@ -166,14 +167,14 @@ WriteMakefile(
'INC' => "$CPPFLAGS $CFLAGS $GIMP_INC_NOUI $DEFS",
'DEFINE' => ($IN_GIMP ? " -DIN_GIMP" : ""),
'realclean' => { FILES => "config.status config.cache config.log config.pl config.h" },
'clean' => { FILES => "Makefile.old config.pl" },
'clean' => { FILES => "Makefile.old stamp-h" },
);
$IN_GIMP or print <<EOF;
Hopefully, Gimp is now correctly configured. you can now enter "make", "make
test" and "make install".
Hopefully, Gimp is now correctly configured. you can now enter "make",
"make test" and "make install".
EOF
......
......@@ -10,6 +10,8 @@ make test TEST_VERBOSE=1
bugs
* auto-edit shebang
* only install plug-ins that really work
[DONE] * gimptool 1.0 doesn't support -n or --noui
* perl_fu_webify in homepage-logo.pl
[????] * save_image should be called for non-null return values
......
......@@ -27,3 +27,5 @@ AC_SUBST(GIMP)
AC_SUBST(GIMPTOOL)
AC_SUBST(GIMP_CFLAGS)
AC_SUBST(GIMP_LIBS)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment