Commit ea13e816 authored by Jehan's avatar Jehan

Bug 750105 - Migrating 2.8 themes to 2.9/2.10

Old themes should not be copied over to the GIMP 2.9/2.10 config at
first launch since they won't be compatible anyway. Let's go the less
painful way by dropping old themes rather than trying to salvage themes
which we know will be broken by design.
parent 9b322532
......@@ -741,8 +741,9 @@ user_install_migrate_files (GimpUserInstall *install)
else if (g_file_test (source, G_FILE_TEST_IS_DIR))
{
/* skip these directories for all old versions */
if (strcmp (basename, "tmp") == 0 ||
strcmp (basename, "tool-options") == 0)
if (strcmp (basename, "tmp") == 0 ||
strcmp (basename, "tool-options") == 0 ||
strcmp (basename, "themes") == 0)
{
goto next_file;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment