Commit e3fb63d5 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

use PANGO_DISABLE_DEPRECATED for pango < 1.17.

2007-04-27  Sven Neumann  <sven@gimp.org>

	* configure.in: use PANGO_DISABLE_DEPRECATED for pango < 1.17.

	* plug-ins/common/sample_colorize.c: removed unused variable.

svn path=/trunk/; revision=22354
parent 1cc3041d
2007-04-27 Sven Neumann <sven@gimp.org>
* configure.in: use PANGO_DISABLE_DEPRECATED for pango < 1.17.
* plug-ins/common/sample_colorize.c: removed unused variable.
2007-04-27 Sven Neumann <sven@gimp.org>
* configure.in: depend on poppler-glib >= 0.4.1.
......@@ -468,13 +468,13 @@ PKG_CHECK_MODULES(PANGOFT2, pangoft2 >= pangoft2_required_version, :,
*** We require Pango with the optional support for FreeType2 compiled in.
*** See the file 'INSTALL' for more help.]))
AC_MSG_CHECKING([if Pango is version 1.15.0 or newer])
if $PKG_CONFIG --atleast-version=1.15.0 pango; then
have_pango_1_15=yes
AC_MSG_CHECKING([if Pango is version 1.17.0 or newer])
if $PKG_CONFIG --atleast-version=1.17.0 pango; then
have_pango_1_17=yes
else
have_pango_1_15=no
have_pango_1_17=no
fi
AC_MSG_RESULT($have_pango_1_15)
AC_MSG_RESULT($have_pango_1_17)
gimp_save_CFLAGS=$CFLAGS
CFLAGS="$PANGOFT2_CFLAGS $CFLAGS"
......@@ -1764,7 +1764,7 @@ if test "x$have_gtk_2_11" != "xyes"; then
CPPFLAGS="${CPPFLAGS} -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
fi
if test "x$have_pango_1_15" != "xyes"; then
if test "x$have_pango_1_17" != "xyes"; then
CPPFLAGS="${CPPFLAGS} -DPANGO_DISABLE_DEPRECATED"
fi
......
......@@ -1071,8 +1071,7 @@ level_in_events (GtkWidget *widget,
{
GdkEventButton *bevent;
GdkEventMotion *mevent;
gchar text[20];
double width, mid, tmp;
gdouble width, mid, tmp;
gint x, distance;
gint i;
gint update = FALSE;
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment