Commit 8e9b20e5 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

HACKING document the changed dependencies.

2005-12-28  Sven Neumann  <sven@gimp.org>

	* HACKING
	* INSTALL: document the changed dependencies.

	* configure.in
	* app/sanity.c: check for glib >= 2.8.2 at compile and run-time.

	* app/plug-in/plug-in.c: removed workaround for glib < 2.8.2.
parent cbea6791
2005-12-28 Sven Neumann <sven@gimp.org>
* HACKING
* INSTALL: document the changed dependencies.
* configure.in
* app/sanity.c: check for glib >= 2.8.2 at compile and run-time.
* app/plug-in/plug-in.c: removed workaround for glib < 2.8.2.
2005-12-28 Simon Budig <simon@gimp.org>
* tools/pdbgen/pdb/image.pdb
......
......@@ -84,10 +84,10 @@ anonymous CVS server:
The interesting modules and the suggested stable branches to use are:
* gimp
* glib (glib-2-6)
* atk (gnome-2-6)
* pango (pango-1-8)
* gtk+ (gtk-2-6)
* glib (glib-2-8)
* atk (gnome-2-12)
* pango (pango-1-10)
* gtk+ (gtk-2-8)
* libart_lgpl
* gtkhtml2
* intltool
......
......@@ -433,38 +433,13 @@ plug_in_open (PlugIn *plug_in)
argc = 0;
#if defined (G_OS_WIN32) && !GLIB_CHECK_VERSION (2, 8, 2)
/* In GLib < 2.8.2 on Win32 the argument vector passed to g_spawn*()
* should be in system codepage.
*
* Checking compile-time GLib version is the right thing to do.
* Even if running against GLib >= 2.8.2, code compiled against
* headers from GLib < 2.8.2 use backward-compatible functions that
* still take system codepage. Only code compiled against headers
* from GLib >= 2.8.2 use the g_spawn versions (that actually are
* called g_spawn*_utf8()) that take UTF-8.
*/
if (interp)
{
args[argc++] = g_locale_from_utf8 (interp, -1, NULL, NULL, NULL);
if (args[argc-1] == NULL)
g_error ("Interpreter %s is a file name with characters not in the system codepage. That doesn't work when GIMP is built against GLib 2.8.1 or earlier.", interp);
}
#else
if (interp)
args[argc++] = interp;
#endif
if (interp_arg)
args[argc++] = interp_arg;
#if defined (G_OS_WIN32) && !GLIB_CHECK_VERSION (2, 8, 2)
args[argc++] = g_locale_from_utf8 (plug_in->prog, -1, NULL, NULL, NULL);
if (args[argc-1] == NULL)
g_error ("Plug-in %s is a file name with characters not in the system codepage. That doesn't work when GIMP is built against GLib 2.8.1 or earlier.", plug_in->prog);
#else
args[argc++] = plug_in->prog;
#endif
args[argc++] = "-gimp";
args[argc++] = read_fd;
args[argc++] = write_fd;
......@@ -543,18 +518,6 @@ cleanup:
g_free (read_fd);
g_free (write_fd);
g_free (stm);
#if defined (G_OS_WIN32) && !GLIB_CHECK_VERSION (2, 8, 2)
argc = 0;
if (interp)
g_free (args[argc++]);
if (interp_arg)
argc++;
g_free (args[argc++]);
#endif
g_free (interp);
g_free (interp_arg);
......
......@@ -433,38 +433,13 @@ plug_in_open (PlugIn *plug_in)
argc = 0;
#if defined (G_OS_WIN32) && !GLIB_CHECK_VERSION (2, 8, 2)
/* In GLib < 2.8.2 on Win32 the argument vector passed to g_spawn*()
* should be in system codepage.
*
* Checking compile-time GLib version is the right thing to do.
* Even if running against GLib >= 2.8.2, code compiled against
* headers from GLib < 2.8.2 use backward-compatible functions that
* still take system codepage. Only code compiled against headers
* from GLib >= 2.8.2 use the g_spawn versions (that actually are
* called g_spawn*_utf8()) that take UTF-8.
*/
if (interp)
{
args[argc++] = g_locale_from_utf8 (interp, -1, NULL, NULL, NULL);
if (args[argc-1] == NULL)
g_error ("Interpreter %s is a file name with characters not in the system codepage. That doesn't work when GIMP is built against GLib 2.8.1 or earlier.", interp);
}
#else
if (interp)
args[argc++] = interp;
#endif
if (interp_arg)
args[argc++] = interp_arg;
#if defined (G_OS_WIN32) && !GLIB_CHECK_VERSION (2, 8, 2)
args[argc++] = g_locale_from_utf8 (plug_in->prog, -1, NULL, NULL, NULL);
if (args[argc-1] == NULL)
g_error ("Plug-in %s is a file name with characters not in the system codepage. That doesn't work when GIMP is built against GLib 2.8.1 or earlier.", plug_in->prog);
#else
args[argc++] = plug_in->prog;
#endif
args[argc++] = "-gimp";
args[argc++] = read_fd;
args[argc++] = write_fd;
......@@ -543,18 +518,6 @@ cleanup:
g_free (read_fd);
g_free (write_fd);
g_free (stm);
#if defined (G_OS_WIN32) && !GLIB_CHECK_VERSION (2, 8, 2)
argc = 0;
if (interp)
g_free (args[argc++]);
if (interp_arg)
argc++;
g_free (args[argc++]);
#endif
g_free (interp);
g_free (interp_arg);
......
......@@ -64,7 +64,7 @@ sanity_check_glib (void)
#define GLIB_REQUIRED_MAJOR 2
#define GLIB_REQUIRED_MINOR 8
#define GLIB_REQUIRED_MICRO 0
#define GLIB_REQUIRED_MICRO 2
mismatch = glib_check_version (GLIB_REQUIRED_MAJOR,
GLIB_REQUIRED_MINOR,
......
......@@ -40,7 +40,7 @@ m4_define([gimp_stable],
m4_define([gimp_full_name], [GNU Image Manipulation Program])
# required versions of other packages
m4_define([glib_required_version], [2.8.0])
m4_define([glib_required_version], [2.8.2])
m4_define([gtk_required_version], [2.8.0])
m4_define([gdk_pixbuf_required_version], [gtk_required_version])
m4_define([pangoft2_required_version], [1.10.0])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment