Commit 89ef9ca5 authored by Jehan's avatar Jehan Committed by Michael Natterer

INSTALL: add brushlib dependency info.

parent 77b04551
...@@ -79,7 +79,13 @@ header files installed. ...@@ -79,7 +79,13 @@ header files installed.
9. libpng, libjpeg and lcms are hard dependencies that can not be 9. libpng, libjpeg and lcms are hard dependencies that can not be
disabled. disabled.
10. You may want to install other third party libraries or programs 10. For mypaint brushes, GIMP requires brushlib (libmypaint) @LIBMYPAINT_REQUIRED_VERSION@,
compiled with GEGL support: `scons enable_gegl=true install`.
Brushlib repository is hosted at:
https://gitorious.org/mypaint/libmypaint/
11. You may want to install other third party libraries or programs
that are needed for some of the available plug-ins. We recommend that are needed for some of the available plug-ins. We recommend
to check that the following libraries are installed: libjasper, to check that the following libraries are installed: libjasper,
libpoppler-glib, libtiff, webkit, libmng, librsvg, libwmf, libaa libpoppler-glib, libtiff, webkit, libmng, librsvg, libwmf, libaa
...@@ -94,26 +100,28 @@ header files installed. ...@@ -94,26 +100,28 @@ header files installed.
but you are sure it is installed, you are advised to test your build but you are sure it is installed, you are advised to test your build
afterwards. afterwards.
11. The Python extension requires Python 2 development headers (@PYTHON2_REQUIRED_VERSION@ 12. The Python extension requires Python 2 development headers (@PYTHON2_REQUIRED_VERSION@
or newer) to be present. You will also need PyGTK and the or newer) to be present. You will also need PyGTK and the
respective development headers. respective development headers.
12. Configure GIMP by running the `configure' script. You may want 13. Configure GIMP by running the `configure' script. You may want
to pass some options to it, see below. to pass some options to it, see below.
13. Build GIMP by running `make'. The use of GNU make is recommended. 14. Build GIMP by running `make'. The use of GNU make is recommended.
If you need to tweak the build to make it work with other flavours If you need to tweak the build to make it work with other flavours
of make, we'd appreciate if you'd send us a patch with the changes. of make, we'd appreciate if you'd send us a patch with the changes.
14. Install GIMP by running `make install'. In order to avoid clashes 15. Install GIMP by running `make install'. In order to avoid clashes
with other versions of GIMP, we install a binary called gimp-@GIMP_APP_VERSION@. with other versions of GIMP, we install a binary called gimp-@GIMP_APP_VERSION@.
By default there's also a link created so that you can type 'gimp' By default there's also a link created so that you can type 'gimp'
to start gimp-@GIMP_APP_VERSION@. to start gimp-@GIMP_APP_VERSION@.
15. Summary of required packages and what version you need: 16. Summary of required packages and what version you need:
ATK: @ATK_REQUIRED_VERSION@ ATK: @ATK_REQUIRED_VERSION@
babl: @BABL_REQUIRED_VERSION@ babl: @BABL_REQUIRED_VERSION@
brushlib: @LIBMYPAINT_REQUIRED_VERSION@
libbzip2
cairo: @CAIRO_REQUIRED_VERSION@ cairo: @CAIRO_REQUIRED_VERSION@
Fontconfig: @FONTCONFIG_REQUIRED_VERSION@ Fontconfig: @FONTCONFIG_REQUIRED_VERSION@
freetype2: @FREETYPE2_REQUIRED_VERSION@ freetype2: @FREETYPE2_REQUIRED_VERSION@
...@@ -130,7 +138,7 @@ header files installed. ...@@ -130,7 +138,7 @@ header files installed.
pangocairo: @PANGOCAIRO_REQUIRED_VERSION@ pangocairo: @PANGOCAIRO_REQUIRED_VERSION@
zlib zlib
16. Summary of optional packages: 17. Summary of optional packages:
Package Name Version Feature Package Name Version Feature
......
...@@ -141,6 +141,7 @@ GEXIV2_REQUIRED_VERSION=gexiv2_required_version ...@@ -141,6 +141,7 @@ GEXIV2_REQUIRED_VERSION=gexiv2_required_version
LCMS_REQUIRED_VERSION=lcms_required_version LCMS_REQUIRED_VERSION=lcms_required_version
LIBPNG_REQUIRED_VERSION=libpng_required_version LIBPNG_REQUIRED_VERSION=libpng_required_version
LIBLZMA_REQUIRED_VERSION=liblzma_required_version LIBLZMA_REQUIRED_VERSION=liblzma_required_version
LIBMYPAINT_REQUIRED_VERSION=libmypaint_required_version
PANGOCAIRO_REQUIRED_VERSION=pangocairo_required_version PANGOCAIRO_REQUIRED_VERSION=pangocairo_required_version
BABL_REQUIRED_VERSION=babl_required_version BABL_REQUIRED_VERSION=babl_required_version
FONTCONFIG_REQUIRED_VERSION=fontconfig_required_version FONTCONFIG_REQUIRED_VERSION=fontconfig_required_version
...@@ -167,6 +168,7 @@ AC_SUBST(GEXIV2_REQUIRED_VERSION) ...@@ -167,6 +168,7 @@ AC_SUBST(GEXIV2_REQUIRED_VERSION)
AC_SUBST(LCMS_REQUIRED_VERSION) AC_SUBST(LCMS_REQUIRED_VERSION)
AC_SUBST(LIBPNG_REQUIRED_VERSION) AC_SUBST(LIBPNG_REQUIRED_VERSION)
AC_SUBST(LIBLZMA_REQUIRED_VERSION) AC_SUBST(LIBLZMA_REQUIRED_VERSION)
AC_SUBST(LIBMYPAINT_REQUIRED_VERSION)
AC_SUBST(PANGOCAIRO_REQUIRED_VERSION) AC_SUBST(PANGOCAIRO_REQUIRED_VERSION)
AC_SUBST(BABL_REQUIRED_VERSION) AC_SUBST(BABL_REQUIRED_VERSION)
AC_SUBST(FONTCONFIG_REQUIRED_VERSION) AC_SUBST(FONTCONFIG_REQUIRED_VERSION)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment