Commit 7d8dd66e authored by Jehan's avatar Jehan

INSTALL: update dependency information.

It seems we forgot to move librsvg from optional to mandatory
dependency. Also add RawTherapee as an optional runtime dependency.
Finally reorder the lists alphabetically.
parent ce894dfd
...@@ -129,13 +129,14 @@ header files installed. ...@@ -129,13 +129,14 @@ header files installed.
HarfBuzz @HARFBUZZ_REQUIRED_VERSION@ HarfBuzz @HARFBUZZ_REQUIRED_VERSION@
libbzip2 libbzip2
libjpeg libjpeg
libpng @LIBPNG_REQUIRED_VERSION@
liblzma @LIBLZMA_REQUIRED_VERSION@ liblzma @LIBLZMA_REQUIRED_VERSION@
libmypaint @LIBMYPAINT_REQUIRED_VERSION@ libmypaint @LIBMYPAINT_REQUIRED_VERSION@
libpng @LIBPNG_REQUIRED_VERSION@
libpoppler-glib @POPPLER_REQUIRED_VERSION@
librsvg @RSVG_REQUIRED_VERSION@
libtiff libtiff
Little CMS @LCMS_REQUIRED_VERSION@ Little CMS @LCMS_REQUIRED_VERSION@
pangocairo @PANGOCAIRO_REQUIRED_VERSION@ pangocairo @PANGOCAIRO_REQUIRED_VERSION@
libpoppler-glib @POPPLER_REQUIRED_VERSION@
poppler-data @POPPLER_DATA_REQUIRED_VERSION@ poppler-data @POPPLER_DATA_REQUIRED_VERSION@
zlib zlib
...@@ -143,24 +144,24 @@ header files installed. ...@@ -143,24 +144,24 @@ header files installed.
Package Name Version Feature Package Name Version Feature
libaa - ASCII art cairo-pdf @CAIRO_PDF_REQUIRED_VERSION@ PDF export
ExcHndl - Crash logs on Windows with Dr. MinGW
gs - ghostscript gs - ghostscript
webkit @WEBKIT_REQUIRED_VERSION@ Help browser & webpage libaa - ASCII art
libjasper - JPEG 2000 libjasper - JPEG 2000
libmng - MNG libmng - MNG
openexr @OPENEXR_REQUIRED_VERSION@ OpenEXR libwebp @WEBP_REQUIRED_VERSION@ WebP (built with --enable-libwebpmux and --enable-libwebpdemux)
cairo-pdf @CAIRO_PDF_REQUIRED_VERSION@ PDF export
python 2 @PYTHON2_REQUIRED_VERSION@ Python plug-ins
librsvg @RSVG_REQUIRED_VERSION@ SVG
libwmf @WMF_REQUIRED_VERSION@ WMF libwmf @WMF_REQUIRED_VERSION@ WMF
libXcursor - X11 Mouse Cursor libXcursor - X11 Mouse Cursor
libxpm - XPM libxpm - XPM
ExcHndl - Crash logs on Windows with Dr. MinGW openexr @OPENEXR_REQUIRED_VERSION@ OpenEXR
libwebp @WEBP_REQUIRED_VERSION@ WebP (built with --enable-libwebpmux and --enable-libwebpdemux) python 2 @PYTHON2_REQUIRED_VERSION@ Python plug-ins
webkit @WEBKIT_REQUIRED_VERSION@ Help browser & webpage
19. Summary of optional runtime dependencies: 19. Summary of optional runtime dependencies:
darktable >= 1.7, with lua support enabled for raw loading darktable >= 1.7, with lua support enabled for raw loading
RawTherapee >= 5.2 for raw loading
xdg-email for sending emails xdg-email for sending emails
sendmail for sending emails if --with-sendmail enabled sendmail for sending emails if --with-sendmail enabled
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment