Commit 6721b968 authored by Raphael Quinet's avatar Raphael Quinet Committed by Raphaël Quinet

Added a test for the version of intltool because some of the recent

2004-03-22  Raphael Quinet  <quinet@gamers.org>

	* autogen.sh: Added a test for the version of intltool because
	some of the recent versions are known to break the Tips file.
	This fixes bug #137502.  The message should be updated when a new
	version of libtool is released.
parent f87a2f64
2004-03-22 Raphaël Quinet <quinet@gamers.org>
* autogen.sh: Added a test for the version of intltool because
some of the recent versions are known to break the Tips file.
This fixes bug #137502. The message should be updated when a new
version of libtool is released.
2004-03-22 Simon Budig <simon@gimp.org> 2004-03-22 Simon Budig <simon@gimp.org>
* app/widgets/gimpdock.c: set the minimum of the * app/widgets/gimpdock.c: set the minimum of the
...@@ -133,6 +133,34 @@ else ...@@ -133,6 +133,34 @@ else
DIE=1 DIE=1
fi fi
# Special test for problematic versions of intltool. Details at:
# http://bugzilla.gnome.org/show_bug.cgi?id=137502
# Print a warning message, but do not exit.
INTLTOOL_BUG_MIN_VERSION=0.28
INTLTOOL_BUG_MAX_VERSION=0.31
echo -n "checking for intltool < $INTLTOOL_BUG_MIN_VERSION or > $INTLTOOL_BUG_MAX_VERSION ... "
if (intltoolize --version) < /dev/null > /dev/null 2>&1; then
VER=`intltoolize --version \
| grep intltoolize | sed "s/.* \([0-9.]*\)/\1/"`
if expr $VER \>= $INTLTOOL_BUG_MIN_VERSION > /dev/null; then
if expr $VER \<= $INTLTOOL_BUG_MAX_VERSION > /dev/null; then
echo "no (found version $VER)"
echo
echo " Versions of intltool between 0.28 and 0.31 are known to"
echo " generate incorrect XML output. Please consider using an"
echo " earlier version of intltool in order to avoid these"
echo " problems until a newer version of intltool is released."
else
echo "yes"
fi
else
echo "yes"
fi
else
echo "not found"
fi
if test "$DIE" -eq 1; then if test "$DIE" -eq 1; then
echo echo
echo "Please install/upgrade the missing tools and call me again." echo "Please install/upgrade the missing tools and call me again."
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment