Commit 5bd481a6 authored by Sven Neumann's avatar Sven Neumann Committed by Sven Neumann

HACKING updated for GTK+ 2.2.

2003-03-06  Sven Neumann  <sven@gimp.org>

	* HACKING
	* INSTALL: updated for GTK+ 2.2.
parent d395daa7
2003-03-06 Sven Neumann <sven@gimp.org>
* HACKING
* INSTALL: updated for GTK+ 2.2.
2003-03-05 Manish Singh <yosh@gimp.org>
* configure.in: require GTK+ 2.2. The 2.0.x series is no longer
......@@ -15,7 +20,7 @@
* app/gui/gui.c: free return value of gdk_get_display ()
* app/widgets/gimpcontainertreeview.c: use gtk_list_store_move_before ()
* app/widgets/gimpcontainertreeview.c: use gtk_list_store_move_before()
for reordering.
2003-03-05 Sven Neumann <sven@gimp.org>
......@@ -32,8 +32,8 @@ by running:
Basically this does the following for you:
cvsroot/gimp# aclocal-1.6; automake-1.6 -a; autoconf
cvsroot/gimp# glib-gettextize; intltoolize
cvsroot/gimp# aclocal-1.7; libtoolize; automake-1.7 -a;
cvsroot/gimp# autoconf; glib-gettextize; intltoolize
The above commands create the "configure" script. Now you
can run the configure script in cvsroot/gimp to create all
......@@ -53,9 +53,10 @@ autogen.sh and they will be passed on to configure.
autogen.sh by default passes --enable-gtk-doc to configure in order to
enable the creation of the GIMP API reference manuals in the devel-docs
directory. You will need a recent version of gtk-doc as well as a working
setup for handling DocBook XML. If you run into any problems here, you
can disable creation of the docs using --disable-gtk-doc with autogen.sh.
directory. You will need a recent version of gtk-doc as well as a
working setup for handling DocBook XML. If you run into any problems
here, you can disable creation of the docs by passing --disable-gtk-doc
to autogen.sh.
CVS
......@@ -72,10 +73,10 @@ anonymous CVS server:
The interesting modules and the suggested branches to use are:
glib (glib-2-0)
atk (atk-1-0)
pango (pango-1-0)
gtk+ (gtk-2-0)
glib (glib-2-2)
atk (gnome-2-2)
pango (pango-1-2)
gtk+ (gtk-2-2)
libart_lgpl
gtkhtml2
intltool
......
......@@ -7,10 +7,10 @@ There are some basic steps to building and installing the GIMP:
1. You need to have installed a recent version of pkg-config available
from http://www.freedesktop.org/software/pkgconfig/.
2. You need to have installed GTK version 2.0.0 or better. Do not try
to use an older GTK+ version (1.2.x), it will not work. GTK+-2.0
itself needs recent versions of GLib-2.0, Pango and ATK. Grab them
from ftp://ftp.gtk.org/. GTK+-2.0 and friends can be installed side
2. You need to have installed GTK version 2.2.0 or better. Do not try
to use an older GTK+ version (1.2.x), it will not work. GTK+-2.2
itself needs recent versions of GLib-2.2, Pango and ATK. Grab them
from ftp://ftp.gtk.org/. GTK+-2.2 and friends can be installed side
by side with GTK+-1.2.
3. We require PangoFT2, a Pango backend that uses FreeType2. Make sure
......@@ -36,7 +36,7 @@ There are some basic steps to building and installing the GIMP:
with an installed stable version of The GIMP, we install a binary
called gimp-1.3.
Please make sure you don't have any old GTK+-2.0, jpeg, etc. libraries
Please make sure you don't have any old GTK+-2.x, jpeg, etc. libraries
lying around on your system, otherwise configure may fail to find the
new ones.
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment